cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
14174
Views
1
Helpful
4
Replies
Ahmed M Alzaeem
Beginner

question about ether channel

hi ,

i want to ask about etherchannel  and especailly , why we type the command

#channel-protocol pagp

or

#channel-protocol lacp

i mean we can type desirable , auto ,on for pagp,

but why we need to type the command

#channel-protocol pagp

currently im confusing and see that the command

#channel-protocol pagp

has no need to be written .

plz advice about my issue

regards

1 ACCEPTED SOLUTION

Accepted Solutions
kcnajaf
Rising star

Hi,

Channel-protocol command is for setting whether you want to use Cisco's original, but proprietary, PAgP protocol for etherchanneling or you will use the IEEE standard LACP protocol.

Depending on protocol you keywords for the mode command will differ (LACP has active and passive where PAgP has desirable and auto).

The "channel-protocol" command is optional. Use the channel-protocol command only to restrict a channel to LACP or PAgP.

See the output below.

Switch_Test(config)#int range f0/21 - 22

Switch_Test(config-if-range)#channel-group 1 mode desirable

Creating a port-channel interface Port-channel 1

Switch_Test(config-if-range)#end

Switch_Test(config)#int range f0/23 - 24

Switch_Test(config-if-range)#channel-group 2 mode active

Creating a port-channel interface Port-channel 2

Switch_Test(config-if-range)#end

Switch_Test#sh etherchannel

                Channel-group listing:

                ----------------------

Group: 1

----------

Group state = L2

Ports: 2   Maxports = 8

Port-channels: 1 Max Port-channels = 1

Protocol:   PAgP

Group: 2

----------

Group state = L2

Ports: 2   Maxports = 16

Port-channels: 1 Max Port-channels = 16

Protocol:   LACP

Switch_Test#

Notice how the switch understand which protocol to use based on the mode selected.  However, when we select "on" as the mode, since both PAgP and LACP use the "on" as an option for the mode the switch now does not know which protocol to use.  See the output below.

Switch_Test(config)#int range f0/1 - 2

Switch_Test(config-if-range)#channel-group 3 mode on

Creating a port-channel interface Port-channel 3

Switch_Test(config-if-range)#end

Switch_Test#sh etherchannel

                Channel-group listing:

                ----------------------

Group: 1

----------

Group state = L2

Ports: 2   Maxports = 8

Port-channels: 1 Max Port-channels = 1

Protocol:   PAgP

Group: 2

----------

Group state = L2

Ports: 2   Maxports = 16

Port-channels: 1 Max Port-channels = 16

Protocol:   LACP

Group: 3

----------

Group state = L2

Ports: 2   Maxports = 8

Port-channels: 1 Max Port-channels = 1

Protocol:    -

Switch_Test#

If you set the protocol by using the channel-protocol command, the setting is not overridden by the channel-group interface configuration command.

Hope that helps

Regards

Najaf

Please rate when applicable or helpful !!!

View solution in original post

4 REPLIES 4
kcnajaf
Rising star

Hi,

Channel-protocol command is for setting whether you want to use Cisco's original, but proprietary, PAgP protocol for etherchanneling or you will use the IEEE standard LACP protocol.

Depending on protocol you keywords for the mode command will differ (LACP has active and passive where PAgP has desirable and auto).

The "channel-protocol" command is optional. Use the channel-protocol command only to restrict a channel to LACP or PAgP.

See the output below.

Switch_Test(config)#int range f0/21 - 22

Switch_Test(config-if-range)#channel-group 1 mode desirable

Creating a port-channel interface Port-channel 1

Switch_Test(config-if-range)#end

Switch_Test(config)#int range f0/23 - 24

Switch_Test(config-if-range)#channel-group 2 mode active

Creating a port-channel interface Port-channel 2

Switch_Test(config-if-range)#end

Switch_Test#sh etherchannel

                Channel-group listing:

                ----------------------

Group: 1

----------

Group state = L2

Ports: 2   Maxports = 8

Port-channels: 1 Max Port-channels = 1

Protocol:   PAgP

Group: 2

----------

Group state = L2

Ports: 2   Maxports = 16

Port-channels: 1 Max Port-channels = 16

Protocol:   LACP

Switch_Test#

Notice how the switch understand which protocol to use based on the mode selected.  However, when we select "on" as the mode, since both PAgP and LACP use the "on" as an option for the mode the switch now does not know which protocol to use.  See the output below.

Switch_Test(config)#int range f0/1 - 2

Switch_Test(config-if-range)#channel-group 3 mode on

Creating a port-channel interface Port-channel 3

Switch_Test(config-if-range)#end

Switch_Test#sh etherchannel

                Channel-group listing:

                ----------------------

Group: 1

----------

Group state = L2

Ports: 2   Maxports = 8

Port-channels: 1 Max Port-channels = 1

Protocol:   PAgP

Group: 2

----------

Group state = L2

Ports: 2   Maxports = 16

Port-channels: 1 Max Port-channels = 16

Protocol:   LACP

Group: 3

----------

Group state = L2

Ports: 2   Maxports = 8

Port-channels: 1 Max Port-channels = 1

Protocol:    -

Switch_Test#

If you set the protocol by using the channel-protocol command, the setting is not overridden by the channel-group interface configuration command.

Hope that helps

Regards

Najaf

Please rate when applicable or helpful !!!

hi  najaf ,

thkns forur reply ,

now i concluded that the channel-protocol command is needed whenwe choose the moe to be on

in this case the no negotioation so , we have to type

channel-protocol  command .

and also i concluded that channel-protocol command   overides the the mode negotation

mean if there was both , negotation and channel-protcol command , the etherchannel will get the protocol typed in

channel-protcol command

plz  give me an Ack , if my two points above were correct .

regrads

Hi,

My mistake...

I didnt realise deleting one of my replies will delete all other replies behind it even though i have selected to delete only one post:-( Sorry for that.

Like Peter said "mode on" can not be used with channel protocol command. When you select "mode on" etherchannel will form unconditionally with out any protocol (ie without PagP or LACP protocols).

Coming back to your above two points...

1) I have tested this now on a live switch and we can not have "mode on" and "channel protocol" under the same interface. The switch will through the error message as below if you try to configure both under same interface.

Switch(config)#int range fas 0/23 -24

Switch(config-if-range)#channel-group 1 mode on

Switch(config-if-range)#channel-protocol lacp

% Range command terminated because it failed on FastEthernet0/23

Switch(config-if-range)#

00:53:36: %EC-5-ERRPROT2: Command rejected: the interface Fa0/23 is already part of a channel with a different type of protocol enabled

2) For the second point if you configure the switch to negotiate  (for example let us assume we configured switch port to negotiate to PagP using desirable at one end and auto at other end) and on top of this you try applying the "channel-protocol" the switch would again reject this with below error message.

Switch(config)#int range fas 0/23- 24

Switch(config-if-range)#channel-group 1 mode desirable

Switch(config-if-range)#channel-protocol pagp

Command rejected (the interface Fa0/23 is ): is already part of a channel with a different type of protocol enabled

% Range command terminated because it failed on FastEthernet0/23

Switch(config-if-range)#

Switch(config-if-range)#channel-protocol lacp

Command rejected (the interface Fa0/23 is ): is already part of a channel with a different type of protocol enabled

% Range command terminated because it failed on FastEthernet0/23

Switch(config-if-range)#

On the other hand if the interface already have the "channel-protocol" set (assume the channel protocol is configured to PagP) and if we try to set the group for LACP below error message will be generated by switch

Switch(config)#int range fas 0/23- 24

Switch(config-if-range)#channel-protocol pagp

Switch(config-if-range)#channel-group 1 mode passive

% Range command terminated because it failed on FastEthernet0/23

Switch(config-if-range)#

01:47:55: %EC-5-ERRPROT: Channel protocol mismatch for interface Fa0/23 in group 1: the interface can not be added to the channel group

Switch(config-if-range)#

So in short we can see here that "channel-protocol" command does not have much role...

Hope this helps.

Regards

Najaf

Peter,

Thanks a lot for your explantion which made me to lab this up :-)

mahmoodmkl
Rising star

Hi
the rther channel will form if the other side also configured with mode on.
the on mode is like statically configuring the ports

Sent from Cisco Technical Support iPhone App