06-28-2007 11:02 AM - edited 03-05-2019 05:01 PM
We are replacing our core network at our central office with a new Catalyst 4507. Our current network consists of several 3500-series switches along with a 4908 Layer-3 switch. The 4908 switches among multiple buildings on different subnets. Those are all being replaced with the 4500.
I am running into a configuration issue with converting the config from the 4908 to the 4500. The 4908 configures more like a router with subinterfaces. The 4500 apparently does not support that setup. How would I duplicate this setup on the 4500:
interface GigabitEthernet2
description SBO
no ip address
no ip directed-broadcast
!
interface GigabitEthernet2.1
description SBO Data VLAN
encapsulation dot1Q 1 native
ip address 192.168.1.1 255.255.255.0
ip helper-address XXXX
no ip directed-broadcast
interface GigabitEthernet2.2
description SBO Voice VLAN
encapsulation dot1Q 2
ip address 192.168.101.1 255.255.255.0
ip helper-address XXXX
no ip directed-broadcast
We use VLANs 1 & 2 on both the remote sites and the site where the 4500 is located, but they are not the same IP subnet, so I do not think logical L3 routing will work without renumbering the VLANs on the far end. The only other option I could come up with is to configure separate physical interfaces for the Data and Voice VLANs, but I am out of gigabit ports on the far end of this link. I hope I am just missing a simple solution.
Thanks,
Jason
06-28-2007 11:26 AM
Hi Jason
I'm not sure i fully understand your layout.
If you want to translate the subinterface config on your 4908 to a 4500 config you need to use SVI's on the 4500 ie.
interface vlan 1
description SBO Data VLAN
ip address 192.168.1.1 255.255.255.0
ip helper-address XXXX
no ip directed-broadcast
interface vlan 2
description SBO Voice VLAN
ip address 192.168.101.1 255.255.255.0
ip helper-address XXXX
no ip directed-broadcast
And then you would make the gig2 interface a trunk link.
Does this answer your question ?
Jon
06-28-2007 11:36 AM
Friend,
the toplogy you were using is called router on a stick wherein you create subinterfaces for each vlan for intervlan routing.
as jon said, you have to use SVI in case of 4500.
http://www.cisco.com/en/US/docs/switches/lan/catalyst4500/12.2/25ewa/configuration/guide/vlans.html
HTH, rate if it does
Narayan
06-28-2007 11:36 AM
Jon,
The problem is that I am already using VLANs 1 & 2 in the building where the 4500 is physically located. The VLAN 1 & 2 at that building are not on the same subnet as VLAN 1 & 2 in the other building. The 4908 kept them separate with the L3 setup I posted above.
Jason
06-29-2007 06:50 AM
Hi Jason
Must admit i am still confused, bit like Samuel i think :-)
Could you elaborate on the actual topology of your main site, interconnects between your sites and how you are trying to connect up your sites (layer 2/layer 3) etc. so we can help you more.
Jon
06-28-2007 11:33 AM
Hi Jason,
Your configuration could implemented as you want i.e. 1 physical Interface to support both types of traffic (Data and Voice).
Please provide us the sh version of the switch along with the sh module (just to see the details of IOS and Sup and modules).
You should be able to configure the Switch as you have planned.
Kind Regards,
Wilson Samuel
06-28-2007 11:38 AM
Wilson,
I hope you are correct. The show output is below:
show version:
Cisco IOS Software, Catalyst 4000 L3 Switch Software (cat4000-I9S-M), Version 12.2(25)EWA8, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Wed 24-Jan-07 14:38 by pwade
Image text-base: 0x10000000, data-base: 0x114EECF0
ROM: 12.2(20r)EW1
Dagobah Revision 226, Swamp Revision 32
SBOA-CoreS1 uptime is 2 hours, 43 minutes
Uptime for this control processor is 2 hours, 43 minutes
System returned to ROM by reload
System image file is "bootflash:"
cisco WS-C4507R (MPC8245) processor (revision 14) with 524288K bytes of memory.
Processor board ID FOX11070A6C
MPC8245 CPU at 333Mhz, Supervisor IV
Last reset from Reload
3 Virtual Ethernet interfaces
116 Gigabit Ethernet interfaces
403K bytes of non-volatile configuration memory.
Configuration register is 0x2101
show module:
Chassis Type : WS-C4507R
Power consumed by backplane : 40 Watts
Mod Ports Card Type Model Serial No.
---+-----+--------------------------------------+------------------+-----------
1 2 Supervisor IV 1000BaseX (GBIC) WS-X4515 JAE11097SEV
3 48 10/100/1000BaseT (RJ45)V, Cisco/IEEE WS-X4548-GB-RJ45V JAE1115CPC1
4 48 10/100/1000BaseT (RJ45) WS-X4548-GB-RJ45 JAE1112A9P3
7 18 1000BaseX (GBIC) WS-X4418-GB JAE11043HP3
M MAC addresses Hw Fw Sw Status
--+--------------------------------+---+------------+----------------+---------
1 001b.5348.4380 to 001b.5348.4381 5.3 12.2(20r)EW1 12.2(25)EWA8 Ok
3 001b.545d.cff0 to 001b.545d.d01f 3.2 Ok
4 001b.53e7.ea30 to 001b.53e7.ea5f 2.4 Ok
7 001a.6d5d.a328 to 001a.6d5d.a339 1.3 Ok
Mod Redundancy role Redundancy mode Redundancy status
----+-------------------+-------------------+-------------------
1 Active Supervisor Non redundant Active
Thanks,
Jason
06-28-2007 11:42 AM
Hi Jason,
Thanks for the information.
Please provide a bit more detail on the below points:-
1. Why are you trying to configure Voice cum Data ports on the switch? Is it for the Cisco IP Telephoney implementation?
2. If its not, please specify the desired implmentation of the network.
Regards,
Wilson Samuel;
06-28-2007 11:48 AM
Yes, we use Cisco phones at all sites. The site in question does not have their own router locally, so we used the 4908 to route their data (VLAN1) and voice (VLAN2) networks and to provide DHCP relaying to both VLANs.
Jason
06-28-2007 12:04 PM
Hi Jason,
We have had a similar settings on 3750 Switches, and I'm pasting config from the same. I'm sure this should work on 4500 also.
And as far as the DHCP is concerned ( we had Win2k Server, and had 2 different Scopes for the same) its well taken care by a single entry for the ip helper address command.
interface FastEthernet1/0/3
switchport trunk encapsulation dot1q
switchport trunk native vlan 1
switchport mode trunk
switchport voice vlan 2
no ip address
mls qos trust device cisco-phone
mls qos trust cos
no mdix auto
spanning-tree portfast
alternativly you may like to refer the Config Guide for the 12.25 EWA on 4500 for any further information.
http://www.cisco.com/en/US/docs/switches/lan/catalyst4500/12.2/18ew/configuration/guide/voice.html
HTH,
Please rate if it helps,
Kind Regards,
Wilson Samuel
06-28-2007 12:14 PM
Thanks for the help, but that is just a standard L2 config for a switchport.
Jason
06-29-2007 06:31 AM
Hi Jason,
Sorry for not being able to understand your requirement.
Could you please specify exactly what are you looking forward for?
Regards,
Wilson Samuel
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide