cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
26008
Views
30
Helpful
18
Replies
softcake20
Beginner

recovering switch with wrong BAUD rate

Hi,

it seem's that i made a mistake when typing the BAUD rate of a 2960-Switch in rommon.

I can't start the switch now, because there is no image on it (because I deleted it before) and the baud-rate has wrong settings. When connecting via console cable i can't see anything (except some strange hieroglyphics) when starting. I tried all the speeds in teraterm... without success.

what can i do, to recover the switch back?

regards

peter

18 REPLIES 18
Reza Sharifi
Hall of Fame Expert

Hi,

Try following this link to reset the switch

To reset the switch in one of these ways:

• Press the Reset button on the rear panel.

• Press and hold the Mode button. The switch LEDs begin blinking after about

3 seconds. Continue holding down the Mode button. The LEDs stop blinking

after 7 more seconds, and the switch reboots.

http://www.cisco.com/en/US/docs/switches/lan/catalyst2960c_3560c/hardware/quick/guide/all_languages/2960c_3560c_gsg_eng.pdf

HTH

Thanks for your answer, but it's an 2960S-Switch... there is only a "mode-button" no reset-button.

Pressing the button for 3-10 seconds or more has no effect... can't still see anything on the console screen.

I tested it several times...

Peter

Do you have any memory of what you typed when you typed the baud wrong? If we knew that we might be able to determine what it things the baud rate is.

At the risk of seeming to be picky, can you tell us specifically all of the baud rates that you have tried?

It has been a while since I used teraterm and I do not remember some of its details very well. But I know that for some terminal emulators when you change the baud setting for a console connection you need to stop and re-start the emulator. Can I suggest that you try this with teraterm that you stop and re-start the software each time you have made a change in the speed?

HTH

Rick

HTH

Rick

hi Richard,

I have the same issue on a 2960s.

My collegue put in the baudrate (in bootrom) using "set baud 230400" for xmodem and IOS recovery purposes. According to the manual this is not a supported value but there's no syntax check by the bootrom. So he was able to set this value, but the bootloader is not using 230400, but another unknown baudrate. I've tried all common speeds that are accepted according to the manual with no luck.

The 2960s doesnt have any way to reset the bootrom environment values (there's no jumper on the inside) and there's no way you can reset the console baud rate to 9600 afaik? The switch has a non-bootable IOS image, so i really wonder what we can do. The boot variables are stored outside of the flash: content. I'm basicly looking for a way to reset the bootrom values on a 2960s so the console baudrate is set back to 9600....

Any idea?

Your help is much appreciated and kudo's will be given....

you need a cable USB-to-COM (not cisco usb console) with support variable baud rate.

Use putty program to conntec cisco RJ-45 console port and set Serial Speed to 170000

(try any speed from 169300 to 179000) .

its a cisco bug

paolo bevilacqua
Hall of Fame Master

Try all the speeds again, with 1 and 2 stop bits. If still no luck, try even/odd/none parity.

already tried this.

nothing to see in screen.

i think, the baud rate is more than 115200

Peter, did you have any success with the 2960?

I got myself in the same 'movie'....

Wouter Prins
Beginner

The only way to recover this is an RMA/AVR. There are no other procedures to recover the 2960s unfortunatly.

shakir1404
Beginner

Andrey Kravtsov had given an awesome solution to this. Thank you.

I think most people missed it......

We had the same issue, by giving the unsupported baud rate on 2960s to 230400, which ended up in not connecting, or no prompt....

As suggested by Andrey, the switch gave the rommon prompt by setting the baud rate to 179000 on putty... later we changed the baud rate back to 115200, and it worked through hyperterminal....

so no need for RMA....

Hello all,

Thanks for input, i am also set un entsupported baud rate 230400 on 2960s, then rommon prompt showing on 179000 but i can not enter any input on this. Please help

Set putty to 230400. connect via usb-serial cable to RJ 45 Console port. You should be good to go.

My switch c2960x has a corrupted ios file and i want to recover it by using xmodem, but the problem is that, the switch is not responding to enter on the ramon mode (switch: mode). Can any one help me what to do on this please? The switch stops as below screen shot.

 

CPU rev: B
Board rev: 5
Testing DataBus...
Testing AddressBus...
Testing Memory from 0x00000000 to 0x1fffffff...|

Mongi

Hi,

 

I have made same mistake as many others in this thread.

 

And i've got some console visibility after setting baud rate to 179000, but there were still some illegal characters and i wasn't able to type anything in console itself. I've spend around one day to figure out correct console port settings. So i've set data bits to 7 and stop bits to 2 (while defaults are 8 and 1) and now i'm getting proper output and can interact with the console.

 

Thanks everyone for suggestions!

Added one day later:

 

Actually no command was recognized by rommon - it kept replying "unknown cmd"...

But eventually i found solution - i had tried 4 different usb to com adapters and only last one worked, so i connected over 179000 baud and with 8N1.