05-11-2017 10:43 AM - edited 03-08-2019 10:32 AM
I'm running a test lab with simple routing redistribution. Basically the network looks like this:
OSPF router in area 0 ----- OSPF ASBR with one leg in OSPF area 0 and the other leg in EIGRP ---- EIGRP router
The OSPF ASBR is doing bidirectional route redistribution.
What I noticed is that the ASBR is not redistributing the connected interfaces enabled in EIGRP into OSPF.
Partial configuration of the ASBR:
interface Loopback0
ip address 192.168.0.12 255.255.255.255
interface GigabitEthernet0/1.510
encapsulation dot1Q 510
ip address 192.168.251.12 255.255.255.0
interface GigabitEthernet0/2.310
encapsulation dot1Q 310
ip address 192.168.231.12 255.255.255.0
router eigrp 100
network 192.168.0.12 0.0.0.0
network 192.168.231.0
redistribute ospf 100 metric 100000 1 255 1 1500
router ospf 100
router-id 192.168.0.12
redistribute eigrp 100 subnets
network 192.168.251.0 0.0.0.255 area 0
Since both 192.168.0.12/32 and 192.168.231.0/24 are local interface, although EIGRP is enabled on these interfaces, the router does not redistribute the two subnets into OSPF. "show ip ospf database" does not show these Type-5 LSA's.
C 192.168.0.12 is directly connected, Loopback0
C 192.168.231.0/24 is directly connected, GigabitEthernet0/2.310
I understand that these are not EIGRP routes in the routing table, as such the router doesn't redistribute them into OSPF from EIGRP. However, when I replaced the router with another one, running the same configuration, the two locally connected EIGRP interfaces are redistributed automatically without adding the command "redistribute connected subnets" command under OSPF process.
Being puzzled by this behavior, I did some research and understand that Cisco calls the behavior with the 2nd router "indirect redistribution". Although they are not EIGRP routes in the routing table, they are still redistributed because they are local EIGRP enabled interfaces. But the question is why the first router doesn't do the "indirect redistribution"? My guess is because of the different IOS version, or I'm hitting a bug? Or anything in my configuration is incorrect?
The 1st router in the above mentioned test is a Cisco 2911 running IOS 15.1(4)M3. The 2nd router is Cisco 4331 running IOS 15.5(3)S4b.
Did anyone see this behavior as well? Is it expected? Thanks in advance.
Solved! Go to Solution.
05-11-2017 04:17 PM
Thank you
It is not a normal behavior, it could be a bug on the IOS. I lab it and there are no problems.
What about if you create the eigrp adjacency using the hosts instead the entire subnet for example:
router eigrp 100
network 192.168.251.2 0.0.0.0
05-11-2017 12:31 PM
Hi
You dont see the subnet 192.168.251.0 255.255.255.0 on the Router 1 as E2, is that correct? your config is fine, It should receive the network between router 2 and 3 into from EIGRP into OSPF unless you have any filtering method applied.
Could you please share the configuration of the 3 routers?
05-11-2017 01:00 PM
Hi Julio
No, 192.168.251.0/24 is not shown as E2, but as a Net Link, since it's an OSPF internal connection. It also has no problem to receive redistributed EIGRP routes from router 3. My only challenge is with that 2911 (router 2), the local connected interfaces on EIGRP side of router 2 are not redistributed into OSPF without using "redistribute connected" command. But with the 4331 as router 2, they are "indirectly" redistributed without additional configuration.
I will post the configs later today when I get back to office.
Thanks.
05-11-2017 01:10 PM
Thanks,
Try this config
Router 1 (OSPF)
router ospf 100
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
Router 2 ( ASBR)
router eigrp 100
redistribute ospf 100 metric 10000 10 255 1 1500
network 192.168.251.0
no auto-summary
!
router ospf 100
log-adjacency-changes
redistribute eigrp 100 subnets
network 192.168.231.0 0.0.0.255 area 0
Router 3 (EIGRP)
router eigrp 100
network 0.0.0.0
no auto-summary
Redistribute connected will advertise the connected subnets except the specify into the routing protocol as external. Please try the config and keep me posted.
:-)
05-11-2017 03:56 PM
Here're the partial router configurations:
Router 1 (OSPF)
router ospf 100
router-id 192.168.0.10
log-adjacency-changes
network 192.168.0.10 0.0.0.0 area 0
network 192.168.251.0 0.0.0.255 area 0
Router 2 (OSPF ASBR)
router ospf 100
router-id 192.168.0.12
redistribute eigrp 100 subnets
network 192.168.251.0 0.0.0.255 area 0
!
router eigrp 100
network 192.168.0.12 0.0.0.0
network 192.168.231.0
redistribute ospf 100 metric 100000 1 255 1 1500
(no auto-summary command is default and hidden with this version of IOS)
Router 3 (EIGRP)
router eigrp 100
network 192.168.0.14 0.0.0.0
network 192.168.231.0
no auto-summary
These are pretty much the same as your suggested configurations, except a few more loopback interfaces.
Routing table on Router 1 (it's actually a layer 3 switch)
O E2 192.168.0.14 [110/20] via 192.168.251.12, 15:46:44, Vlan510
C 192.168.0.10 is directly connected, Loopback0
C 192.168.251.0/24 is directly connected, Vlan510
Routing table on Router 2
O 192.168.0.10 [110/2] via 192.168.251.10, 15:54:08, GigabitEthernet0/1.510
C 192.168.0.12 is directly connected, Loopback0
C 192.168.231.0/24 is directly connected, GigabitEthernet0/2.310
L 192.168.231.12/32 is directly connected, GigabitEthernet0/2.310
C 192.168.251.0/24 is directly connected, GigabitEthernet0/1.510
L 192.168.251.12/32 is directly connected, GigabitEthernet0/1.510
D 192.168.0.14 [90/130816] via 192.168.231.14, 3d07h, GigabitEthernet0/2.310
Routing table of router 3
D EX 192.168.0.10 [170/28416] via 192.168.231.12, 15:58:08, FastEthernet0/1.310
C 192.168.231.0/24 is directly connected, FastEthernet0/1.310
D EX 192.168.251.0/24 [170/28416] via 192.168.231.12, 15:58:06, FastEthernet0/1.310
C 192.168.0.14 is directly connected, Loopback0
D 192.168.0.12 [90/156160] via 192.168.231.12, 3d07h, FastEthernet0/1.310
As you can see, router 1 doesn't learn 192.168.0.12/32 and 192.168.231.0/24 through OSPF, if I don't configure "redistribute connected" under OSPF. I'm fine with adding that command, but it makes me wonder why the newer ISR 4331 does not need it.
05-11-2017 04:17 PM
Thank you
It is not a normal behavior, it could be a bug on the IOS. I lab it and there are no problems.
What about if you create the eigrp adjacency using the hosts instead the entire subnet for example:
router eigrp 100
network 192.168.251.2 0.0.0.0
05-11-2017 04:29 PM
Which version of IOS do you run?
I will do some more tests with older IOS.
05-11-2017 05:34 PM
Hi
Im using three 1841 (15.0.1M), have you tried in GNS3?
05-11-2017 06:27 PM
Update:
After rebooting router 2 (the ISR 2911), the issue is gone.
First I tried by removing all routing configurations on all 3 routers, and adding them back. No luck.
Then isolating router 2 by disconnecting the links. I'm still not seeing the loopback interface being redistributed from EIGRP to OSPF.
The last attempt, which was to reboot router 2, fixed it.
So looks like I did hit a bug.
Thanks guys for running the tests on your system and confirming your findings. That definitely helped!
05-11-2017 06:40 PM
It was a pleasure :-)
Have a great day
05-11-2017 03:25 PM
Hello,
on a side note, this might as well be linked to the IOS version you were running on your 2911. It works perfectly in GNS3 with IOS 15.2(4)S5.
It might be interesting to see the EIGRP topology table (show ip eigrp topology) with and without the 'redistributed connected' command.
05-11-2017 04:01 PM
Hi Georg
That's what I suspect, too. I tried another router with newer IOS 15.2, it supports "indirect redistribution", too. I'm just curious if this is true, in case I missed anything.
EIGRP topology table on router 2 shows the two subnets as local connected interfaces, no matter if I have "redistributed connected" or not under OSPF.
OSPF database only shows the two subnets when I add "redistribute connected".
thanks.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide