01-17-2018 06:41 PM - edited 03-08-2019 01:27 PM
Current ConnectionPLANNED CONNECTION
Hello Guru's
I need your help about this network diagram,
Currently we have two ISP provider, (ISP-1 ISP-2 as shown in the drawing ) and functioning separately.
To optimize both ISP I want to make it redundant.
My plan set up is to connect router 0 and router 2 as well as Router 1 and Router 3 so that when one hardware ( router ) fail there are still a backup.
I am not very technical person about networking that’s why I decided to post my concern here because I believe that there are so many gurus member here that can help.
I need your advice on what would be the protocol/configuration that I need to apply to make my network setup happen.
Currently the hardware’s ( Router 0, 1, 2 and 3 ) are configured as follow. Very simple configuration but its working fine without any issue.
ROUTER0#
ROUTER0#show run
ROUTER0#show running-config
Building configuration...
Current configuration : 770 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname ROUTER0
!
interface FastEthernet0/0
ip address 172.17.32.200 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface Serial2/0
ip address 161.126.44.193 255.255.255.252
!
router eigrp 7620
network 161.126.0.0
network 172.17.0.0
no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.17.32.1
!
no cdp run
!
line con 0
line vty 0 4
login
!
end
==========================================================================================================
ROUTER1#show running-config
Building configuration...
Current configuration : 753 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname ROUTER1
!
interface FastEthernet0/0
ip address 192.168.3.200 255.255.255.0
duplex auto
speed auto
!
interface Serial2/0
ip address 161.126.44.194 255.255.255.252
clock rate 2000000
!
router eigrp 7620
network 161.126.0.0
network 192.168.3.0
no auto-summary
!
ip classless
!
no cdp run
!
line con 0
line vty 0 4
login
!
end
ROUTER2#show running-config
Building configuration...
Current configuration : 847 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname ROUTER2
!
interface FastEthernet0/0
ip address 192.168.0.200 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/0.1
encapsulation dot1Q 10
ip address 192.168.6.10 255.255.255.0
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface Serial2/0
ip address 161.126.44.221 255.255.255.252
!
interface Serial3/0
no ip address
shutdown
!
interface FastEthernet4/0
no ip address
shutdown
!
interface FastEthernet5/0
no ip address
shutdown
!
router eigrp 7609
network 161.126.0.0
network 192.168.0.0
network 192.168.6.0
no auto-summary
!
ip classless
!
no cdp run
!
line con 0
line vty 0 4
login
!
end
ROUTER3#show running-config
Building configuration...
Current configuration : 753 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname ROUTER3
!
interface FastEthernet0/0
ip address 192.168.2.200 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface Serial2/0
ip address 161.126.44.222 255.255.255.252
clock rate 2000000
!
interface Serial3/0
no ip address
shutdown
!
interface FastEthernet4/0
no ip address
shutdown
!
interface FastEthernet5/0
no ip address
shutdown
!
router eigrp 7609
network 161.126.0.0
network 192.168.2.0
no auto-summary
!
ip classless
!
no cdp run
!
line con 0
line vty 0 4
login
!
end
01-17-2018 11:43 PM
Hi,
How many public IPs allocated you by ISP? Is ISP providing BGP synchronizing (neighbourship)?
Regards,
Deepak Kumar
01-18-2018 12:00 AM
01-18-2018 12:48 AM
01-18-2018 05:40 AM
You will need minimally a /24 (class C) block of registered IP addresses and an ARIN administered BGP ASN. If you have the /24 already, then you need to apply to ARIN for the BGP ASN. If you do not have the required addressing, you would need to obtain such a block from one of the ISP's and a letter of authorization from them the indicated address can be advertised to a secondary ISP. Once you have obtained the class C block from one of the ISP's, then you can get the ASN from ARIN.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide