12-06-2012 07:31 PM - edited 03-07-2019 10:26 AM
I started using RIPv2 on Packet Tracer. I got two subnets to connect with two routers. After I completed that, I decided to add a third router. Could someone help me setup the Routing Table for atleast R3???
If you need more info, let me know.
Thanks!
Solved! Go to Solution.
12-06-2012 08:31 PM
Hi Mike,
I'm not able to access R1 and R3 as they are password protected :-(
I think the problem you have got here is you have wrong ip address on the interfaces. The point to point interface between R3 to R1&R2 should have ip's from the same subnet.
But in your configuration R3's (S0/0/0 - 192.168.44.14/29) is connected to R1's (S0/0/0-192.168.44.1/29). Both these ranges are two different subnet . So you will have to reconfigure either of the interface. This holds good for the connection to the R2 router as well. Please try modifying configuration as below.
On R3
conf terminal
interface Serial0/0/0
no ip address
!
interface Serial0/0/1
no ip address
!
interface Serial0/0/0
ip address 192.168.44.3 255.255.255.248
!
interface Serial0/0/1
ip address 192.168.45.3 255.255.255.248
!
router rip
no auto-summary
On R2
interface Serial0/0/0
ip address 192.168.45.2 255.255.255.248
!
router rip
no auto-summary
On R1
router rip
no auto-summary
Hope this helps.
Najaf
12-06-2012 08:31 PM
Hi Mike,
I'm not able to access R1 and R3 as they are password protected :-(
I think the problem you have got here is you have wrong ip address on the interfaces. The point to point interface between R3 to R1&R2 should have ip's from the same subnet.
But in your configuration R3's (S0/0/0 - 192.168.44.14/29) is connected to R1's (S0/0/0-192.168.44.1/29). Both these ranges are two different subnet . So you will have to reconfigure either of the interface. This holds good for the connection to the R2 router as well. Please try modifying configuration as below.
On R3
conf terminal
interface Serial0/0/0
no ip address
!
interface Serial0/0/1
no ip address
!
interface Serial0/0/0
ip address 192.168.44.3 255.255.255.248
!
interface Serial0/0/1
ip address 192.168.45.3 255.255.255.248
!
router rip
no auto-summary
On R2
interface Serial0/0/0
ip address 192.168.45.2 255.255.255.248
!
router rip
no auto-summary
On R1
router rip
no auto-summary
Hope this helps.
Najaf
12-06-2012 08:58 PM
I will try your advice out in the morning! Thank You!
12-10-2012 03:33 PM
I tried what you suggested, with no luck. So, I might have the interfaces correct now, but I still have to set up new routing tables now? Since I switched the interfaces, my old routing tables wouldn't work...? And I'm sorry, the passwords for my routers are "cisco" and "class".
R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#router rip
R1(config-router)#no auto-summary
R1(config-router)#end
R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#int S0/0/0
R2(config-if)#ip address 192.168.45.2
% Incomplete command.
R2(config-if)#ip address 192.168.45.2 255.255.255.248
R2(config-if)#exit
R2(config)#router rip
R2(config-router)#no auto-summary
R2(config-router)#end
R3#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R3(config)#int S0/0/0
R3(config-if)#no ip address
R3(config-if)#exit
R3(config)#int
% Incomplete command.
R3(config)#interface Serial0/0/0
R3(config-if)#exit
R3(config)#int S0/0/1
R3(config-if)#no ip address
R3(config-if)#exit
R3(config)#int S0/0/0
R3(config-if)#ip address 192.168.44.3 255.255.255.248
R3(config-if)#exit
R3(config)#int S0/0/1
R3(config-if)#ip address 192.168.45.3 255.255.255.248
R3(config-if)#exit
R3(config)#router rip
R3(config-router)#no auto-summary
R3(config-router)#end
12-10-2012 03:51 PM
I GOT IT!! :-)
I setup the new routing tables and I got a reply. I'm still having troubles understanding what IP addr goes to what interface on what router.... :-\
192.168.44.0/29 is subnetted, 2 subnets
C 192.168.44.0 is directly connected, Serial0/0/0
C 192.168.44.8 is directly connected, FastEthernet0/0
192.168.45.0/29 is subnetted, 1 subnets
R 192.168.45.0 [120/1] via 192.168.44.3, 00:00:15, Serial0/0/0
220.16.5.0/27 is subnetted, 1 subnets
R 220.16.5.0 [120/1] via 192.168.44.3, 00:00:15, Serial0/0/0
R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 192.168.44.0
R1(config-router)#network 192.168.44.8
R1(config-router)#network 192.168.45.0
R1(config-router)#network 220.16.5.0
R1(config-router)#end
140.49.0.0/22 is subnetted, 1 subnets
C 140.49.8.0 is directly connected, FastEthernet0/0
192.168.45.0/29 is subnetted, 1 subnets
C 192.168.45.0 is directly connected, Serial0/0/0
R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 140.49.8.0
R2(config-router)#network 192.168.45.0
R2(config-router)#end
R2#
192.168.44.0/29 is subnetted, 2 subnets
C 192.168.44.0 is directly connected, Serial0/0/0
R 192.168.44.8 [120/1] via 192.168.44.1, 00:00:01, Serial0/0/0
192.168.45.0/29 is subnetted, 1 subnets
C 192.168.45.0 is directly connected, Serial0/0/1
220.16.5.0/27 is subnetted, 1 subnets
C 220.16.5.0 is directly connected, FastEthernet0/0
R3#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#network 192.168.44.0
R3(config-router)#network 192.168.44.8
R3(config-router)#network 192.168.45.0
R3(config-router)#network 220.16.5.0
R3(config-router)#end
R3#
Thanks a bunch, Najaf! =]
12-10-2012 06:14 PM
Hi Mike,
Good to hear that solution is working as expected.
How good are you in subnetting? Understanding of subnetting is a must to get a view of what ip address goes to which interface.
The rule of thump of ip address assignement on point to point interface is that both ip address should be from the same network.
In order to make it simple for you let us assume you have three different networks as below.
192.168.1.0/24
192.168.2.0/24
192.168.3.0/24
Since all the network has a mask of /24 (255.255.255.0) each network has 254 valid host address from
192.168.x.1 - 192.168.x.254. So if you want to assign ip address to a point to point interface you pick two ip address from these range.
Assume that you have two router connected back to back and let us call them router A and B then you can assign the ip address as below
A ip is 192.168.1.10 255.255.255.0------>B ip is 192.168.1.20 255.255.255.0 (here as long as both ip address are from the network range of 192.168.1.1 - 254 you are fine.
But if you assign ip address 192.168.1.10 to A and 192.168.2.20 to router B then this is a wrong configuration as both ip address belongs to different networks.
Also another thing which you have to keep in mind is that before you start configuring any routing protocol please ensure you have ping reachablility between the connnected interface. Once you are able to ping all directly connected interface then you can start configuring the routing protocol.
Hope this helps.
Regards
Najaf
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide