cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2707
Views
0
Helpful
2
Replies

Router doesn't show Switch in CDP neighbor; cannot ping gateway

mdelator
Cisco Employee
Cisco Employee

I have a router configured with the IP 1.2.51.3 onto g0/0. It does not show the switch when doing show cdp neighbor. I cannot ping gateway, switch or TFTP server. Cables have been replaced. Interface has been brought up. This issue was seen before but was resolved by switching to another port on switch. Have done so, but it has not worked today. Here are the configs for router

Current configuration : 4400 bytes

!

! Last configuration change at 19:00:51 UTC Wed Apr 17 2013

version 15.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname sunil_palestrina_stress

!

boot-start-marker

boot-end-marker

!

!

!

no aaa new-model

ip cef

!

!

!

!

!

!

ipv6 multicast rpf use-bgp

no ipv6 cef

multilink bundle-name authenticated

!

!

!

!

!

!

voice-card 0

!

!

!

!

!

!

!

!

license udi pid VG350-SPE150/K9 sn FOC16104EEH

license boot module vg350 technology-package securityk9

license boot module vg350 technology-package uck9

license boot module vg350 technology-package datak9

hw-module pvdm 0/0

!

hw-module sm 2

!

hw-module sm 4

!

!

!

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

!

interface GigabitEthernet0/0

ip address 1.2.51.3 255.255.0.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface GigabitEthernet0/2

no ip address

shutdown

duplex auto

speed auto

!

ip forward-protocol nd

!

!

no ip http server

no ip http secure-server

ip route 223.255.254.254 255.255.255.255 1.2.0.1

!

!

!

!

control-plane

!

Switch shows router when I do sh cpd neighbor. Switch can ping gateway 1.2.0.1 and TFTP server but cannot ping router. Here are the configs for switch.

Building configuration...

Current configuration : 1517 bytes

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Castellano_Sw

!

!

ip subnet-zero

!

spanning-tree extend system-id

!

!

interface FastEthernet0/1

no ip address

!

interface FastEthernet0/2

no ip address

!

interface FastEthernet0/3

no ip address

!

interface FastEthernet0/4

no ip address

!

interface FastEthernet0/5

no ip address

!

interface FastEthernet0/6

no ip address

!

interface FastEthernet0/7

no ip address

!

interface FastEthernet0/8

no ip address

!

interface FastEthernet0/9

no ip address

!

interface FastEthernet0/10

no ip address

!

interface FastEthernet0/11

no ip address

!

interface FastEthernet0/12

no ip address

!

interface FastEthernet0/13

no ip address

!

interface FastEthernet0/14

no ip address

!

interface FastEthernet0/15

no ip address

!

interface FastEthernet0/16

no ip address

!

interface FastEthernet0/17

no ip address

!

interface FastEthernet0/18

no ip address

!

interface FastEthernet0/19

no ip address

!

interface FastEthernet0/20

no ip address

!

interface FastEthernet0/21

no ip address

!

interface FastEthernet0/22

no ip address

!

interface FastEthernet0/23

no ip address

!

interface FastEthernet0/24

no ip address

!

interface FastEthernet0/25

no ip address

!

interface FastEthernet0/26

no ip address

!

interface Vlan1

ip address 1.2.233.233 255.255.0.0

no ip route-cache

!

ip default-gateway 1.2.0.1

ip http server

!

!

line con 0

line vty 0 4

login

line vty 5 15

login

!

end

I am at a loss. Any help will be greatly appreciated. Thanks in advanced!

2 Replies 2

blau grana
Level 7
Level 7

Hello mdelator,

maybe this will help you

https://supportforums.cisco.com/message/3913413

Best Regards

Please rate all helpful posts and close solved questions

Best Regards Please rate all helpful posts and close solved questions

Jeff Van Houten
Level 5
Level 5

Try putting switchport mode Access on the switch port the router is plugged into.

Sent from Cisco Technical Support iPad App

Review Cisco Networking for a $25 gift card