cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
915
Views
10
Helpful
14
Replies

Router Forwarding between VLANs

rodrigo2673
Beginner
Beginner

Hi,

I'm trying to communicate 2VLAN's in a 2900XL to a 2600Router. My 2600 supports dot1q so I changed the encapsulation and set 2 sub-interfaces on Eth0/0. However, seems there no comm. between 2hosts on the diff. subnets (e/vlan)I've configured both VLANs and set the trunk on Fa0/16 which is part of both VLANs 1 and 3. Any clues on this?

Thank you.

1 Accepted Solution

Accepted Solutions

Hi

Configure the Link between the two swithces as Trunk link.i.e

switchport mode trunk

and see tht u dnot enable portfast on the ports used for trunking.

Thanks

Mahmood

View solution in original post

14 Replies 14

glen.grant
VIP Alumni
VIP Alumni

Probably have to post both configs . Also what model is the 2924 ? A old 4 meg or newer 8 meg model . The older ones didn't support trunking i don't believe .

Hi thanks for the fast response!

the 2924 is 8meg model.

rodrigo2673
Beginner
Beginner

Sorry, I forgot to attach the config files.

Here for you.

regards,

Hi Rodrigo,

Instead of using multi vlan command on siwtch interface can you try this command

interface FastEthernet0/16

switchport trunk encapsulation dot1q

switchport mode trunk

Regards,

Ankur

Thanks Ankur! it works now. There is comm. now from host to router.

Hi Rodrigo,

Nice to know that it worked for you.

Regards,

Ankur

*Pls rate all helpfull post

The problem is your trunk port on the 2900, you have it configured as a multi-vlan port, not a trunk port. Remove the multi commands and set the port as a trunk. Your config should look like this:

int fa0/16

switchport trunk encapsulation dot1q

switchport mode trunk

!

Thanks! that solved the problem :)

Hi,

Im following the same configuration but now I added another sw2926-XL. The problem is: I cannot get to comm. I've connected a crossover between the 2 sw. (Fa0/17) STP is working in FWD mode in both interfaces. However, when I ping the router says Request Time Out. I've also put Fa0/16 which is the host on VLAN 02.

Please, can you help?

Regards,

Rod

Hi

Configure the Link between the two swithces as Trunk link.i.e

switchport mode trunk

and see tht u dnot enable portfast on the ports used for trunking.

Thanks

Mahmood

Hi Mahmood,

Thank you! that worked.

Hi Rod,

Can you please confirm if you are trying to ping ro touter from the switch? If yes have you det a default gateway on your switch pointing to router ip address?

Regards,

Ankur

Hi,

I am trying to comm.3 routers on a hub-and-spoke topology. The HUB router comms.with the "left" router on a point-to-point connection fine. However, the int.S1(multipoint)connected to router "right" does not comm. Please, find attached 3conf.files of each router.

I hope you can see what is missing in my config.

Thanks.

Rod

rodrigo2673
Beginner
Beginner

Hi,

I hope you can help me since I'm having problems configuring my PIX 501. I have set e0 and e1 static ip addresses and they both comm. with their own segments. HOwever, I can't comm. from e1 through e0.

I've set in both NAT (inside) 0 0 0 and outside as well. There are no packet going out from any of both nics.

Please, can you help?

regadrs,

Rod

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: