10-24-2013 04:22 PM - edited 03-07-2019 04:13 PM
I am trying to upgrade a link between two routers from a pair of bundles T1's to a ethernet copper link. I have tried 3 different times and it always fails and I am at a loss to explain why. I am assuming it has something to do with the VRFs that are set up on the edge router. I am trying to get rid of multilink 1 and replace it with a ethernet connection from Office-2851 interface Gi 0/1 to 3745-Edge Fa 0/0. I have tried using the IP addresses of the multi link to keep the current routing working but it always breaks as soon as I change it. I have tried getting rid of the VRF's all together and go with all static routes with no luck as well. Any ideas? I am putting up the two configs below. If anyone needs any more info just ask and I would be happy to share. This is driving me up a wall here.
Router 1: 2851
show run
Building configuration...
Current configuration : 6089 bytes
!
! No configuration change since last restart
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Office-2851
!
!
!
multilink bundle-name authenticated
!
controller T1 0/0/0
framing esf
linecode b8zs
cablelength short 133
channel-group 0 timeslots 1-24
!
controller T1 0/0/1
framing esf
linecode b8zs
cablelength short 133
!
controller T1 0/1/0
framing esf
linecode b8zs
channel-group 0 timeslots 1-24
!
controller T1 0/1/1
framing esf
linecode b8zs
!
ip ssh time-out 60
ip ssh authentication-retries 4
!
!
!
interface Loopback0
ip address 192.168.63.3 255.255.255.255
!
interface Multilink1
description To Office
ip address 192.168.0.6 255.255.255.252
no ip redirects
no ip unreachables
no ip proxy-arp
ppp multilink
ppp multilink group 1
!
interface GigabitEthernet0/0
no ip address
ip route-cache flow
duplex auto
speed auto
!
interface GigabitEthernet0/0.801
encapsulation dot1Q 801
ip address 192.168.5.1 255.255.255.0
ip helper-address 192.168.5.25
!
interface GigabitEthernet0/1
no ip address
duplex full
speed 100
!
interface Serial0/0/0:0
description To 3745-Edge S0/0:0
no ip address
encapsulation ppp
no fair-queue
ppp multilink
ppp multilink group 1
!
interface Serial0/1/0:0
description To 3745-Edge S0/2
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 1
!
ip route 0.0.0.0 0.0.0.0 192.168.0.5
ip route 192.168.5.0 255.255.255.0 192.168.62.5
ip route 192.168.63.4 255.255.255.255 192.168.62.5
!
ip flow-export version 5
ip flow-export destination 192.168.128.202 3000
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip http path flash:
ip tacacs source-interface GigabitEthernet0/0
!
logging 192.168.128.20
access-list 23 permit 10.10.10.0 0.0.0.7
Office-2851#
Router 2: 3745
show run
Building configuration...
Current configuration : 6148 bytes
!
log datetime msec
service password-encryption
!
hostname 3745-EDGE
!
!
card type t3 1
card type t3 2
no logging console
!
no network-clock-participate wic 0
aaa new-model
!
!
!
ip vrf ntl
rd 1:10
route-target export 1:10
route-target import 1:10
!
no ip bootp server
no ip domain lookup
ip domain name blmntl.gov
ip ssh time-out 60
ip ssh authentication-retries 4
ip ips po max-events 100
no ftp-server write-enable
!
!
controller T1 0/0
framing esf
fdl both
clock source internal
linecode b8zs
channel-group 0 timeslots 1-24 speed 64
!
controller T1 0/1
framing esf
fdl both
linecode b8zs
channel-group 1 timeslots 1-24 speed 64
controller T3 1/0
!
controller T3 2/0
!
no crypto isakmp ccm
!
!
!
!
interface Loopback0
ip address 172.31.31.252 255.255.255.255
!
interface Multilink1
description To Office-2851
ip vrf forwarding ntl
ip address 192.168.0.5 255.255.255.252
ppp multilink
ppp multilink group 1
!
interface FastEthernet0/0
description To MPLS Core1
ip address 172.31.31.18 255.255.255.248
ip ospf network point-to-point
shutdown
speed 100
full-duplex
tag-switching ip
!
interface Serial0/0:0
description To Office-2851 S0/0/0:0
ip vrf forwarding ntl
no ip address
encapsulation ppp
no fair-queue
ppp multilink
ppp multilink group 1
!
interface FastEthernet0/1
no ip address
speed 100
full-duplex
!
interface Serial0/1:1
description To Office2851 S0/0/1:0
ip vrf forwarding ntl
no ip address
encapsulation ppp
no fair-queue
ppp multilink
ppp multilink group 1
!
interface Serial0/2
description To Field-2821
ip vrf forwarding ntl
ip address 192.168.0.9 255.255.255.252
encapsulation ppp
no fair-queue
!
interface Serial0/3
description To Field-2821
ip vrf forwarding ntl
ip address 192.168.0.9 255.255.255.252
encapsulation ppp
shutdown
no fair-queue
!
interface Serial1/0
description To Alpha S3/0
ip vrf forwarding ntl
ip address 10.121.208.2 255.255.255.252
encapsulation ppp
dsu bandwidth 44210
!
interface Serial2/0
description To Beta S3/0
ip vrf forwarding ntl
ip address 10.121.209.142 255.255.255.252
encapsulation ppp
dsu bandwidth 44210
!
router ospf 3745
router-id 172.31.31.252
log-adjacency-changes
passive-interface default
no passive-interface FastEthernet0/0
no passive-interface FastEthernet0/1
network 172.31.31.0 0.0.0.255 area 0
!
router ospf 37452
log-adjacency-changes
!
router bgp 64610
no synchronization
bgp log-neighbor-changes
redistribute connected
redistribute static
neighbor 10.121.208.1 remote-as 64700
neighbor 10.121.208.1 description To 3845-Alpha S3/0
neighbor 10.121.208.1 soft-reconfiguration inbound
neighbor 10.121.209.141 remote-as 64700
neighbor 10.121.209.141 description To 3845-Beta S3/0
neighbor 10.121.209.141 soft-reconfiguration inbound
neighbor 172.31.31.251 remote-as 64610
neighbor 172.31.31.251 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 172.31.31.251 activate
neighbor 172.31.31.251 next-hop-self
neighbor 172.31.31.251 send-community extended
exit-address-family
!
address-family ipv4 vrf ntl
redistribute connected
redistribute static
neighbor 10.121.208.1 remote-as 64700
neighbor 10.121.208.1 activate
neighbor 10.121.208.1 soft-reconfiguration inbound
neighbor 10.121.209.141 remote-as 64700
neighbor 10.121.209.141 activate
neighbor 10.121.209.141 soft-reconfiguration inbound
no auto-summary
no synchronization
exit-address-family
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.31.31.251
ip route 192.168.128.0 255.255.255.0 10.121.208.1
ip route vrf ntl 192.168.5.0 255.255.255.0 192.168.0.6
ip route vrf ntl 192.168.6.0 255.255.255.0 192.168.0.10
ip route vrf ntl 192.168.62.4 255.255.255.252 192.168.0.6
ip route vrf ntl 192.168.63.3 255.255.255.255 192.168.0.6
ip route vrf ntl 192.168.63.4 255.255.255.255 192.168.0.6
ip route vrf ntl 192.168.63.5 255.255.255.255 192.168.0.10
!
!
!
end
--More--
3745-EDGE#
10-24-2013 05:09 PM
Anything in the logs when you connect them?
Do the interfaces show up/up when you connect them?
10-24-2013 05:31 PM
No nothing in the logs and yes both sides come up and I can ping both sides. Here is what I am trying. Once changes are made I can no longer ping 192.168.5.1 and it works with the T1s.
interface FastEthernet0/0
ip vrf forwarding ntl
ip address 192.168.0.5 255.255.255.252
speed auto
duplex auto
interface GigabitEthernet0/1
ip address 192.168.0.6 255.255.255.252
duplex auto
speed auto
10-25-2013 08:51 AM
Have you tried a ping to anything besides .5.1?
Where did you source the ping from?
Did you run a traceroute?
The static route on the 2851 might be affecting the traffic. ip route 192.168.5.0 255.255.255.0 192.168.62.5
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide