04-04-2013 02:21 PM - edited 03-07-2019 12:38 PM
Here is my home lab topology that I'm having problem pinging between PC to Server and vice versa. Examine the topology below the PC that has an ip address 10.0.0.10 and to Server that has an IP address 30.0.0.10/24. What I did hard coded the mac-address on the Router Fas0/0. All trunk links are encapsulation dot1q and the router fas0/0 were splited into two sub-interfaces encap dot1q 2 for VLAN 2 and encap dot1q 3 for VLAN 3.
Kindly show me how do I fix my problem so that I can pinging the PC to Server and back. Thank so much.
04-04-2013 02:26 PM
Hi,
Can the PC and the server ping it's default gateway? Why did you hard code the routers MAC address on the router?
04-04-2013 02:35 PM
Good question Mike!..the reason is I just want to know provided if it work and all that, I know who is belong to..
Strange enough I could not pinging the default-gateway either so what is it the problem here? is it difference VLAN's or the trunking I did not config properly or what else it could be a problem? Thanks
04-04-2013 02:41 PM
Hi,
Lots of things to check..start at the PC and server and work your way to the router. Is the PC and server in the correct vlan and showing link? Are the IP addresses and subnet masks correct on the systems and router? Are the trunks up between the switches and passing the vlans? Is the switch interface that the router is connected to showing up and trunking with the correct vlans?
Lots of things to check.
04-04-2013 05:49 PM
Sorry that I have to paste my configuration because this forum does not provide file attachment only image and video. Now..please see my configuration, let me know if you may find anything peculiar or the error was? Thanks.
R5
interface FastEthernet0/0
description connect to SW1 Fas0/15
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.2
encapsulation dot1Q 2
ip address 10.0.0.2 255.255.255.0
!
interface FastEthernet0/0.3
encapsulation dot1Q 3
ip address 30.0.0.3 255.255.255.0
Sh ip int br
FastEthernet0/0 unassigned YES NVRAM up up
FastEthernet0/0.2 10.0.0.2 YES manual up up
FastEthernet0/0.3 30.0.0.3 YES manual up up
PC
interface FastEthernet0/0
ip address 10.0.0.10 255.255.255.0
!
ip default-gateway 10.0.0.2
Sh arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 10.0.0.10 - 0013.c45e.9cce ARPA FastEthernet0/0
Sh ip int br
FastEthernet0/0 10.0.0.10 YES manual up up
SW2
interface FastEthernet0/2
description connect to PC
switchport access vlan 2
switchport trunk encapsulation dot1q
switchport trunk native vlan 2
switchport mode access
!
interface FastEthernet0/11
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/12
switchport trunk encapsulation dot1q
switchport mode trunk
Sh vlan brief
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/1, Fa0/3, Fa0/4, Fa0/5
Fa0/6, Fa0/7, Fa0/8, Fa0/9
Fa0/10, Fa0/13, Fa0/14, Fa0/15
Fa0/16, Fa0/17, Fa0/18, Fa0/19
Fa0/20, Fa0/21, Fa0/22, Fa0/23
Fa0/24, Gi0/1, Gi0/2
2 VLAN0002 active Fa0/2
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup
SW1
interface FastEthernet0/11
switchport access vlan 2
switchport trunk encapsulation dot1q
switchport mode trunk
shutdown
!
interface FastEthernet0/12
switchport access vlan 2
switchport trunk encapsulation dot1q
switchport mode trunk
shutdown
!
interface FastEthernet0/13
switchport access vlan 3
switchport trunk encapsulation dot1q
switchport mode trunk
shutdown
!
interface FastEthernet0/14
switchport access vlan 3
switchport trunk encapsulation dot1q
switchport mode trunk
shutdown
!
interface FastEthernet0/15
description connect to R5
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2,3
switchport mode access
Sh vlan br
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/4
Fa0/5, Fa0/6, Fa0/7, Fa0/8
Fa0/9, Fa0/10, Fa0/15, Fa0/16
Fa0/17, Fa0/18, Fa0/19, Fa0/20
Fa0/21, Fa0/22, Fa0/23, Fa0/24
Gi0/1, Gi0/2
2 VLAN0002 active Fa0/11, Fa0/12
3 VLAN0003 active Fa0/13, Fa0/14
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup
SW3
interface FastEthernet0/3
switchport access vlan 3
switchport trunk encapsulation dot1q
switchport trunk native vlan 3
switchport mode access
!
interface FastEthernet0/13
switchport access vlan 3
switchport trunk encapsulation dot1q
switchport mode access
!
interface FastEthernet0/14
switchport access vlan 3
switchport trunk encapsulation dot1q
switchport mode access
Sh vlan br
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/1, Fa0/2, Fa0/4, Fa0/5
Fa0/6, Fa0/7, Fa0/8, Fa0/9
Fa0/10, Fa0/11, Fa0/12, Fa0/15
Fa0/16, Fa0/17, Fa0/18, Fa0/19
Fa0/20, Fa0/21, Fa0/22, Fa0/23
Fa0/24, Gi0/1, Gi0/2
3 VLAN0003 active Fa0/3, Fa0/13, Fa0/14
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup
Server
interface FastEthernet0/0
ip address 30.0.0.10 255.255.255.0
!
ip default-gateway 30.0.0.3
Sh arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 30.0.0.10 - 000d.2909.6840 ARPA FastEthernet0/0
sh ip int br
FastEthernet0/0 10.0.0.10 YES manual up up
NOTE:
I have shut all interface fa0/11 - 14 on SW1 because I have Native VLAN mismatch in all trunks.
*Apr 4 08:26:43.421: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/11 (1), with SW2 FastEthernet0/11 (2).
*Apr 4 08:26:43.421: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/12 (1), with SW2 FastEthernet0/12 (2).
*Apr 4 08:26:34.349: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/13 (1), with SW3 FastEthernet0/13 (3).
*Apr 4 08:26:34.389: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/14 (1), with SW3 FastEthernet0/14 (3).
04-04-2013 11:52 PM
Hi,
SW3:
interface FastEthernet0/3
switchport access vlan 3
no switchport trunk encapsulation dot1q
no switchport trunk native vlan 3
switchport mode access
!
interface FastEthernet0/13
no switchport access vlan 3
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/14
no switchport access vlan 3
switchport trunk encapsulation dot1q
switchport mode trunk
SW1:
interface FastEthernet0/11
no switchport access vlan 2
switchport trunk encapsulation dot1q
switchport mode trunk
no shutdown
!
interface FastEthernet0/12
no switchport access vlan 2
switchport trunk encapsulation dot1q
switchport mode trunk
no shutdown
!
interface FastEthernet0/13
no switchport access vlan 3
switchport trunk encapsulation dot1q
switchport mode trunk
no shutdown
!
interface FastEthernet0/14
no switchport access vlan 3
switchport trunk encapsulation dot1q
switchport mode trunk
no shutdown
!
interface FastEthernet0/15
description connect to R5
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2,3
switchport mode trunk
SW2:
interface FastEthernet0/2
description connect to PC
switchport access vlan 2
no switchport trunk encapsulation dot1q
no switchport trunk native vlan 2
switchport mode access
clear arp on PC and Server and make sure ip routing is disabled with no ip routing command
Regards
Alain
Don't forget to rate helpful posts.
04-05-2013 04:05 PM
Hi Alain,
Thanks for the respond but between PC to Server to PC still isn't pinging, I also verified pinging to the router with no success as well. Would that be anything else we have missed here? Let me know what you think.
Regards,
Arif
04-06-2013 06:23 AM
Hi,
did you clear arp on all L3 devices? do this on the pc and router:
conf t
logging buffered debug
no service timestamp debug
do debug ip pack detail 100
access-list 100 permit icmp any any
do ping X.X.X.X rep 2 on the PC where X.X.X.X is the IP of the router in same subnet(f0/0.2)
do sh log
post the output here.
if it is ok then do the ping for the IP of f0/0.3 and if it is ok then do the ping for the server IP( do clear log between each ping).
Regards
Alain
Don't forget to rate helpful posts.
04-07-2013 09:25 AM
Hi,
Disable IP Routing on Switches
NO IP routing.
Post Sh ip int briief of Switche
Also
Give IP to L2 Switche to check Connectivity from near end.
*** Do Rate All Helpful Posts***
04-08-2013 03:01 PM
Hi Alain,
First at all, it still doesn't work and I think I have tried every sources including you method and others too. It seems there still puzzle why this topology is not pinging. So I came up with similar topology but I used EIGRP to advertise both network and finally it work...:) Thanks for your help at least you try to help and others too.
Warm regards,
Arif
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide