cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3312
Views
0
Helpful
7
Replies
Highlighted

Routing problem adding secondary address at interface Vlan1

Switch - Cisco IOS Software, C3750 Software (C3750-IPSERVICES-M), Version 12.2(35)SE5, RELEASE SOFTWARE (fc1)

interface Vlan1

description VLAN LAN

ip address 10.193.21.1 255.255.255.0 secondary

ip address 10.193.29.4 255.255.255.0

ip helper-address 10.52.188.103

ip helper-address 10.53.140.31

!

!

router eigrp 301

redistribute static

network 10.193.0.0 0.0.255.255

no auto-summary

!

BRPIP-S01-A#sh ip route 10.193.21.0

Routing entry for 10.193.21.0/24

  Known via "connected", distance 0, metric 0 (connected, via interface)

  Redistributing via eigrp 301

  Routing Descriptor Blocks:

  * directly connected, via Vlan1

      Route metric is 0, traffic share count is 1

From LAN routing is working fine but from WAN or even from SP router it doesn't, and this could be classified as a routing issue at router, but if I connect at another Vlan, it works normally from remote sites.

Does someone knows if there is some limitation or even looking at configuration it some error is missing?

Thanks,

Luiz

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Luiz

Am I understanding correctly that you can configure that subnet as a secondary address on other VLANs and it works ok through the ISP router?

One possible explanation occurs to me - is the connection to the ISP router through VLAN 1? If so that would explain the issue. EIGRP enforces the split horizon rule and will not advertise a subnet out the interface on which it is learned. So if the VLAN 1 has the secondary address, and VLAN 1 is the path to the ISP router then EIGRP would not advertise the subnet out the VLAN 1 interface. The normal solution for this is to be sure that the secondary address is also configured on the layer 3 device that connects to that subnet. I am not clear what your topology is and whether configuring the secondary address on the other layer 3 device is feasible.

If that is not the situation then please post the complete configuration of the switch. There must be some other reason and if we saw the complete config then we might be able to find the explanation.

HTH

Rick

HTH

Rick

View solution in original post

7 REPLIES 7
Highlighted
Hall of Fame Guru

Luiz

The part of the config that you have posted looks ok to me and I do not see any problems in it.

I do not fully understand your question, especially about where it is working and where it is not working. You say: "from WAN or even from SP router it doesn't, and this could be classified as a routing issue at router, but if I connect at another Vlan, it works normally from remote sites."

I understand the part about from the ISP router it does not work. And I believe that the situation may be that the ISP router is not participating in your EIGRP and does not know about the secondary subnet. It may also be an issue about network translation for traffic going to the Internet. I am assuming that there is address translation configured for the subnet of the primary address 10.193.29.0 but wondering if it is missing translation for the secondary subnet 10.193.21.0.

When you say that it works normally from remote sites, are these sites connected over the WAN or are they sites connected through the LAN?

HTH

Rick

HTH

Rick
Highlighted

I'm not entirely sure I understand what you mean by this:

From LAN routing is working fine but from WAN or even from SP router it doesn't, and this could be classified as a routing issue at router, but if I connect at another Vlan, it works normally from remote sites.

Do you mean that eigrp is not advertising the secondary address?

Is it in the local routing table? Well I know it is because I see in your post. Just thinking out loud

 Known via "connected", distance 0, metric 0 (connected, via interface)

You can see it is connected, but you are no redistributing connected. So others, SP and WAN don't see the route. Have I understood you correctly?

router eigrp 301

redistribute static

network 10.193.0.0 0.0.255.255

no auto-summary

Maybe you should try redistribute conncted but with no knowledge of your network that could have wider implications.

Regards,

Ian

Please rate if I hepled.

Highlighted

Hi Rick,

You beat me to it

Highlighted

Hi My friends,

The problem is the following:

When set the secondary address at VLAN 01, at 3750 switch it works from other connected Vlans locally at this switch, but from remote sites coming through the WAN not, not even from ISP router.

But, at same switch when connect to other Vlan it works perfectly from local connected and from WAN sites coming through this same ISP router.

This is really weird and I would assume that is a routing issue if didn't work when same range is configured as secondary at any other VLAN different from 01.

Rds and thanks for the help.

Luiz

Highlighted

Luiz

Am I understanding correctly that you can configure that subnet as a secondary address on other VLANs and it works ok through the ISP router?

One possible explanation occurs to me - is the connection to the ISP router through VLAN 1? If so that would explain the issue. EIGRP enforces the split horizon rule and will not advertise a subnet out the interface on which it is learned. So if the VLAN 1 has the secondary address, and VLAN 1 is the path to the ISP router then EIGRP would not advertise the subnet out the VLAN 1 interface. The normal solution for this is to be sure that the secondary address is also configured on the layer 3 device that connects to that subnet. I am not clear what your topology is and whether configuring the secondary address on the other layer 3 device is feasible.

If that is not the situation then please post the complete configuration of the switch. There must be some other reason and if we saw the complete config then we might be able to find the explanation.

HTH

Rick

HTH

Rick

View solution in original post

Highlighted

we have solvet this by creating another connection with the router, but it was very nice to be back to routing basics and remember  this. sometimes we look for super complicated problems and the answer is close and basics.

Thanks for the help,

Luiz

Highlighted

Luiz

I am glad that you have found an alternative that works and that my suggestions have been helpful in this. Thank you for marking this issue as resolved (and thanks for the points). It makes the forum more useful when readers can read about an issue and can know that a solution was found. Your marking will help readers to recognize that in this thread.

HTH

Rick

HTH

Rick
Content for Community-Ad