cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1479
Views
10
Helpful
4
Replies
Highlighted
Beginner

Routing to ISP using NAT

I have set up multiple vlans which all communicate with each other using a layer 3 switch, the PCs / servers can ping to the router, both the inside and outside port, though for the life of me I can't get it past this point.

I have tried setting up NAT to change the IPs, though I dont think this is the problem.

 

Fake Company public IP Address: 47.10.21.1 – 47.10.21.14 (Used for NAT i think)

Web server IP address: 77.10.18.50/24

ISP router (fa0/0): 77.10.18.1/24

 

Any help on this would be appreciated, so I can learn what I am doing wrong, I've followed countess YouTube videos and read through my Cisco command guide so much.

Bare in mind i'm a newbie to all this :) thanks in advance.

 

Everyone's tags (4)
2 ACCEPTED SOLUTIONS

Accepted Solutions
VIP Advocate

Re: Routing to ISP using NAT

HI,

Your NAT was configured wrong. 

below are the correct configuration:

 

interface FastEthernet0/0
ip address 7.7.10.14 255.255.255.252
ip nat outside
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.0.0.1 255.0.0.0
ip nat inside
duplex auto
speed auto

!

!

ip nat inside source list 1 interface fastEthernet 0/0 overload 

 

Your Fast Ethernet 0/0 is Connects the interface to the outside network.

 

Don't forget to mark helpful, if it will helpful for you.

 

Regards,

Deepak Kumar

 

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution If this comment will make help you!

View solution in original post

VIP Advocate

Re: Routing to ISP using NAT

Please check your NAT ACL also. 

In the Access-list 1, there is only one subnet is allowed as 10.0.0.0/24  but you must allow all subnets which are configured in your LAN or allow all. as 

 

access-list 1 permit any

 

Regards,

Deepak Kumar

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution If this comment will make help you!

View solution in original post

4 REPLIES 4
VIP Advocate

Re: Routing to ISP using NAT

HI,

Your NAT was configured wrong. 

below are the correct configuration:

 

interface FastEthernet0/0
ip address 7.7.10.14 255.255.255.252
ip nat outside
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.0.0.1 255.0.0.0
ip nat inside
duplex auto
speed auto

!

!

ip nat inside source list 1 interface fastEthernet 0/0 overload 

 

Your Fast Ethernet 0/0 is Connects the interface to the outside network.

 

Don't forget to mark helpful, if it will helpful for you.

 

Regards,

Deepak Kumar

 

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution If this comment will make help you!

View solution in original post

Beginner

Re: Routing to ISP using NAT

Hi,

    thank you for the reply, I was able to ping from the router to the ISP, though still unable to ping from the PC to the ISP?

 

I've updated the file on Google Drive.

 

Any ideas? 

VIP Advocate

Re: Routing to ISP using NAT

Please check your NAT ACL also. 

In the Access-list 1, there is only one subnet is allowed as 10.0.0.0/24  but you must allow all subnets which are configured in your LAN or allow all. as 

 

access-list 1 permit any

 

Regards,

Deepak Kumar

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution If this comment will make help you!

View solution in original post

Beginner

Re: Routing to ISP using NAT

Life saver!

Thank you very much :))))

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards