cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
14547
Views
17
Helpful
10
Replies

service-policy on Vlan interface failed

Eugene Khabarov
Level 7
Level 7

Hi, All!

This is my configuration:

class-map match-any voip_control_trust-CMAP
match ip dscp cs3
match ip dscp af31
class-map match-any voip_rtp_trust-CMAP
match ip dscp ef
class-map match-any internetwork-cntrl-CMAP
match ip dscp cs6
!
!
policy-map output_qos-PMAP
class voip_rtp_trust-CMAP
  priority 56
class voip_control_trust-CMAP
  bandwidth percent 2
class internetwork-cntrl-CMAP
  bandwidth percent 5
class class-default
  fair-queue
  random-detect
!

cisco(config)#int Vlan 2
cisco(config-if)#service-policy output output_qos-PMAP
Configuration failed!

It was tested on 877, 871, 871W, 877W with ios c870-advipservicesk9-mz.124-15.T5.bin, c870-advipservicesk9-mz.124-15.T8.bin, c870-advipservicesk9-mz.124-15.T10.bin, c870-advipservicesk9-mz.124-15.T11.bin, c870-advipservicesk9-mz.124-24.T2.bin

Strange error. Does anybody know what's the problem?

10 Replies 10

Eugene Khabarov
Level 7
Level 7

any ideas?

Ok, i tried to make workaround solution:

policy-map OUTPUT_QOS_PMAP
class VOIP_RTP_TRUST_CMAP
    priority 56
class VOIP_CTRL_TRUST_CMAP
    bandwidth percent 2
class INETWORK-CTRL-CMAP
    bandwidth percent 5
class class-default
    fair-queue
     random-detect
  service-policy OUTPUT_QOS_PMAP
service-policy output OUTPUT_QOS_PMAP

interface Vlan2
description *** WAN SVI ***
bandwidth 256
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip virtual-reassembly
bridge-group 1
!
end

interface BVI1
description *** WAN BVI ***
bandwidth 256
ip address 10.96.0.57 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip virtual-reassembly
!
service-policy output OUTPUT_QOS_PMAP
end

sh policy-map interface
BVI1

  Service-policy output: OUTPUT_QOS_PMAP

    queue stats for all priority classes:

      queue limit 64 packets
      (queue depth/total drops/no-buffer drops) 0/0/0
      (pkts output/bytes output) 0/0

    Class-map: VOIP_RTP_TRUST_CMAP (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: ip dscp ef (46)
        0 packets, 0 bytes
        5 minute rate 0 bps
      Priority: 56 kbps, burst bytes 1500, b/w exceed drops: 0


    Class-map: VOIP_CTRL_TRUST_CMAP (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: ip dscp cs3 (24)
        0 packets, 0 bytes
        5 minute rate 0 bps
      Match: ip dscp af31 (26)
        0 packets, 0 bytes
        5 minute rate 0 bps
      Queueing
      queue limit 64 packets
      (queue depth/total drops/no-buffer drops) 0/0/0
      (pkts output/bytes output) 0/0
      bandwidth 2% (5 kbps)

    Class-map: INETWORK-CTRL-CMAP (match-any)
      6 packets, 896 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: ip dscp cs6 (48)
        6 packets, 896 bytes
        5 minute rate 0 bps
      Match: access-group name IKE
        0 packets, 0 bytes
        5 minute rate 0 bps
      Queueing
      queue limit 64 packets
      (queue depth/total drops/no-buffer drops) 5/0/0
      (pkts output/bytes output) 6/1120
      bandwidth 5% (12 kbps)

    Class-map: class-default (match-any)
      11 packets, 660 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any
      Queueing
      queue limit 64 packets
      (queue depth/total drops/no-buffer drops/flowdrops) 10/0/0/0
      (pkts output/bytes output) 11/660
      Fair-queue: per-flow queue limit 16
        Exp-weight-constant: 9 (1/512)
        Mean queue depth: 0 packets
        class     Transmitted       Random drop      Tail/Flow drop Minimum Maximum Mark
                  pkts/bytes    pkts/bytes       pkts/bytes    thresh  thresh  prob

        0              11/660             0/0              0/0                 20            40  1/10
        1               0/0               0/0              0/0                 22            40  1/10
        2               0/0               0/0              0/0                 24            40  1/10
        3               0/0               0/0              0/0                 26            40  1/10
        4               0/0               0/0              0/0                 28            40  1/10
        5               0/0               0/0              0/0                 30            40  1/10
        6               0/0               0/0              0/0                 32            40  1/10
        7               0/0               0/0              0/0                 34            40  1/10

BUT! Until service-policy is on interface works nothing.

sh int bvi1
BVI1 is up, line protocol is up
  Hardware is BVI, address is 0025.454a.940d (bia 0024.c495.6780)
  Description: *** WAN BVI ***
  Internet address is 10.96.0.57/24
  MTU 1500 bytes, BW 256 Kbit/sec, DLY 5000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 74
  Queueing strategy: Class-based queueing
  Output queue: 33/1000/0 (size/max total/drops)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     114 packets output, 11034 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out

ping 10.96.0.1 source bvi1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.96.0.1, timeout is 2 seconds:
Packet sent with a source address of 10.96.0.57
.....
Success rate is 0 percent (0/5)

Hi:

You cannot apply a policy map on an SVI in the input or output direction.

Also, SVIs do not support CBWFQ, LLQ, WRED or hierarchical MQC QoS, which is what you have configured. The default queing mechanism for an SVI interface is FIFO, in which case there is only one queue anyway and no classifaction or scheduling.

It is true that Cisco allows you to change the queing mechanism on an SVI to WFQ, but in that case there is no manual classifaction and marking of packets. In other words, no MQC QoS configuration.

WFQ is flow-based, so the IOS will automatically (dynamically) create a queue that it will service for each flow that exists. A flow is defined by the source and destination IP addresses, and source and destination TCP/UDP ports. The queues get prioritized service by the scheduler based on a  sequence number (SN) or so-called Finish Time that it assigns to each packet. The lower the number calculated, the greater the packet's priority.

HTH

Victor

So what about second approach? Can I apply service-policy to BVI? Why is thi not working?

You gave me a "2" and expect me to continue answering your questions...fuggetaboutit! :-)

Ouch, it's not a school assessment
I'll give you 5 points and correct answer mark if you can help me, i promise

I was just teasing you...thats why I put the smiley face at the end.

I really dont khave an answer regarding BVI interfaces and what youre trying to achieve with them. Otherwise, I would have given you an answer.


Victor

Thanks for this, this is what i was looking for  :)

kevinhsieh
Level 1
Level 1

I am able to apply an output service-policy (policer) on a SVI under 15.3 on Cisco 881. I am unable to on 12.4. I hope this helps.

Milind Inamdar
Level 1
Level 1

hi, 

 

i am also getting same error while configuring service policy in L2 port and logical port (Vlan 20 )

 

please help me here.

 

logs 

 

hav_091MOHA623029892(config)#int FastEthernet1
hav_091MOHA623029892(config-if)#service-policy output Havells_6COS_2Mb_WAN_Parent_Out
Configuration failed!
hav_091MOHA623029892(config-if)#int vlan 20
hav_091MOHA623029892(config-if)#service-policy output Havells_6COS_2Mb_WAN_Parent_Out
Configuration failed!

 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card