cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1485
Views
5
Helpful
3
Replies

Setting up PPPoE and overload NAT

Roberto Soto
Beginner
Beginner

Hello Community,

I've been trying to setup a PPPoE session from my home. I own a 871W which is connected from its fastethernet 4 WAN interfaces to a ADLS modem provided by my ISP. I having difficulties understanding the difference betwen my f4 and dialer 0 interface. Where do I apply the overload for example? on f4 or dialer 0? Where do I apply my router default route f4 or dialer 0? If anyone could explain the difference or relationship between these 2 interfaces I will be grateful. Please see configs below, also please note that at the end I posted a PPPoE show output; I dont have a clue if the session is working. 

routerA#sh running-config
Building configuration...

Current configuration : 1608 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname routerA
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$oEiU$ibFel1m0vRKS8z7AGeEK4.
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
no ip domain lookup
!
!
!
username 
!
!
!
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3 (I've configured switchport access vlan 1 for this interface)
 duplex full
 speed 100
!
interface FastEthernet4
 ip address dhcp
 ip nat outside
 ip virtual-reassembly
 speed 100
 full-duplex
 pppoe enable group global
 pppoe-client dial-pool-number 1
!
interface Dot11Radio0
 no ip address
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role root
!
interface Dot11Radio0.10
 encapsulation dot1Q 1 native
 shutdown
 no snmp trap link-status
!
interface Vlan1
 ip address 192.168.1.1 255.255.255.0
!
interface Dialer0
 ip address negotiated
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 ip tcp adjust-mss 1452
 dialer pool 1
 ppp authentication chap callin
 ppp chap hostname {myusername}
 ppp chap password 7 {mypassword}
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
!
no ip http server
no ip http secure-server
ip nat inside source list 1 interface Dialer0 overload
!
access-list 1 permit 192.168.1.0 0.0.0.255
no cdp advertise-v2
!
control-plane
!
!
line con 0
 logging synchronous
 login local
 no modem enable
line aux 0
line vty 0 4
 login
!
scheduler max-task-time 5000
end

 

 

routerA#sh pppoe session
     1 client session

Uniq ID  PPPoE  RemMAC          Port                    VT  VA         State
           SID  LocMAC                                      VA-st
    N/A      7  d4ca.6d78.317b  Fa4                    Di0  Vi1        N/A
                001c.57f2.3a44                              UP

3 Replies 3

Henrik Grankvist
Enthusiast
Enthusiast

Hi

There is no relationship between those two interfaces, they are two different physical interfaces. The cable for the DSL connection is plugged into the dialer interface, while your normal RJ45 connector is plugged in to the fast ethernet interface.

Here is a example config (found here: http://www.cisco.com/c/en/us/tech/long-reach-ethernet-lre-digital-subscriber-line-xdsl/pppoe-pppoa-ppp-over-ethernet-ppp-over-atm/tech-configuration-examples-list.html):

vpdn enable
vpdn-group 1
request-dialin
protocol pppoe
!
interface vlan 1
ip address 192.168.1.1 255.255.255.0
ip nat inside
!
interface dialer 1
ip address negotiated
ppp authentication chap
dialer pool 1
ip nat outside
!
ip nat inside source list 1 interface dialer 1 overload
access-list 1 permit 192.168.1.0 0.0.0.255
!
ip route 0.0.0.0 0.0.0.0 dialer 1

Sorry Henrik I forgot to add that the router is connected via f4 with a RJ45 to a DSL modem. The DSL modem I have no access to. So from the cisco 871w a cable from its wan interfaces (f4) goes to a BT openreach FTTC adsl modem as below.

Then you shouldn't worry about the dialer interface, or any of the PPPoE configuration. Just configure the Fa4 as NAT outside and VLAN 1 interface as NAT inside + default route out Fa4.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: