04-29-2013 01:36 PM - edited 03-07-2019 01:05 PM
Hi,
I have 2x2950s and 2x3550s trying to set up etherchannels between them. Everything looks ok but the speed is still around 100Mbps even though there are 2xFE trunks everywhere.
I tried to isolate it, connecting 2x2950s together - the same, I get max 100Mbps...
My basic topology:
PC with a Gb NIC -----------------2950-----------------------2950--------------PC with a Gb NIC
Iperf results:
[ 4] local 172.16.1.144 port 5001 connected with 172.16.1.28 port 51554
[ 4] 0.0-10.0 sec 102 MBytes 85.4 Mbits/sec
[ 4] local 172.16.1.144 port 5001 connected with 172.16.1.28 port 51675
[ 4] 0.0-10.0 sec 107 MBytes 89.3 Mbits/sec
I tried to change PO ports to active/active - still the same. When I connect these PCs to the same 2950 switch using two gigabit ports, I get:
[ 4] 0.0-10.0 sec 390 MBytes 327 Mbits/sec
I also tried to copy from PC3 to both PC1 and PC2 at the same time to make sure it can load balance - unfortunately I was getting 5-6MBps for each connection only
Have I missed anything obvious???
My basic config and show commands:
SWITCH1
switch1#sh run int po1
Building configuration...
Current configuration : 207 bytes
!
interface Port-channel1
description ETHERCHANNEL
switchport trunk native vlan 2
switchport trunk allowed vlan 1-4,99,1002-1005
switchport mode trunk
switchport nonegotiate
flowcontrol send off
end
switch1#sh run int f0/18
Building configuration...
Current configuration : 190 bytes
!
interface FastEthernet0/18
switchport trunk native vlan 2
switchport trunk allowed vlan 1-4,99,1002-1005
switchport mode trunk
switchport nonegotiate
channel-group 1 mode active
end
switch1#sh run int f0/19
Building configuration...
Current configuration : 190 bytes
!
interface FastEthernet0/19
switchport trunk native vlan 2
switchport trunk allowed vlan 1-4,99,1002-1005
switchport mode trunk
switchport nonegotiate
channel-group 1 mode active
end
switch1#sh ethe
switch1#sh etherchannel su
switch1#sh etherchannel summary
Flags: D - down P - in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
u - unsuitable for bundling
U - in use f - failed to allocate aggregator
d - default port
Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
------+-------------+-----------+----------------------------------------------
1 Po1(SU) LACP Fa0/18(P) Fa0/19(Pd)
switch1#sh int po1
Port-channel1 is up, line protocol is up (connected)
Hardware is EtherChannel, address is 0009.43ae.ce13 (bia 0009.43ae.ce13)
Description: ETHERCHANNEL
MTU 1500 bytes, BW 200000 Kbit, DLY 1000 usec,
reliability 255/255, txload 5/255, rxload 1/255
Encapsulation ARPA, loopback not set
Full-duplex, 100Mb/s, media type is unknown media type
input flow-control is off, output flow-control is off
Members in this channel: Fa0/18 Fa0/19
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:01:23, output 00:00:00, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 89000 bits/sec, 172 packets/sec
5 minute output rate 4495000 bits/sec, 354 packets/sec
2831392 packets input, 2669151653 bytes, 1056 no buffer
Received 36665 broadcasts (29399 multicast)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 1056 ignored
0 watchdog, 29399 multicast, 0 pause input
0 input packets with dribble condition detected
2885680 packets output, 3152464741 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 PAUSE output
0 output buffer failures, 0 output buffers swapped out
SWITCH2
switch2#sh run int po1
Building configuration...
Current configuration : 206 bytes
!
interface Port-channel1
description ETHERCHANNEL
switchport trunk native vlan 2
switchport trunk allowed vlan 1-4,99,1002-1005
switchport mode trunk
switchport nonegotiate
flowcontrol send off
end
switch2#sh run int f0/18
Building configuration...
Current configuration : 190 bytes
!
interface FastEthernet0/18
switchport trunk native vlan 2
switchport trunk allowed vlan 1-4,99,1002-1005
switchport mode trunk
switchport nonegotiate
channel-group 1 mode active
end
switch2#sh run int f0/19
Building configuration...
Current configuration : 190 bytes
!
interface FastEthernet0/19
switchport trunk native vlan 2
switchport trunk allowed vlan 1-4,99,1002-1005
switchport mode trunk
switchport nonegotiate
channel-group 1 mode active
end
switch2#sh ethe su
Flags: D - down P - in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
u - unsuitable for bundling
U - in use f - failed to allocate aggregator
d - default port
Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
------+-------------+-----------+--------------------------------------------
1 Po1(SU) LACP Fa0/18(Pd) Fa0/19(P)
switch2#sh int po1
Port-channel1 is up, line protocol is up (connected)
Hardware is EtherChannel, address is 000a.b7dd.3d12 (bia 000a.b7dd.3d12)
Description: ETHERCHANNEL
MTU 1500 bytes, BW 200000 Kbit, DLY 1000 usec,
reliability 255/255, txload 1/255, rxload 4/255
Encapsulation ARPA, loopback not set
Full-duplex, 100Mb/s, media type is unknown media type
input flow-control is off, output flow-control is off
Members in this channel: Fa0/18 Fa0/19
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:00, output 00:02:58, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 3268000 bits/sec, 254 packets/sec
5 minute output rate 56000 bits/sec, 117 packets/sec
2896053 packets input, 3157891899 bytes, 0 no buffer
Received 33572 broadcasts (28209 multicast)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 28204 multicast, 0 pause input
0 input packets with dribble condition detected
2755632 packets output, 2612593705 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 PAUSE output
0 output buffer failures, 0 output buffers swapped out
Solved! Go to Solution.
04-29-2013 01:57 PM
Well your ports that are in the port channel are 100Meg ports so certainly you won't get more than 100Meg out of it. When you do a port channel default load balancing method on the switch is src-mac. Which means if PC1 has a MAC of x.x.x and it is the source all data will go over the first link. Now if you add another PC with a MAC of y.y.y that will go over the second link. Higher end switches offer better and more granular load balancing methods such as source and destination mac or IP, ports etc.
04-29-2013 01:57 PM
Well your ports that are in the port channel are 100Meg ports so certainly you won't get more than 100Meg out of it. When you do a port channel default load balancing method on the switch is src-mac. Which means if PC1 has a MAC of x.x.x and it is the source all data will go over the first link. Now if you add another PC with a MAC of y.y.y that will go over the second link. Higher end switches offer better and more granular load balancing methods such as source and destination mac or IP, ports etc.
04-29-2013 02:02 PM
Mohammad, that is what I did:
PC1 ------------------2950-------------2950 ----------------PC2 and PC3
Was getting max 6MBps on PC2 and PC3 when sending files to PC1....
04-30-2013 07:36 AM
Anyone pls?
04-30-2013 08:14 AM
Hello
Try and recreate the port-channel-
1)Config the physical interfaces involved to default and delete the port-channel
2) assign channel-group and channel-group number on the physical interfaces
on let port-channel be created automaticlly
4)create trunking encapsulation direactly in port-channel interface config mode
5)reset physical interfaces "shut" "no shut"
your port-channel config should be copied onto the physical interfaces automatically.
res
Paul
Please don't forget to rate any posts that have been helpful.
Thanks.
04-30-2013 09:01 AM
Ok so if you were getting 6MBps that is equal to 48Mbps. That should be fine on a 100Mbps link. What kind of transfer was it? Your PC's have a gigabit NICs but your switch supports 100Meg only. So try to hard code the NIC to 100Meg and see what happens.
04-30-2013 10:50 AM
PC1,PC2----------2950--------------2950------------PC3,PC4
copy a file PC1->PC3
copy a file PC2->PC4
All worked great, 100Mb on both PCs.
Thx guys!
05-01-2013 07:26 AM
Thank you for the update, did you have to hard code the NIC settings ?
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide