cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

SNMP Issue

Hi to all,

I have two switches Catalyst (one C2960S and one C2960), I have configured the SNMP for monitoring purposes. The C2960 works fine and the other unit doesn't work.....

The configuration is the same and the switches are in the same subnet, but if I run a snmpwalk I can see the mibs from the c2960 but the other unit doesn't answer me, can anyone help me??

The configs are:

C2960S:

snmp-server community snmpxxx RO
snmp-server community snmpxxx RW
snmp-server trap link ietf
snmp-server trap-source VlanXX
snmp-server location Barcelona
snmp-server contact IT
snmp-server chassis-id BCN01

C2960:

snmp-server community snmpxxx RO
snmp-server community snmpxxx RW
snmp-server trap link ietf
snmp-server trap-source VlanXX
snmp-server location Madrid
snmp-server contact IT
snmp-server chassis-id MAD01

I don't know why it's happening this issue......

Thanks in advance!!

Regards

David.

6 REPLIES 6

Jason Dance
Beginner
Beginner

Hi.

What version of IOS is on each device?

David

Is there any possibility that it is a simple IP connectivity issue for the 2960S? From the remote server are you able to ping the 2960S? Is there any possibility that the community string is not set correctly on the 2960S?

Can you enable logging monitor debug on the 2960S, log in on the 2960S, do term mon, and then attempt the snmpwalk? Are there any log messages generated when you attempt this access? If that does not show anything you might turn on debug for snmp on the 2960S and see what output is produced when you attempt the snmpwalk.

HTH

Rick

HTH

Rick

Hi Richard,

I think there isn't a connectivity issue because I can manage the two devices via telnet/ssh without any problem... I can ping the two devices and I can manage all the functions... I've checked all the communities strings and are configured properly....

If, I enable the debug on the two devices, in the 2960 I can see messages generated by the snmpwalk.... In the 2960S I can see messages answering other snmp access but I can't see my snmp tries....

Regards.

David.

Hi.

Can you post the debug messages?

Hi Jason,

the 2960S has the IOS version: c2960s-universalk9-mz.122-53.SE2.bin. And the 2960 has the IOS version: c2960-lanbase-mz.122-35.SE5.bin.

Thanks.

Regards.

David.

Hi.

Can you please include the output from the following command run on the 2960S?:

show snmp

It would be helpful if you could also include a show run from the 2960S as well.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: