01-08-2015 11:13 AM - edited 03-07-2019 10:08 PM
There are 2 3760g catalyst stacked using 2 StackWise cables.
Then the 2960s are stacked using 4 ports as etherchannels.
The switches work fine. Now where I’m having a problem is I want to set up a second etherchannel between the 3760s and the 2960s. I tried using the same config but when I do a show etherchannel summary I see the channel is down.
Any ideas?
here is a diagram
Here are the configs
SWITCH 1
!
! Last configuration change at 04:50:01 UTC Tue Mar 16 1993
!
version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Switch1
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
switch 1 provision ws-c3750g-48ps
switch 2 provision ws-c3750g-48ps
system mtu routing 1500
no ip domain-lookup
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree vlan 1 priority 24576
!
vlan internal allocation policy ascending
!
ip ssh version 2
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Port-channel2
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface range GigabitEthernet1/0/1-48 , 2/0/1-44
switchport mode access
spanning-tree portfast
!
!
interface GigabitEthernet2/0/45
switchport trunk encapsulation dot1q
switchport mode trunk
speed 1000
duplex full
channel-protocol lacp
channel-group 2 mode active
!
interface GigabitEthernet2/0/46
switchport trunk encapsulation dot1q
switchport mode trunk
speed 1000
duplex full
channel-protocol lacp
channel-group 2 mode active
!
interface GigabitEthernet2/0/47
switchport trunk encapsulation dot1q
switchport mode trunk
speed 1000
duplex full
channel-protocol lacp
channel-group 2 mode active
!
interface GigabitEthernet2/0/48
switchport trunk encapsulation dot1q
switchport mode trunk
speed 1000
duplex full
!
!
interface Vlan1
ip address 192.168.5.2 255.255.255.0
!
ip http server
ip http secure-server
!
!
!
!
!
!
line con 0
logging synchronous
line vty 0 4
no login
transport input ssh
line vty 5 15
no login
!
end
Switch 3
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Switch3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
system mtu routing 1500
ip subnet-zero
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
interface Port-channel1
switchport mode trunk
!
interface Port-channel2
switchport mode trunk
!
interface range GigabitEthernet0/1-41
switchport mode access
spanning-tree portfast
!
!
interface GigabitEthernet0/42
switchport mode trunk
speed 1000
duplex full
channel-protocol lacp
channel-group 2 mode active
!
interface GigabitEthernet0/43
switchport mode trunk
speed 1000
duplex full
channel-protocol lacp
channel-group 2 mode active
!
interface GigabitEthernet0/44
switchport mode trunk
speed 1000
duplex full
channel-protocol lacp
channel-group 2 mode active
!
interface GigabitEthernet0/45
switchport mode trunk
channel-protocol lacp
channel-group 1 mode active
!
interface GigabitEthernet0/46
switchport mode trunk
channel-protocol lacp
channel-group 1 mode active
!
interface GigabitEthernet0/47
switchport mode trunk
channel-protocol lacp
channel-group 1 mode active
!
interface GigabitEthernet0/48
switchport mode trunk
channel-protocol lacp
channel-group 1 mode active
!
interface Vlan1
ip address 192.168.5.3 255.255.255.0
no ip route-cache
!
ip http server
ip http secure-server
!
control-plane
!
!
line con 0
logging synchronous
line vty 0 4
no login
line vty 5 15
no login
!
end
Switch 4
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Switch4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
system mtu routing 1500
ip subnet-zero
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
interface Port-channel1
switchport mode trunk
!
interface Port-channel2
!
interface range GigabitEthernet0/1-44
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/45
switchport mode trunk
channel-protocol lacp
channel-group 1 mode active
!
interface GigabitEthernet0/46
switchport mode trunk
channel-protocol lacp
channel-group 1 mode active
!
interface GigabitEthernet0/47
switchport mode trunk
channel-protocol lacp
channel-group 1 mode active
!
interface GigabitEthernet0/48
switchport mode trunk
channel-protocol lacp
channel-group 1 mode active
!
interface Vlan1
ip address 192.168.5.4 255.255.255.0
no ip route-cache
!
no ip http server
no ip http secure-server
!
control-plane
!
!
line con 0
logging synchronous
line vty 0 4
no login
line vty 5 15
no login
!
end
Here is a show ethercahnnel detail
Switch3#show etherchannel detail
Channel-group listing:
----------------------
Group: 1
----------
Group state = L2
Ports: 4 Maxports = 16
Port-channels: 1 Max Port-channels = 16
Protocol: LACP
Minimum Links: 0
Ports in the group:
-------------------
Port: Gi0/45
------------
Port state = Up Mstr Assoc In-Bndl
Channel group = 1 Mode = Active Gcchange = -
Port-channel = Po1 GC = - Pseudo port-channel = Po1
Port index = 0 Load = 0x00 Protocol = LACP
Flags: S - Device is sending Slow LACPDUs F - Device is sending fast LACPDUs.
A - Device is in active mode. P - Device is in passive mode.
Local information:
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Gi0/45 SA bndl 32768 0x1 0x1 0x2D 0x3D
Partner's information:
LACP port Admin Oper Port Port
Port Flags Priority Dev ID Age key Key Number State
Gi0/45 SA 32768 ec44.767f.ef80 20s 0x0 0x1 0x2D 0x3D
Age of the port in the current state: 0d:03h:05m:57s
Port: Gi0/46
------------
Port state = Up Mstr Assoc In-Bndl
Channel group = 1 Mode = Active Gcchange = -
Port-channel = Po1 GC = - Pseudo port-channel = Po1
Port index = 0 Load = 0x00 Protocol = LACP
Flags: S - Device is sending Slow LACPDUs F - Device is sending fast LACPDUs.
A - Device is in active mode. P - Device is in passive mode.
Local information:
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Gi0/46 SA bndl 32768 0x1 0x1 0x2E 0x3D
Partner's information:
LACP port Admin Oper Port Port
Port Flags Priority Dev ID Age key Key Number State
Gi0/46 SA 32768 ec44.767f.ef80 6s 0x0 0x1 0x2E 0x3D
Age of the port in the current state: 0d:03h:05m:53s
Port: Gi0/47
------------
Port state = Up Mstr Assoc In-Bndl
Channel group = 1 Mode = Active Gcchange = -
Port-channel = Po1 GC = - Pseudo port-channel = Po1
Port index = 0 Load = 0x00 Protocol = LACP
Flags: S - Device is sending Slow LACPDUs F - Device is sending fast LACPDUs.
A - Device is in active mode. P - Device is in passive mode.
Local information:
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Gi0/47 SA bndl 32768 0x1 0x1 0x2F 0x3D
Partner's information:
LACP port Admin Oper Port Port
Port Flags Priority Dev ID Age key Key Number State
Gi0/47 SA 32768 ec44.767f.ef80 24s 0x0 0x1 0x2F 0x3D
Age of the port in the current state: 0d:03h:05m:54s
Port: Gi0/48
------------
Port state = Up Mstr Assoc In-Bndl
Channel group = 1 Mode = Active Gcchange = -
Port-channel = Po1 GC = - Pseudo port-channel = Po1
Port index = 0 Load = 0x00 Protocol = LACP
Flags: S - Device is sending Slow LACPDUs F - Device is sending fast LACPDUs.
A - Device is in active mode. P - Device is in passive mode.
Local information:
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Gi0/48 SA bndl 32768 0x1 0x1 0x30 0x3D
Partner's information:
LACP port Admin Oper Port Port
Port Flags Priority Dev ID Age key Key Number State
Gi0/48 SA 32768 ec44.767f.ef80 20s 0x0 0x1 0x30 0x3D
Age of the port in the current state: 0d:03h:05m:47s
Port-channels in the group:
---------------------------
Port-channel: Po1 (Primary Aggregator)
------------
Age of the Port-channel = 0d:03h:29m:41s
Logical slot/port = 2/1 Number of ports = 4
HotStandBy port = null
Port state = Port-channel Ag-Inuse
Protocol = LACP
Port security = Disabled
Ports in the Port-channel:
Index Load Port EC state No of bits
------+------+------+------------------+-----------
0 00 Gi0/45 Active 0
0 00 Gi0/46 Active 0
0 00 Gi0/47 Active 0
0 00 Gi0/48 Active 0
Time since last port bundled: 0d:03h:05m:49s Gi0/48
Group: 2
----------
Group state = L2
Ports: 3 Maxports = 16
Port-channels: 1 Max Port-channels = 16
Protocol: LACP
Minimum Links: 0
Ports in the group:
-------------------
Port: Gi0/42
------------
Port state = Down Not-in-Bndl
Channel group = 2 Mode = Active Gcchange = -
Port-channel = null GC = - Pseudo port-channel = Po2
Port index = 0 Load = 0x00 Protocol = LACP
Flags: S - Device is sending Slow LACPDUs F - Device is sending fast LACPDUs.
A - Device is in active mode. P - Device is in passive mode.
Local information:
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Gi0/42 SA down 32768 0x2 0x0 0x2A 0x45
Age of the port in the current state: 15d:06h:21m:09s
Port: Gi0/43
------------
Port state = Down Not-in-Bndl
Channel group = 2 Mode = Active Gcchange = -
Port-channel = null GC = - Pseudo port-channel = Po2
Port index = 0 Load = 0x00 Protocol = LACP
Flags: S - Device is sending Slow LACPDUs F - Device is sending fast LACPDUs.
A - Device is in active mode. P - Device is in passive mode.
Local information:
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Gi0/43 SA down 32768 0x2 0x0 0x2B 0x45
Age of the port in the current state: 15d:06h:21m:10s
Port: Gi0/44
------------
Port state = Down Not-in-Bndl
Channel group = 2 Mode = Active Gcchange = -
Port-channel = null GC = - Pseudo port-channel = Po2
Port index = 0 Load = 0x00 Protocol = LACP
Flags: S - Device is sending Slow LACPDUs F - Device is sending fast LACPDUs.
A - Device is in active mode. P - Device is in passive mode.
Local information:
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Gi0/44 SA down 32768 0x2 0x0 0x2C 0x45
Age of the port in the current state: 15d:06h:21m:11s
Port-channels in the group:
---------------------------
Port-channel: Po2 (Primary Aggregator)
------------
Age of the Port-channel = 0d:02h:38m:35s
Logical slot/port = 2/2 Number of ports = 0
HotStandBy port = null
Port state = Port-channel Ag-Not-Inuse
Protocol = LACP
Port security = Disabled
Switch1#show etherchannel summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
2 Po2(SD) LACP Gi2/0/45(I) Gi2/0/46(D) Gi2/0/47(D)
Channel-group listing:
----------------------
Group: 2
----------
Group state = L2
Ports: 3 Maxports = 16
Port-channels: 1 Max Port-channels = 16
Protocol: LACP
Minimum Links: 0
Ports in the group:
-------------------
Port: Gi2/0/45
------------
Port state = Up Sngl-port-Bndl Mstr Not-in-Bndl
Channel group = 2 Mode = Active Gcchange = -
Port-channel = null GC = - Pseudo port-channel = Po2
Port index = 0 Load = 0x00 Protocol = LACP
Flags: S - Device is sending Slow LACPDUs F - Device is sending fast LACPDUs.
A - Device is in active mode. P - Device is in passive mode.
Local information:
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Gi2/0/45 SA indep 32768 0x2 0x2 0x22E 0x7D
Age of the port in the current state: 0d:00h:02m:51s
Port: Gi2/0/46
------------
Port state = Down Not-in-Bndl
Channel group = 2 Mode = Active Gcchange = -
Port-channel = null GC = - Pseudo port-channel = Po2
Port index = 0 Load = 0x00 Protocol = LACP
Flags: S - Device is sending Slow LACPDUs F - Device is sending fast LACPDUs.
A - Device is in active mode. P - Device is in passive mode.
Local information:
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Gi2/0/46 SA down 32768 0x2 0x0 0x22F 0x45
--More--
*Mar 16 05:07:51.105: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet2/0/11, changed state to down
*Mar 16 05:07:53.109: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet2/0/11, changed sAge of the port in the current state: 0d:02h:36m:23s
Port: Gi2/0/47
------------
Port state = Down Not-in-Bndl
Channel group = 2 Mode = Active Gcchange = -
Port-channel = null GC = - Pseudo port-channel = Po2
Port index = 0 Load = 0x00 Protocol = LACP
Flags: S - Device is sending Slow LACPDUs F - Device is sending fast LACPDUs.
A - Device is in active mode. P - Device is in passive mode.
Local information:
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Gi2/0/47 SA down 32768 0x2 0x0 0x230 0x45
Age of the port in the current state: 0d:02h:36m:23s
Port-channels in the group:
---------------------------
Port-channel: Po2 (Primary Aggregator)
------------
Age of the Port-channel = 15d:00h:03m:40s
Logical slot/port = 10/2 Number of ports = 0
HotStandBy port = null
Port state = Port-channel Ag-Not-Inuse
Protocol = LACP
Port security = Disabled
01-09-2015 01:34 AM
Is there a reason you have hard coded the speed and duplex on the physical ports within Channel Group 2?
Presumably the ports are in a down down state?
I would remove the speed 1000 and duplex full and leave the ports to autonegotiate.
Sounds to me like the ports are not coming up at a layer 1/2 level which is why they are not being bundled into the channel group.
01-09-2015 11:00 AM
I will try it next time I'm on site but the reason I did that is because everything I've read about setting up infrastructure in general says links need to be hardcoded when it comes to infrastructure. The book "Network warrior" has a little story and warning about auto-negotiated links. In fact in the place I am currently working at we had an issue with our main WAN link going down. Turns out hard coding the link fixed the issue. The problem with auto negotiate is that when it fails it fails over to half duplex and the lowest possible speed.
But at this point I'll try anything. Someone else told me to take out the channel-group protocol command and just use channel-group mode on for both sides. This manually creates the links instead of using one of the 2 link protocols to handle everything.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide