04-18-2019 02:26 PM
I'm thinking I'm missing something simple here. I'm trying to create subinterfaces on a 1921 for a test lab. Whenever I create one, it is in admin down and will not come up when doing a no shut
Example:
interface GigabitEthernet0/1.1
description HOME
encapsulation dot1Q 1 native
ip address 192.168.1.1 255.255.255.0
Notice it does not show that its shutdown. But when I view the interface itself, its admin down:
Router#sh int gi0/1.1
GigabitEthernet0/1.1 is administratively down, line protocol is down
Also:
Router#sh ip int brief
Interface IP-Address OK? Method Status Protocol
Embedded-Service-Engine0/0 unassigned YES NVRAM administratively down down
GigabitEthernet0/0 unassigned YES NVRAM up up
GigabitEthernet0/1 unassigned YES NVRAM administratively down down
GigabitEthernet0/1.1 192.168.1.1 YES manual administratively down down
Any ideas of what I'm missing here?
Solved! Go to Solution.
04-18-2019 03:23 PM
Hi @clybumat1 ,
If the switch is connected to the router interface g0/0, then the subinterface must be g0/0.1
If you only use vlan 1, the subinterface is not necessary, since the router interfaces traffic by that vlan by default. If you are going to use another vlan number or more than one, then you need the subinterfaces.
Within the subinterfaces you must enter these commands:
encapsulation dot1q <vlan number>
ip address <ip> <mask>
Regards
04-18-2019 02:38 PM - edited 04-18-2019 02:40 PM
Hi @clybumat1 ,
Query: Did you enter the no shutdown command in the g0/1 interface?
The main interface must be UP so that all sub-interfaces are as well.
Regards
04-18-2019 02:49 PM
0/0 goes to a switch. Both 0/0 and 0/1 are unshut.
04-18-2019 02:57 PM
Hi @clybumat1 ,
could you share the result of the show running-config command?
Both your router and the switch that is connected to the g0 / 1 interface.
Regards
04-18-2019 03:07 PM
The switch is actually connected to 0/0
Router#sh run
Building configuration...
Current configuration : 1230 bytes
!
! Last configuration change at 21:12:01 UTC Thu Apr 18 2019
!
version 15.6
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
ethernet lmi ce
!
!
!
!
!
!
!
!
!
!
!
!
no ip domain lookup
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
license udi pid CISCO1921/K9 sn FTX18048326
!
!
vtp mode transparent
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description Uplink to switch
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/1.1
description HOME
encapsulation dot1Q 1 native
ip address 192.168.1.1 255.255.255.0
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
no vstack
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
login
transport input telnet
transport output telnet
!
scheduler allocate 20000 1000
!
end
Switch:
witch#sh run
Building configuration...
Current configuration : 920 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
enable secret 5 $1$i4m8$FiqkcfIn1y2KHvSGT/Jxa0
!
ip subnet-zero
!
no ip domain-lookup
vtp mode transparent
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface GigabitEthernet0/1
description Uplink to Router
switchport mode trunk
!
interface Vlan1
description #HOME#
ip address 192.168.1.2 255.255.255.0
no ip route-cache
!
ip default-gateway 192.168.1.1
ip http server
!
line con 0
line vty 0 4
login
transport input telnet
transport output telnet
line vty 5 15
login
!
!
end
Switch#
04-18-2019 03:23 PM
Hi @clybumat1 ,
If the switch is connected to the router interface g0/0, then the subinterface must be g0/0.1
If you only use vlan 1, the subinterface is not necessary, since the router interfaces traffic by that vlan by default. If you are going to use another vlan number or more than one, then you need the subinterfaces.
Within the subinterfaces you must enter these commands:
encapsulation dot1q <vlan number>
ip address <ip> <mask>
Regards
04-18-2019 03:48 PM
04-18-2019 02:42 PM
GigabitEthernet0/0 unassigned YES NVRAM up up < -- your main interface up.
GigabitEthernet0/1 unassigned YES NVRAM administratively down down <-- go to sub interface unshut
GigabitEthernet0/1.1 192.168.1.1 YES manual administratively down down <-- go to sub interface unshut
04-18-2019 02:51 PM
@balaji.bandi wrote:GigabitEthernet0/0 unassigned YES NVRAM up up < -- your main interface up.
GigabitEthernet0/1 unassigned YES NVRAM administratively down down <-- go to sub interface unshut
GigabitEthernet0/1.1 192.168.1.1 YES manual administratively down down <-- go to sub interface unshut
Yes that is what I have tried. I go to unshut the sub interface and and still stays admin down..
04-18-2019 02:59 PM
Can you post full config of both the side ? of the device please to verify.
04-18-2019 03:26 PM
Yes and good catch
may be you looking to subinterface G0/0 not G0/1 - I guess ?
GigabitEthernet0/1 unassigned YES NVRAM administratively down down <-- go to sub interface unshut
GigabitEthernet0/1.1 192.168.1.1 YES manual administratively down down <-- go to sub interface unshut
04-18-2019 03:21 PM
Hello,
I am not clear on what you have physically connected to GigabitEthernet0/1...GigabitEthernet0/0 goes to the switch, what does GigabitEthernet0/1 go to ?
08-01-2019 01:24 PM
This is a bug, you need add "no ip address" under physical interface.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide