06-13-2017 11:14 AM - edited 03-08-2019 10:57 AM
Hi,
I want to extend a subnet from /24 to /23.
My plan is as follows:
1) Change the SVI subnet from /24 to /23.
2) Change the subnet mask on the servers in this subnet from /24 to /23.
My question is concerning the servers that belongs to this subnet, after I do step (1) and change the SVI subnet, will the servers be able to communicate in the interim time until I change their subnet mask to /23? or they will be isolated until I change their subnet to match the SVI?
Thanks in advance
06-13-2017 11:59 AM
Hi
The servers already into the /24 will be able to communicate during the procedure, because they are going to use the same gateway unless you change it.
Please take in consideration that increase a subnet from /24 to /23 you consider that the octet of the network segment to modify should begin with zero or multiple of 2, example:
Correct
192.168.0.0/24 to 192.168.0.0/23
10.0.2.0/24 to 10.0.2.0/23
Incorrect
192.168.1.0/24 to 192.168.1.0/23
10.0.5.0/24 to 10.0.5.0/23
it will not be accepted on the devices.
Also remember to change the subnet mask on the routing protocols and firewalls.
Hope it is useful
:-)
06-13-2017 12:41 PM
An easy way to test it, is:
configure a switch
Switch Layer 3 connected to 2 PC.
SWITCH
ip routing
vlan 10,20
interface vlan 10
ip add 192.168.10.1 255.255.255.0
no shutdown
interface fa0/1
description TO PC1
switchport
switchport access vlan 10
switchport mode access
no shutdown
interface vlan 20
ip add 192.168.20.1 255.255.255.0
no shutdown
interface fa0/1
description TO PC2
switchport
switchport access vlan 20
switchport mode access
no shutdown
PC1
NIC: 192.168.10.101 255.255.255.0 gateway 192.168.10.1
You can make an extended ping to the IP 192.168.20.101, it will be successful. then change the SVI to the mask /23
PC1
NIC: 192.168.20.101 255.255.255.0 gateway 192.168.10.1
SWITCH
interface vlan 10
ip add 192.168.10.1 255.255.254.0
no shutdown
You will see the PC will be still able to ping the IP 192.168.20.101
Now if you change the IP of the SVI instead 192.168.11.1, you will not able to ping anymore until you change the subnet mask on the PC.
06-13-2017 12:01 PM
Hi,
It should all work fine since the ip addresses are not changing. The ip addresses are in the same subnet when the subnet is a /24 or /23.
Devices use the subnet mask to determine if a host is on the same subnet or not. In your case, your devices will always resolve to the same subnet.
Thanks
John
06-13-2017 03:15 PM
I want to extend a subnet from /24 to /23.
A non-disruptive method is to just create a secondary IP address range.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide