08-15-2007 07:50 PM - edited 03-05-2019 05:55 PM
Hi all
If i have Layer3 devices connected between them. I want to routing and speaking with ip address so i have 2 choices between i create svi and setup configure as routed port (no switchport). How could i choose between them to the most efficiency
thanks
08-15-2007 09:17 PM
Hi Friend,
There is a difference the way both the connection works. Although they will have the same purpose but there is the difference the way the switch ports will work.
In case of a SVI you will have eventually a Layer-2 link between the switches. This will run your normal STP and other control traffic between the switches.This will extend your STP domain from a switch to the other switch.The ports will go thorugh the normal STP states and in case of a link flap or link going dowm/coming back the recovery time will be a little high.
In case of a routed port between the switches,you will have a layer 3 link between the switches and will work as a normal router port. There will no STP running on the ports and the STP domain will not be extended beyond the downstream switches.Applring layer3 features like ACL's,PBR's will be a ltille easy in this case.
The Disadvantage of running routed ports is that each port will be a separate network and you will have to manage a large number of IP subnets on the network. Running a routing protocol will be a good idea in this case.
HTH
Ankur
*Pls rate all helpfull post
06-16-2008 04:43 PM
Hello,
In term of performance would you say one is better than other?
Also what is the problem with SVI and ACLs and PBR?
thank you.
06-16-2008 07:17 PM
Normal L2 switches have Vlan1 by default..this is sort of SVI.
SVI allow you to do intervlan routing w/o involving a router.Also another notable point is the hardware for the SVI interface u create is an EtherSVI .
Choice of SVI's or routed ports depends on wat devices are on the other end of the connection.
This can be explained by 2 scenario's.We have 2 hosts on different vlans trying to communicate with an L3 MLS in between.
*first is using SVI::The L3 will allow Intervlan routing w/o a router.We create 2 SVI's with int vlan XX command alongwith the ip assigned on it.
We'll have to enable ip routing on an L3 switch as its off by default.With this hosts should ip of the respective vlan SVI's as their gateway and they will communicate.
*Ports on a MLS will run as L2 by default.To change this to routed port..use no switchport alongwith the ip address on the interface.Then enable routing using some dynamic protocol and its done.
03-05-2023 08:21 AM
Let's say we have three switches: sw1 <--> sw2 <--> sw3
Between sw1 and sw2 is P2P link with routed ports. Between sw2 and sw3 is trunk and both switches have vlan interface 100.
The ping from sw1 routed port to vlan interface on sw3 will not work, right? In what setup would ping work?
03-05-2023 09:38 AM
In the environment that you describe it is quite possible for ping to be successful between sw1 routed port and sw3 SVI. The following conditions must be met for this to happen:
- there must be an IP subnet configured on both routed ports of sw1 and sw2.
- there must be a different IP subnet configured on the SVI for vlan 100 of sw2 and sw3.
- ip routing must be enabled on sw2.
If these are true then ping should be successful. If any one of these is not true then ping will fail.
03-05-2023 09:44 AM
BTW:
This is Rick's version (should work fine too):
!L2sw1
interface e0
no switchport
ip address 192.168.1.2 255.255.255.0
ip default-gateway 192.168.1.2
!L3sw2
ip routing
interface e0
no switchport
ip address 192.168.1.1 255.255.255.0
interface e1
switchport mode trunk
interface vlan 100
ip address 192.168.2.1 255.255.255.0
no shut
!L2sw3
interface e1
switchport mode trunk
interface vlan 100
ip address 192.168.2.2 255.255.255.0
no shut
ip default-gateway 192.168.2.1
03-05-2023 11:43 AM
Without seeing your reply, I have just configured myself something similar and it worked. I have used default route instead of ip default-gateway. Nonetheless, many thanks!
03-05-2023 12:03 PM
Great!
BTW, default-gateway and default-route accomplish the same but the former implies you're not routing while the latter does (so I believe).
Also if sw2 is proxying, neither sw1 or sw2 might need either default gateway or route (possibly why Rick didn't mention either).
03-05-2023 01:01 PM
What do you mean by "proxying"?
03-05-2023 03:16 PM
I believe that he was referring to proxy-arp, in which a device responds to an arp request for a destination that is actually remote.
Joseph points out that I did not mention default-gateway as a requirement in my suggestion for sw1 and sw3, suggesting that I was making an assumption about configuration of the switches. He is correct that I was making an assumption and that having a correct default-gateway is indeed part of the requirement.
03-05-2023 03:47 PM
03-05-2023 09:38 AM
You implying switches 1 and 2 or L3 switches, possibly switch 3 also?
"The ping from sw1 routed port to vlan interface on sw3 will not work, right?"
Incorrect, it can work.
"In what setup would ping work?"
(more or less)
!L3sw1
ip routing
interface e0
no switchport
ip address 192.168.1.2 255.255.255.0
route 0.0.0.0 0.0.0.0 192.168.1.2
!L3sw2
ip routing
interface e0
no switchport
ip address 192.168.1.1 255.255.255.0
interface e1
switchport mode trunk
interface vlan 100
ip address 192.168.2.1 255.255.255.0
no shut
!L3sw3
ip routing
interface e1
switchport mode trunk
interface vlan 100
ip address 192.168.2.2 255.255.255.0
no shut
route 0.0.0.0 0.0.0.0 192.168.2.1
03-05-2023 09:45 AM
It certainly makes it easier if you enable ip routing on all 3 switches, and if you do this the ping absolutely will work. I believe that with appropriate ip default-gateway configuration on sw1 and sw3 that it should work with ip routing on just sw2.
03-05-2023 11:53 AM - edited 03-05-2023 11:54 AM
Agreed. No doubt you were composting your reply to mine concurrently with my "example" reply to yours.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide