05-15-2023 09:09 AM - edited 05-15-2023 09:10 AM
Hello,
I've a wireless bridge setup to connect two switches together. Ruckus APs are being used to bridg the core network to a C2960. We recently had an issue where one of the ruckus APs failed, so it has been decided to setup a secondary connection with the end goal of replacing the Ruckus APs. This concerns Cisco Aironet 1830s in mobility express
SW03--->Ruckus AP)))(((Ruckus AP<---SW50
When enabling the interface on SW50 that the aironet AP is on , I got the following error.
May 15 14:37:15.240: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/4, changed state to up
May 15 14:37:17.246: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/4, changed state to up
May 15 14:39:03.371: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/4, changed state to down
May 15 14:39:04.375: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/4, changed state to down
May 15 14:39:07.097: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/4, changed state to up
May 15 14:39:09.104: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/4, changed state to up
May 15 14:39:55.578: %SW_MATM-4-MACFLAP_NOTIF: Host xxxx.yyyy.yyyy in vlan 10 is flapping between port Gi1/0/4 and port Gi1/0/1
May 15 14:39:57.091: %SW_MATM-4-MACFLAP_NOTIF: Host xxxx.yyyy.yyyy in vlan 10 is flapping between port Gi1/0/4 and port Gi1/0/1
May 15 14:39:57.899: %SW_MATM-4-MACFLAP_NOTIF: Host yyyy.yyyy.xxxx in vlan 10 is flapping between port Gi1/0/1 and port Gi1/0/4
May 15 14:39:58.615: %SW_MATM-4-MACFLAP_NOTIF: Host yyyy.xxxx.yyyy in vlan 10 is flapping between port Gi1/0/1 and port Gi1/0/4
May 15 14:39:58.681: %SW_MATM-4-MACFLAP_NOTIF: Host xxxx.xxxx.xxxx in vlan 10 is flapping between port Gi1/0/1 and port Gi1/0/4
May 15 14:39:58.860: %SW_MATM-4-MACFLAP_NOTIF: Host xxxx.yyyy.xxxx in vlan 10 is flapping between port Gi1/0/4 and port Gi1/0/1
May 15 14:39:59.381: %SW_MATM-4-MACFLAP_NOTIF: Host yyyy.xxxx.yyyy in vlan 10 is flapping between port Gi1/0/4 and port Gi1/0/1
May 15 14:39:59.699: %SW_MATM-4-MACFLAP_NOTIF: Host yyyy.xxxx.xxxx in vlan 10 is flapping between port Gi1/0/4 and port Gi1/0/1
The end goal is to have 2 sets of APs providing a bridge. What would I need to do to keep the flapping from happening?
Solved! Go to Solution.
05-17-2023 05:08 AM
Yes. And this config is not ok.
switchport access vlan 10
switchport trunk native vlan 10
switchport trunk allowed vlan 1,10,100,600
switchport mode trunk
You should not put the interace in Acces and in trunk. If you are suing native vlan, this is enough. But, the mac address flap must stop with you isolated both APs ports in different vlans.
05-15-2023 10:29 AM
Hi
Let me see if I understood. You have 2 switches and you had a bridge between them using Ruckes and not you configured another bridge with Cisco AP.
Did you used the same vlan for all this ports ? If you did, you kind create a loop.
05-15-2023 10:33 AM
yes, the interfaces on the switches that have the ruckus AP and the Cisco AP are on VLAN 10.
I was thinking that was the issue, but I'm wondering what I could do to not cause the loop, maybe put the ports that the Cisco APs are on a different VLAN?
05-15-2023 10:42 AM
Exactly. Imagine that tihs AP in bridge must have the same function as you extending a cable from one switch to another. We can not do that with two cables. Either spanning tree will block, if enable or you can create a loop.
Put those connectons in different vlans and see if works.
05-17-2023 04:27 AM
@Flavio Miranda wrote:Exactly. Imagine that tihs AP in bridge must have the same function as you extending a cable from one switch to another. We can not do that with two cables. Either spanning tree will block, if enable or you can create a loop.
Put those connectons in different vlans and see if works.
Ruckus AP
interface GigabitEthernet1/0/1
switchport trunk native vlan 10
switchport trunk allowed vlan 1,10,100,600
switchport mode trunk
ip dhcp snooping trust
Cisco Aironet AP
interface GigabitEthernet1/0/4
switchport access vlan 10
switchport trunk native vlan 10
switchport trunk allowed vlan 1,10,100,600
switchport mode trunk
is the current config, do you mean moving the native trunk vlan from vlan 10 to something else on gi1/0/4 ?
05-17-2023 05:08 AM
Yes. And this config is not ok.
switchport access vlan 10
switchport trunk native vlan 10
switchport trunk allowed vlan 1,10,100,600
switchport mode trunk
You should not put the interace in Acces and in trunk. If you are suing native vlan, this is enough. But, the mac address flap must stop with you isolated both APs ports in different vlans.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide