cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

585
Views
5
Helpful
8
Replies
Highlighted
Participant

Switch management vlan IP unreachable

Dear All,

let me know why my switch management IP cannot ping from anywhere.MY pc can ping to router and vlan interfaces.router can ping vlan interface itself. router cannot ping to  switch management IP. Router Model is c892 and switches model is ws-c2960+24tc-s (LanLite).

Switch have have 4 vlan and carry traffic with trunk to router and router have 4 vlan interfaces.(i didn't use router on the stick .

let me know which IP should i need to set as ip default-gateway? 

i set management interface ip as default gateway in switches but cannot solve.

PLease see below config and help me to solve.

Router config:

vlan 20

vlan 21

vlan 22

vlan 23

vlan 77

interface Vlan20

description management vlan
ip address 1.1.8.1 255.255.255.0
!
interface Vlan21
ip address 1.1.7.1 255.255.255.0
!
interface Vlan22
ip address 1.1.6.1 255.255.255.0
!
interface Vlan23
ip address 1.1.5.1 255.255.255.0

 

nterface GigabitEthernet7
description LAN LINK to Switch
switchport trunk native vlan 77
switchport trunk allowed vlan 1,2,20-24,1001-1005
switchport mode trunk

 

Switch Config:

vlan 20

discription management vlan

vlan 21

vlan 22

vlan 23

vlan 77

interface Vlan20
description MGMT VLAN
ip address 1.1.8.100 255.255.255.0

 

interface range Gi 0/1
description UPLink to Router
switchport mode trunk
switchport trunk allowed vlan 20,21,22,23,24,1,1002,1005

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
VIP Advocate

Re: Switch management vlan IP unreachable

Hi,

There will not things:

1. Check your switch configuration, If there is a command "IP routing" then you must remove the command (no ip routing) first. 

2. "IP default-gateway 1.1.8.1" must be configured on the switch means VLAN 20 Gateway IP.

Last thing: There is interface configuration is also showing a VLAN mismatch. 

 

Regards,

Deepak Kumar

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution If this comment will make help you!
8 REPLIES 8
Hall of Fame Guru

Re: Switch management vlan IP unreachable

 

Can you post a "sh ip int br" from both devices. 

 

Jon

VIP Advocate

Re: Switch management vlan IP unreachable

Hi,

There will not things:

1. Check your switch configuration, If there is a command "IP routing" then you must remove the command (no ip routing) first. 

2. "IP default-gateway 1.1.8.1" must be configured on the switch means VLAN 20 Gateway IP.

Last thing: There is interface configuration is also showing a VLAN mismatch. 

 

Regards,

Deepak Kumar

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution If this comment will make help you!
Participant

Re: Switch management vlan IP unreachable

hi,

i am showing sample config.in my real device i use /27 for all VLAN.for example. I use 10.1.8.0/27 for vlan200,10.1.8.64/27 for vlan201,10.1.8.94/27 for vlan 202 (mgmt network).If i use vlan 200 as mgmt network and use 10.1.8.1 as gateway,i can reachable to switch and swich can ping anywhere.but if i use other vlan as mgmt net,switch cannot reach anywhere.

Everyone's tags (3)
Hall of Fame Guru

Re: Switch management vlan IP unreachable

 

Best to show real configuration in future. 

 

If you use a different vlan for management are you also changing the default gateway to an IP from the new subnet ? 

 

Jon

VIP Advocate

Re: Switch management vlan IP unreachable

Hi,

Please post complete configuration and hopping that you missed a command on the switch:

ip default-gateway 1.1.8.1

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution If this comment will make help you!
Beginner

Re: Switch management vlan IP unreachable

This maybe a stupid question but why do you have a trunk interface and vlans on your router? Switch port modules?

VIP Advocate

Re: Switch management vlan IP unreachable

Hi,

A trunk interface is used to carry multiple VLAN traffic on a single interface. In your case, you used trunk port because you want to carry VLAN 2, 20, 21, 22 etc on a single interface. 

 

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution If this comment will make help you!
Hall of Fame Master

Re: Switch management vlan IP unreachable

There was a request for the output of show ip int brief from both devices. I believe that this output would be helpful. In addition would the original poster give us the output of show cdp neighbor from both devices and the output of show interface status from the switch?

 

HTH

 

Rick

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards