cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
341
Views
1
Helpful
7
Replies

Switch stopped responding to ping through trunk port

fabioairoldi
Level 1
Level 1

Hey all,

 

I have several switches (Catalyst 9200) IOS version 17.10, all connected to a CORE switch (WS-C3850-24XS-E)

All 9200 are connected through trunk ports, whose native vlan i is the management vlan where all switches have IP adresses.

Now a few days ago, one (and only one) of those switches stopped responding to ping, while still working and forwarding traffic just fine.

As far as I know there were no changes to config both Core-side and 9200-side. By checking the configs of both the core and the 9200, everything is fine. If I connect directly to the 9200 on an access port configured on the management VLAN, I can ping it just fine.

If I issue show cdp neighbors on the core, I can see the non-pinging switch. The IP config and default gateway are properly configured, but from the non-pinging switch I cannot ping anything, not even my default gateway.

What's really stumping me is that every other 9200 has the same config and has no issues. What could I be missing?

 

thanks in advance

F.

 

1 Accepted Solution

Accepted Solutions

Hello,

I do not want to state the obvious, but very often, when these issues occur, rebooting the switch might help.

View solution in original post

7 Replies 7

More likely 

1- mgmt vlan not allow in trunk

Show interface trunk 

2- vlan is missing or down

Show vlan breif 

MHM

1 - No, show int trunk shows the VLAN allowed on the trunk just as it does on every other 9200

2 -No,unfortunately I had already checked that... VLAN is up and active (otherwise I wouldn't even be able to ping the switch by directly connecting to access port).

 

thanks for the reply anyway

any other ideas?

 

Can i see 

Show interface trunk 

MHM

Hello,

I do not want to state the obvious, but very often, when these issues occur, rebooting the switch might help.

Yeds, as this is a very crucial Switch to production, I was trying to avoid doing so; but if everything else fails I'll come in extremely early and try that.

 

@MHM Cisco World 

SW_97#sh int tru

Port Mode Encapsulation Status Native vlan
Te1/1/1 on 802.1q trunking 1

Port Vlans allowed on trunk
Te1/1/1 1-4094

Port Vlans allowed and active in management domain
Te1/1/1 1,5-12,17-18,20-23,30,40,50,60,70-72,75-76,79-84,86,90-91,101,110-111,127,210-215,220,230-231,240-241,301-308,311-314,350,401,430,508,550,900,920,999-1000

Port Vlans in spanning tree forwarding state and not pruned
Te1/1/1 1,5-12,17-18,20-23,30,40,50,60,70-72,75-76,79-84,86,90-91,101,110-111,127,210-215,220,231,240-241,301-308,311-314,350,401,430,508,550,900,920,999-1000