cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
5294
Views
0
Helpful
2
Replies

Switchport trunk allowed vlan

Jerry Ayers
Level 1
Level 1

          I have a port channel that is set up as a trunk. I currently am allowing certain vlans but would like to change it to add another vlans. I want to know if I change it will I experience any down time.

Example

(Current Port-channel and ports)

interface Port-channel1

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 50

switchport trunk allowed vlan 1,25,30,35,50,192

switchport mode trunk

no ip address

spanning-tree portfast trunk

spanning-tree bpduguard enable

interface TenGigabitEthernet8/1

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 50

switchport trunk allowed vlan 1,25,30,35,50,192

switchport mode trunk

no ip address

spanning-tree portfast trunk

spanning-tree bpduguard enable

channel-group 1 mode on

interface TenGigabitEthernet9/1

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 50

switchport trunk allowed vlan 1,25,30,35,50,192

switchport mode trunk

no ip address

spanning-tree portfast trunk

spanning-tree bpduguard enable

channel-group 1 mode on

I want to change by using these commands

conf t
interface Port-channel1
switchport trunk allowed vlan add 10

interface TenGigabitEthernet8/1
switchport trunk allowed vlan add 10

interface TenGigabitEthernet9/1
switchport trunk allowed vlan add 10

Should I expect to experience any down time.

2 Replies 2

mfurnival
Level 4
Level 4

No, you can use the "add" command and it will not disrupt traffic.

Bilal Nawaz
VIP Alumni
VIP Alumni

Hello, down time is minimal, and its good you are taking note of this down time if you do not use the key word, you are also correct with the 'add' command, this is a key word in the command where it will add the vlan instead of removing all the vlans and re-applying them to the trunk.

Lets say I have a trunk and its already trunking vlans from 5 - 100. I want to add vlans 1,2,3 to the trunk.

If you was to do this e.g

Switchport trunk allowed vlan 1,2,3,5-100

This would temporarily remove all vlans and re-apply the vlans on the trunk.

But instead of just doing this you can do this:

Switchport trunk allowed vlan add 1,2,3

The trunk will then be configured to cater for the additional vlans without removing the vlans, and results in 0 downtime.

This is specified by the 'add' key word. Also there is a 'remove' key word if you want to remove vlans from the trunk

NOTE:
In your case you only need to apply the add command to the port channel interface, not the physical interfaces!

I.e.

conf t
!
interface Port-channel1
switchport trunk allowed vlan add 10

Then this configuration will also take effect on the port channel members.
Hope this helps

Sent from Cisco Technical Support iPhone App

Please rate useful posts & remember to mark any solved questions as answered. Thank you.
Review Cisco Networking products for a $25 gift card