cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

232
Views
0
Helpful
3
Replies
Highlighted
Beginner

Tagged vs untagged traffic on cisco 3560 simple question

Hello, 

 I'm a newbie to Cisco switches, on previous ones my config would be simple:

 

port 1 -> router (tagged traffic for vlan 2,3, maybe untagged for mgmt vlan to access the switch)

ports 10-20 -> untagged traffic for vlan 2

ports 21-24 -> untagged traffic for vlan 3

 

and that's it.

 

Here, to make a tagged port on my 3560 as far as I understood I need to:

 

conf t

interface gi0/x

switchport mode trunk

switchport access vlan x ??

 

when I do:

 

show interface gi0/x switchport  I see:

 

Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk

...

Access Mode VLAN: x (xxxx)
Trunking Native Mode VLAN: 1 (default)

 

On untagged I do:

switchport mode access

switchport access vlan x

 

and I think that the untagged one should be correct :)

 To tag a vlan I need to add it to a trunking native mode vlan or access mode vlan? 

 

Thank you in advance for any responses!

Everyone's tags (5)
1 ACCEPTED SOLUTION

Accepted Solutions
VIP Expert

Re: Tagged vs untagged traffic on cisco 3560 simple question

Hi,

Are you using one vlan for all these devices? 

for trunk all you need is this:

 

conf t

interface gi0/x

switchport mode trunk

If you want to be specific you can add the vlans to your trunk port

switchport trunk allowed vlan x,x,x

 

 

For access port your config is correct

On untagged I do:

switchport mode access

switchport access vlan x

HTH

 

 

 

 

View solution in original post

3 REPLIES 3
VIP Expert

Re: Tagged vs untagged traffic on cisco 3560 simple question

Hi,

Are you using one vlan for all these devices? 

for trunk all you need is this:

 

conf t

interface gi0/x

switchport mode trunk

If you want to be specific you can add the vlans to your trunk port

switchport trunk allowed vlan x,x,x

 

 

For access port your config is correct

On untagged I do:

switchport mode access

switchport access vlan x

HTH

 

 

 

 

View solution in original post

Beginner

Re: Tagged vs untagged traffic on cisco 3560 simple question

Hi,

 Thanks for the response, I didn't notice "trunk allowed VLANs" :). In this particular case, I'm using only two VLANs which are tagged to separate routers as there are two WAN connections which had to be separated this way, that's why I wanted to specify which VLAN should be tagged to a specific port.

 

 

VIP Expert

Re: Tagged vs untagged traffic on cisco 3560 simple question

There should be command under the interface that is trunked. Here is an example.

Also if you are using older software you may have to set the encapsulation. See link:

switchport trunk allowed vlan  2, 10

or 

switchport trunk allowed vlan  add 2, 10

 

https://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst3560/software/release/12-2_55_se/configuration/guide/3560_scg/swvlan.html

HTH

CreatePlease to create content
Content for Community-Ad