cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
18213
Views
5
Helpful
2
Replies

trunk interfaces not showing ?

tedauction
Level 1
Level 1

Hello, in the following C3650X-48 switch config, I have a number of trunk interfaces, however when I run the command 'sh int trunk' I do not see any trunks displayed.

Also when I run the command 'sh int gi0/1 trunk' it tells me there are no vlans allowed, however I have explicitly allowed vlan 35. Am I missing something here ?

Thank you kindly.

mySwitch(config-if)# do sh int trunk

mySwitch(config-if)#do sh int gi0/1 trunk

Port Mode Encapsulation Status Native vlan
Gi0/1 on 802.1q other 1

Port Vlans allowed on trunk
Gi0/1 none

Port Vlans allowed and active in management domain
Gi0/1 none

Port Vlans in spanning tree forwarding state and not pruned
Gi0/1 none

Current configuration : 10615 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname mySwitch
!
boot-start-marker
boot-end-marker
!
logging buffered 409600
!
no aaa new-model
system mtu routing 1500
ip routing
!
!
no ip domain-lookup
login on-failure log
login on-success log
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
vlan internal allocation policy ascending
!
!
!
interface FastEthernet0
no ip address
no ip route-cache cef
no ip route-cache
no ip mroute-cache
!
interface GigabitEthernet0/1
description Link From IT Router
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 35
switchport mode trunk
!
interface GigabitEthernet0/2
description Link to Cisco (VLAN 30)
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 30
switchport mode trunk
!
interface GigabitEthernet0/3
description Link to Cisco (VLAN 40)
switchport access vlan 40
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/4
switchport access vlan 30
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/5
description Kordia NIC (VLAN 4)
switchport access vlan 4
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/6
description Link to VF Multicast Audio port 2
switchport access vlan 4
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/7
description Golden Eagle
switchport access vlan 35
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/8
description Magic FM55 Processor
switchport access vlan 35
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/9
description GE UPS MGT
switchport access vlan 35
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/10
switchport access vlan 30
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/11
description Breeze Processor Optimod
switchport access vlan 35
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/12
description Processor
switchport access vlan 35
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/13
description Aserv
switchport access vlan 35
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/14
descriptione Aserv
switchport access vlan 35
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/15
description Aserv
switchport access vlan 35
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/16
description Aserv
switchport access vlan 35
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/17
description Aserv
switchport access vlan 35
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/18
description Aserv
switchport access vlan 35
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/19
switchport access vlan 35
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/20
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 30
switchport mode trunk
!
interface GigabitEthernet0/21
switchport access vlan 35
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/22

switchport access vlan 35
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/23
switchport access vlan 30
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/24
switchport access vlan 35
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/25
switchport access vlan 30
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/26
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 35
switchport mode trunk
!
interface GigabitEthernet0/27
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 35
switchport mode trunk
!
interface GigabitEthernet0/28
switchport access vlan 30
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/29
switchport access vlan 30
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/30
switchport access vlan 30
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/31
switchport access vlan 35
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/32
switchport access vlan 35
switchport mode access
shutdown
spanning-tree portfast
!
interface GigabitEthernet0/33
switchport access vlan 30
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/34
switchport access vlan 30
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/35
switchport access vlan 30
switchport mode access
shutdown
spanning-tree portfast
!
interface GigabitEthernet0/36
switchport access vlan 35
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/37
switchport access vlan 35
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/38
switchport access vlan 4
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/39
switchport access vlan 35
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/40
switchport access vlan 4
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/41
switchport access vlan 35
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/42
switchport access vlan 4
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/43
switchport access vlan 35
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/44
switchport access vlan 4
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/45
switchport access vlan 35
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/46
switchport access vlan 4
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/47
switchport access vlan 35
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/48
switchport access vlan 4
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface GigabitEthernet1/3
!
interface GigabitEthernet1/4
!
interface TenGigabitEthernet1/1
!
interface TenGigabitEthernet1/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan30
ip address 10.21.210.2 255.255.255.0
!
interface Vlan35
ip address 10.23.40.2 255.255.255.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.21.210.1
no ip http server
ip http secure-server
!
ip access-list standard ACL_Restrict_SNMP
permit 10.21.250.0 0.0.0.255
permit 10.5.1.0 0.0.0.255
!
logging trap notifications
logging source-interface Vlan30
logging 10.21.250.23
snmp-server community precision RO ACL_Restrict_SNMP
!
!
line con 0
line vty 0 4
login local
transport input ssh
line vty 5 15
login local
transport input ssh
!
end

2 Accepted Solutions

Accepted Solutions

lpassmore
Level 1
Level 1

has the interface G0/1 actually connected as a trunk?  I think the 'other' in the status might be a clue.  This should say 'Trunking' if it is connected properly.

What does show interface G0/1 switchport show?

Does VLAN35 actually exist?  show vlan id 35?

View solution in original post

Hello
Looks like the other side of the trunk isnt active?

res
Paul


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

View solution in original post

2 Replies 2

lpassmore
Level 1
Level 1

has the interface G0/1 actually connected as a trunk?  I think the 'other' in the status might be a clue.  This should say 'Trunking' if it is connected properly.

What does show interface G0/1 switchport show?

Does VLAN35 actually exist?  show vlan id 35?

Hello
Looks like the other side of the trunk isnt active?

res
Paul


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul
Review Cisco Networking for a $25 gift card