cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
6305
Views
0
Helpful
2
Replies

UDP traffic Priority over TCP

dparmar89
Level 1
Level 1

How can i ensure that UDP traffic has priotity over TCP data in a network?

2 Replies 2

cadet alain
VIP Alumni
VIP Alumni

Hi,

You must implement QoS in your network.

On cisco routers this is done using MQC syntax like this:

class-map UDP_TRAFFIC

match protocol udp

class-map TCP_TRAFFIC

match protocol tcp

policy-map TRAFFIC_POLICY

class UDP_TRAFFIC

set dscp af31

class TCP_TRAFFIC

set dscp af21

int x/x

service-policy inbound TRAFFIC_POLICY

this will give priority to UDP vs TCP vs all other traffic except control plane traffic which has a higher DSCP value set

Regards.

Alain.

Don't forget to rate helpful posts.

acampbell
VIP Alumni
VIP Alumni

Hi,

You would need to use something like policmaps(QOS)

You will need to adjust interfaces access-list numbers etc to suit your set up

!

ip access-list 101

permit udp any any

!

ip access-list 102

permit tcp any any

!

!

class-map match-all UDP

match access-group 101

!

!

class-map match-all TCP

match access-group 102

!
policy-map UDP-THEN-TCP

class UDP

    priority percent 30  

class TCP

   bandwidth remaining percent 60

class class-default

   fair-queue

!

!

int fast 0/0

service-policy out UDP-THEN-TCP

!

HTH

Alex

Regards, Alex. Please rate useful posts.
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card