cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2266
Views
0
Helpful
7
Replies

Unable to communicate between vlans

I currently have an Inter-Vlan routing network using a Layer 2 switch and a Layer 3 switch, the former one manages the vlan's ports for the clients and the latter routes the communications between them. I have a trunk cable between the switches in order to do so.

Each client can ping other members on the same vlan and all of the others' vlan gateway but cannot cross that barrier and cannot ping over to the client on the other vlan.

All the network is simulated on GNS3, the L3 switch is a Cisco IOU L3 version 15.7 and the L2 switch is a Cisco IOU L2 version 15.1a

I'll share you the configuration of both switches:

L2:


!
! Last configuration change at 02:36:37 UTC Mon Apr 17 2023
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname IOU2
!
boot-start-marker
boot-end-marker
!
!
logging discriminator EXCESS severity drops 6 msg-body drops EXCESSCOLL
logging buffered 50000
logging console discriminator EXCESS
!
no aaa new-model
no ip icmp rate-limit unreachable
!
ip cef
!
!
no ip domain-lookup
no ipv6 cef
ipv6 multicast rpf use-bgp
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
vlan internal allocation policy ascending
!
ip tcp synwait-time 5
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1-100
switchport mode trunk
duplex auto
!
interface Ethernet0/1
duplex auto
!
interface Ethernet0/2
duplex auto
!
interface Ethernet0/3
duplex auto
!
interface Ethernet1/0
switchport access vlan 10
switchport mode access
duplex auto
!
interface Ethernet1/1
duplex auto
!
interface Ethernet1/2
duplex auto
!
interface Ethernet1/3
duplex auto
!
interface Ethernet2/0
switchport access vlan 20
switchport mode access
duplex auto
!
interface Ethernet2/1
duplex auto
!
interface Ethernet2/2
duplex auto
!
interface Ethernet2/3
duplex auto
!
interface Ethernet3/0
switchport access vlan 30
switchport mode access
duplex auto
!
interface Ethernet3/1
duplex auto
!
interface Ethernet3/2
duplex auto
!
interface Ethernet3/3
duplex auto
!
interface Vlan1
no ip address
!
!
router eigrp 1
network 10.10.10.0 0.0.0.255
network 10.10.20.0 0.0.0.255
network 10.10.30.0 0.0.0.255
auto-summary
!
!
no ip http server
!
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
end

 

L3:

!
!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
no service dhcp
!
hostname ESW1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip routing
no ip icmp rate-limit unreachable
!
!
no ip cef
no ip domain lookup
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
vtp file nvram:vlan.dat

!
!
ip tcp synwait-time 5
!
!
!
!
!
interface FastEthernet0/0
description *** Unused for Layer2 EtherSwitch ***
no ip address
no ip route-cache
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
duplex full
speed 100
!
interface FastEthernet1/1
duplex full
speed 100
!
interface FastEthernet1/2
duplex full
speed 100
!
interface FastEthernet1/3
duplex full
speed 100
!
interface FastEthernet1/4
duplex full
speed 100
!
interface FastEthernet1/5
duplex full
speed 100
!
interface FastEthernet1/6
duplex full
speed 100
!
interface FastEthernet1/7
duplex full
speed 100
!
interface FastEthernet1/8
duplex full
speed 100
!
interface FastEthernet1/9
duplex full
speed 100
!
interface FastEthernet1/10
duplex full
speed 100
!
interface FastEthernet1/11
duplex full
speed 100
!
interface FastEthernet1/12
duplex full
speed 100
!
interface FastEthernet1/13
duplex full
speed 100
!
interface FastEthernet1/14
duplex full
speed 100
!
interface FastEthernet1/15
switchport mode trunk
duplex full
speed 100
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
interface Vlan10
ip address 10.10.10.1 255.255.255.0
!
interface Vlan20
ip address 10.10.20.1 255.255.255.0
!
interface Vlan30
ip address 10.10.30.1 255.255.255.0
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
no cdp log mismatch duplex
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
banner exec 

***************************************************************
This is a normal Router with a SW module inside (NM-16ESW)
It has been preconfigured with hard coded speed and duplex

To create vlans use the command "vlan database" from exec mode
After creating all desired vlans use "exit" to apply the config

To view existing vlans use the command "show vlan-switch brief"

Warning: You are using an old IOS image for this router.
Please update the IOS to enable the "macro" command!
***************************************************************


!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end

 

NETWORK:

nicolasmonta1807_0-1681701414914.png

 

 

 

2 Accepted Solutions

Accepted Solutions

Hi

 The problem is in the L3 switch. You have the commamd "no ip routing". You need to run:

Conf t

 Ip routing

wr

View solution in original post

rakuntal
Level 1
Level 1

The Problem is this

 

no aaa new-model
memory-size iomem 5
no ip routing
no ip icmp rate-limit unreachable
!

Solution

IP routing enable

 

IP routing not enabled on L3

View solution in original post

7 Replies 7

Hello,

 

Did you create the L2 VLANs on the L3 switch. Creating the VLAN interface does not automatically create the L2 instance. Make sure you configured all 3 L2 VLANs.

config t

vlan 10

vlan 20

vlan 30

end

-David

Hi

 The problem is in the L3 switch. You have the commamd "no ip routing". You need to run:

Conf t

 Ip routing

wr

..

rakuntal
Level 1
Level 1

The Problem is this

 

no aaa new-model
memory-size iomem 5
no ip routing
no ip icmp rate-limit unreachable
!

Solution

IP routing enable

 

IP routing not enabled on L3

It seemed to be the routing not being enabled. Thanks for the response and sorry for the error.

Sorry can you send me the image of l3sw you use in gns3 ?

Thanks 

Sure. Here it is