cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
886
Views
5
Helpful
7
Replies

unable to ping from Access switch 2 to Router

mriswan3
Level 1
Level 1

Hi,

 

I have created a simple network topology with 2 switches and 1 router.

switch 1 is directly connected to a router1 via fe port and a switch2 is a trunk link to switch 1.

however I am unable to ping from switch 2 to router1. not sure what I did wrong. can anyone please help?

Network topology is attached in this post for your reference. 

3 Accepted Solutions

Accepted Solutions

Hello

rtr
int fa1/0
ip address 192.168.1.1 255.255.255.0
no shut

 

switch1
int fa1/1
switchport encapsulation dot1q
switchport mode trunk
no shut

int fa1/0
switchport encapsulation dot1q
switchport mode trunk
no shut


switch2
int fa1/1
switchport encapsulation dot1q
switchport mode trunk

 

int vlan 1
ip addres 192.168.1.3 255.255.255.0
no shut
ip default-gateway 192.168.1.1

 

ping 192.168.1.1



Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

View solution in original post

Hello,

 

post the full running confguration (sh run) of the switch that has this configured:

 

interface FastEthernet0/0
ip address 172.16.10.2 255.255.255.0
duplex auto
speed auto

 

If you have another interface than Vlan 1 configured with an IP address, it means this device is most likely a layer 3 device, and not a switch (layer 2) anymore.

View solution in original post

Hello

Glad to hear it..


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

View solution in original post

7 Replies 7

Leo Laohoo
Hall of Fame
Hall of Fame

Nice picture.  
Where is the config?

Hello

rtr
int fa1/0
ip address 192.168.1.1 255.255.255.0
no shut

 

switch1
int fa1/1
switchport encapsulation dot1q
switchport mode trunk
no shut

int fa1/0
switchport encapsulation dot1q
switchport mode trunk
no shut


switch2
int fa1/1
switchport encapsulation dot1q
switchport mode trunk

 

int vlan 1
ip addres 192.168.1.3 255.255.255.0
no shut
ip default-gateway 192.168.1.1

 

ping 192.168.1.1



Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Thank you Paul, 

Its indeed a great help. below are the configs that I applied but still unable to reach router from switch 2. However from switch 1 to router 1 is fine.. The idea is to ping from both switches to router even the switch2 is not directly connected to router 1..

attached Revised topology fyi. please help

 

Router 1

 

interface Ethernet0/0
ip address 192.168.1.1 255.255.255.0
full-duplex
!
!
ip forward-protocol nd

 

Switch 2

interface FastEthernet0/0
ip address 172.16.10.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
switchport mode trunk
!
interface FastEthernet1/1
switchport mode trunk
!

interface Vlan1
ip address 192.168.1.2 255.255.255.0
!
ip default-gateway 192.168.1.1
no ip http server
no ip http secure-server
ip forward-protocol nd
!
!
no cdp log mismatch duplex
!
control-plane

 

Switch 2

interface FastEthernet1/0
!
interface FastEthernet1/1
switchport mode trunk
!
!
interface Vlan1
ip address 192.168.1.3 255.255.255.0
!
!
ip default-gateway 192.168.1.1
no ip http server
no ip http secure-server
ip forward-protocol nd
!
!
!
no cdp log mismatch duplex
!
!
!
control-plane

Thanks Paul.. 

 

It has been resolved now! Greatly appreciative.

 

Here is the config I made some changes and link protocol was down when I did sh ip int bri..

I restart the interface and it works now!

 

Router 1

interface Ethernet0/0
ip address 192.168.1.1 255.255.255.0
full-duplex

 

Switch 1

 

interface FastEthernet1/0
switchport mode trunk
!
interface FastEthernet1/1
switchport mode trunk
!
interface Vlan1
ip address 192.168.1.2 255.255.255.0
!
!
ip default-gateway 192.168.1.1

 

Switch 2

 

interface FastEthernet1/1
switchport mode trunk
!
interface Vlan1
ip address 192.168.1.3 255.255.255.0
!
!
ip default-gateway 192.168.1.1

Hello

Glad to hear it..


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Hello,

 

post the full running confguration (sh run) of the switch that has this configured:

 

interface FastEthernet0/0
ip address 172.16.10.2 255.255.255.0
duplex auto
speed auto

 

If you have another interface than Vlan 1 configured with an IP address, it means this device is most likely a layer 3 device, and not a switch (layer 2) anymore.

rajeshkrinfo
Level 1
Level 1

Please find the similar scenario i have designed a topology with two Switches and One Router. Both Swithes having VLANs of 10 ports designated with respective VLANs. Port no 23 in Switch1 connected with Router as Trunk Link and Port No 24 connected with Switch2 as Trun Link.

Router#
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.1
encapsulation dot1Q 100
ip address 10.92.255.1 255.0.0.0
!
interface FastEthernet0/0.2
encapsulation dot1Q 200
ip address 20.92.255.1 255.0.0.0
!
Router#
-----------------------------------------------
SW1>
SW1#
!
interface FastEthernet0/1
switchport access vlan 100
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 100
switchport mode access
!
!
interface FastEthernet0/11
switchport access vlan 200
switchport mode access
!
interface FastEthernet0/12
switchport access vlan 200
switchport mode access
!
!
interface FastEthernet0/23
switchport mode trunk
!
interface FastEthernet0/24
switchport mode trunk
!
SW1#
-----------------------------
SW2>
SW2#
!
interface FastEthernet0/1
switchport access vlan 100
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 100
switchport mode access
!
!
interface FastEthernet0/11
switchport access vlan 200
switchport mode access
!
interface FastEthernet0/12
switchport access vlan 200
switchport mode access
!
!
interface FastEthernet0/24
switchport mode trunk
!
SW2#

Review Cisco Networking for a $25 gift card