Showing results for 
Search instead for 
Did you mean: 

Unexpected exception to CPUvector while trying to SSH on a C2960X with IOS 15.0(2a)EX5


hi everybody,


We have 2 C2960X (for spare) and because the first one gone in production suffer the GLT-C SFP bug with 15.0(2)EX5 which make him lost the uplink at random time,

I tried the 2a release. I don't know if it works better with the GLT-C SFP but since then, when I want to SSH on it (with pubkey ont password) I get a CPU error which make the switch reboot. I tried the upgrade on the second switch with the same result :

17:57:57 CET Wed Aug 19 2015: Unexpected exception to CPUvector 1100, PC = 1ABEC38
-Traceback= 0x1ABEC38z 0x2889D30z 0x429104z 0x429C28z 0x4308C4z 0x42E38Cz 0x42E738z 0xE01CE0z 0x1932E34z 0x1926A24z 0x27158E8z 0x270F928z

Writing crashinfo to flash:/crashinfo_ext/crashinfo_ext_5


Motherboard assembly number     : 73-14192-04
Power supply part number        : 341-0537-02

Model revision number           : B0
Motherboard revision number     : A0
Model number                    : WS-C2960X-48TS-L
Daughterboard assembly number   : 73-14200-03

Top Assembly Part Number        : 800-37657-02
Top Assembly Revision Number    : C0
Version ID                      : V02

Daughterboard revision number   : A0
Hardware Board Revision Number  : 0x05

Switch Ports Model              SW Version            SW Image                 
------ ----- -----              ----------            ----------               
*    1 52    WS-C2960X-48TS-L   15.0(2a)EX5           C2960X-UNIVERSALK9-M     

I suppose I will give some chance to a downgrade... Does anybody experienced something like this ?



7 Replies 7

Reza Sharifi
Hall of Fame Master Hall of Fame Master
Hall of Fame Master

Hi Guillaume,

If I remember correctly there was someone else in this forum with similar issue, but I could not find the post. This is most likely another IOS bug in the 2960x series switches. I recommend calling TAC as they will most likely recommend a downgrade or upgrade if there is a newer version out there.


Hi there,

i'm facing the same issue (exact IOS and module), 

is there any update?

thanks in advance

I Don't think so (if you stick to 15.0(2a)EX5).

Just don't configure the following and your good:

login on-success log

login on-failure log

Or better still, upgrade to an MD release such as 15.2(2)E3 .  The 15.0EX train was the first cut of code for that platform (which is always a risky thing to be running) and probably won't get any more bug fixes going forward.

Move up to something that is going to be maintained for the longer term where bugs like this either have been fixed already or will be fixed quickly going forward.

My colleges encountered the 15.2 train as a complete nightmare....

Ich Nafi

I encountered exactly the same Bug. The effect only appears, when connecting over the management port Fa0 via telnet or ssh. In-Band connections to a int vlan are not affected.

In a testing environment I was able to track the Bug down to the following config command:

login on-success log

Without this command, everything works.



Hi Fellow,


We had the same problem even with TELNET, We typed the command "no login on-success log" and the problem was gone. We have just upgraded from 15.0(2a)EX5 to Firmware 2960X 15.2.3E2(ED), so far it seem OK in a test enviroment, I dont know this is the solution for a production enviroment. 


have you had any update for this case?



Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers