cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
662
Views
0
Helpful
7
Replies
Highlighted
Beginner

Upgrade IOS on 2960 and 3750

Hey Everyone

Just wanted to ask you for some tips and tricks..

We are going to upgrade our IOS on our WS-C2960G-48TC-L..

But before we do that i want to ask whats the best IOS release to choose.

Why we want to upgrade is because our switch software now don't support ssh just telnet access

Switch details:

Model: WS-C2960G-48TC-L 

SW Version:  12.2(25)SEE2

Image: C2960-LANBASE-M

I was thinking about upgrading the IOS to 12.2(44)SE6 are maybe i should upgrade it to a newer release?

One more thing we have a bunch of stacked 3750 switches, that also need to be upgraded.

Any tips will be really appreciated ?

Thanks

Shane

7 REPLIES 7
Highlighted
Hall of Fame Master

To begin with, how have you determined that "needs to be upgraded" ? Have you run into  any switch bug ?

Highlighted

No bugs, just that we want to use ssh and not telnet

Cheers

Shane

Highlighted
Beginner

on 3750, you can upgrade to "c3750-ipservicesk9-mz.122-55.SE5.bin".

we are running this IOS on stacked 3750 switches.

cheers,

Shain Bharati CCIE (R&S) #28837

Highlighted

Thank you Shain

Highlighted

Actually, which version is available for the 3750 switches depends on the specific model.

Highlighted

  We have a couple of WS-C3750G-12S and 2 WS-C3750G-24TS

  It looks like the IOS that Shain recommended works on both

/Shane

Highlighted
Hall of Fame Community Legend

But before we do that i want to ask whats the best IOS release to choose.

For both 2960 and 3750, I recommend 12.2(55)SE6.

I was thinking about upgrading the IOS to 12.2(44)SE6 are maybe i should upgrade it to a newer release?

I wouldn't touch that IOS version even if my life depended on it.

For IOS versions 15.0(1)SE (and later) and 15.0(2)SE I can say this:  Use either these two at your own peril!

PS:  In regards to your 3750, check first if you have 16 mb of flash.  If you do have 16 mb of flash, the "highest" IOS version you can go is 12.2(55)SE (and later).  You will not be able to load, for example, 12.2(58)SE (and later).

Content for Community-Ad