02-12-2007 12:02 AM - edited 03-05-2019 02:17 PM
Hi.
I am trying to create bgp sessions in vrf?s through vlans / trunks but I get no TCP sessions.
PE: (this running on a 3750)
ip vrf PE_CustVrf
description CustomerMPLS
rd 3292:125
route-target export 3292:125
route-target import 3292:125
interface GigabitEthernet1/0/1
description Connection to CE 6506 switchport trunk encapsulation dot1q
switchport trunk allowed vlan 125
switchport mode trunk
interface Vlan125
ip vrf forwarding PE_CustVrf
ip address 172.31.254.1 255.255.255.252 secondary
ip address 172.31.254.5 255.255.255.252
!
router bgp 3292
no synchronization
bgp log-neighbor-changes
no auto-summary
!
address-family ipv4 vrf PE_CustVrf
redistribute connected
redistribute static route-map primar
neighbor 172.31.254.2 remote-as 65525
neighbor 172.31.254.2 description TDC Hosting
neighbor 172.31.254.2 ebgp-multihop 5
neighbor 172.31.254.2 disable-connected-check
neighbor 172.31.254.2 update-source Vlan125
neighbor 172.31.254.2 activate
neighbor 172.31.254.2 soft-reconfiguration inbound
default-information originate
no auto-summary
no synchronization
exit-address-family
!
CE: (this running on a 6506 sup720)
ip vrf CE_CustVrf
description 0000552: West-Wood A/S
rd 65525:125
route-target export 65525:125
route-target import 65525:125
!
interface Vlan125
description 0000552: West-Wood A/S
ip vrf forwarding CE_CustVrf
ip address 172.31.254.2 255.255.255.252 secondary
ip address 10.45.73.2 255.255.255.192
no ip redirects
router bgp 65525
no synchronization
bgp log-neighbor-changes
no auto-summary
!
address-family ipv4 vrf CE_CustVrf
redistribute connected
redistribute static
neighbor 172.31.254.1 remote-as 3292
neighbor 172.31.254.1 description TDC Net
neighbor 172.31.254.1 ebgp-multihop 5
neighbor 172.31.254.1 update-source Vlan125
neighbor 172.31.254.1 activate
neighbor 172.31.254.1 soft-reconfiguration inbound
neighbor 172.31.254.6 remote-as 65525
neighbor 172.31.254.6 description TDC Net
neighbor 172.31.254.6 activate
neighbor 172.31.254.6 soft-reconfiguration inbound
default-information originate
no auto-summary
no synchronization
exit-address-family
!
ip route vrf CE_CustVrf 0.0.0.0 0.0.0.0 10.45.73.1
ip route vrf CE_CustVrf 10.0.0.0 255.0.0.0 172.31.254.1
ip route vrf CE_CustVrf 10.45.32.0 255.255.255.0 10.45.73.1
ip route vrf CE_CustVrf 10.45.71.0 255.255.255.0 10.45.73.1
ip route vrf CE_CustVrf 10.45.72.0 255.255.255.0 10.45.73.1
ip route vrf CE_CustVrf 10.45.73.64 255.255.255.192 10.45.73.1
ip route vrf CE_CustVrf 10.45.253.0 255.255.255.0 10.45.73.1
ip route vrf CE_CustVrf 10.72.0.0 255.255.255.0 10.45.73.1
ip route vrf CE_CustVrf 10.118.15.0 255.255.255.0 10.45.73.1
ip route vrf CE_CustVrf 10.200.1.0 255.255.255.0 10.45.73.1
ip route vrf CE_CustVrf 172.16.0.0 255.240.0.0 172.31.254.1
ip route vrf CE_CustVrf 192.168.0.0 255.255.0.0 172.31.254.1
ip route vrf CE_CustVrf 195.225.195.0 255.255.255.0 172.31.254.1
The connections (interfaces) is PE:g1/0/1 as trunk and CE:g6/1 as trunk
interface GigabitEthernet6/1
description Trunk to PE
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address
no cdp enable
!
Anyone?
02-12-2007 04:17 AM
Needed a lo0 interface with an ipaddress.. And that made all the difference...
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide