cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
754
Views
0
Helpful
11
Replies
Muthukumar P
Beginner

VRRP configuration

HI,

            We have two isp links and both are terminated  in single router with vrrp & BGP, when both routers on live ISP links fluctuation is happened , but its working fine with single router, we want HA for the Router also. Please find the master router configuration and help on this..

neinho23-primary#sh run
Building configuration...

Current configuration : 4350 bytes
!
! Last configuration change at 23:50:36 UTC Thu May 26 2016
! NVRAM config last updated at 23:53:44 UTC Thu May 26 2016
! NVRAM config last updated at 23:53:44 UTC Thu May 26 2016
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname neinho23-primary
!
boot-start-marker
boot-end-marker
!
!
enable secret 4 tnhtc92DXBhelxjYk8LWJrPV36S2i4ntXrpb4RFmfqY
!
no aaa new-model
!
no ipv6 cef
ip source-route
ip cef
!
!
!
!
!
multilink bundle-name authenticated
!
!
crypto pki token default removal timeout 0
!
!
license udi pid CISCO2911/K9 sn FGL164811FW
!
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 ip address 10.206.10.23 255.255.255.0
 duplex auto
 speed auto
 vrrp 1 ip 10.206.10.9
 vrrp 1 preempt delay minimum 300
 vrrp 1 priority 200
!
interface GigabitEthernet0/1
 description tata_mpls
 ip address 172.30.170.75 255.255.255.248
 duplex auto
 speed auto
 vrrp 1 ip 172.30.170.74
 vrrp 1 preempt delay minimum 300
 vrrp 1 priority 200
!
interface GigabitEthernet0/2
 description reliance_mpls
 ip address 10.227.76.251 255.255.255.248
 duplex auto
 speed auto
 vrrp 1 ip 10.227.76.250
 vrrp 1 preempt delay minimum 300
 vrrp 1 priority 200
!
interface FastEthernet0/0/0
 ip address 10.206.50.2 255.255.255.0
 duplex auto
 speed auto
 vrrp 1 ip 10.206.50.1
 vrrp 1 preempt delay minimum 300
 vrrp 1 priority 200
!
interface FastEthernet0/0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1/0
 description bsnl_p2p
 ip address 3.1.3.1 255.255.255.252
 encapsulation ppp
!
router rip
 version 2
 network 3.0.0.0
 network 10.0.0.0
!
router bgp 65211
 bgp log-neighbor-changes
 network 10.206.0.0 mask 255.255.0.0
 network 10.206.10.0 mask 255.255.255.0
 network 10.206.11.0 mask 255.255.255.0
 network 10.206.12.0 mask 255.255.255.0
 network 10.206.13.0 mask 255.255.255.0
 network 10.206.14.0 mask 255.255.255.0
 network 10.206.15.0 mask 255.255.255.0
 network 10.206.16.0 mask 255.255.255.0
 network 10.206.17.0 mask 255.255.255.0
 network 10.206.18.0 mask 255.255.255.0
 network 10.206.19.0 mask 255.255.255.0
 network 10.206.20.0 mask 255.255.255.0
 network 10.206.21.0 mask 255.255.255.0
 network 10.206.22.0 mask 255.255.255.0
 network 10.206.23.0 mask 255.255.255.0
 network 10.206.24.0 mask 255.255.255.0
 network 10.206.25.0 mask 255.255.255.0
 network 10.206.27.0 mask 255.255.255.0
 network 10.206.29.0 mask 255.255.255.0
 network 10.206.30.0 mask 255.255.255.0
 network 10.206.31.0 mask 255.255.255.0
 network 10.206.32.0 mask 255.255.255.0
 network 10.206.33.0 mask 255.255.255.0
 network 10.206.35.0 mask 255.255.255.0
 network 10.206.50.0 mask 255.255.255.0
 network 10.206.60.0 mask 255.255.255.0
 network 10.218.0.0 mask 255.255.255.0
 network 10.218.1.0 mask 255.255.255.0
 network 10.227.76.0 mask 255.255.255.192
 network 172.30.170.0 mask 255.255.255.192
 network 182.156.86.0 mask 255.255.255.192
 network 203.124.152.0 mask 255.255.255.192
 neighbor 10.227.76.249 remote-as 18101
 neighbor 10.227.76.249 description ### reliance BGP Peering###
 neighbor 10.227.76.249 ebgp-multihop 4
 neighbor 10.227.76.249 default-originate
 neighbor 10.227.76.249 soft-reconfiguration inbound
 neighbor 172.30.170.73 remote-as 65000
 neighbor 172.30.170.73 description ###TATA BGP Peering ####
 neighbor 172.30.170.73 ebgp-multihop 4
 neighbor 172.30.170.73 default-originate
 neighbor 172.30.170.73 soft-reconfiguration inbound
!
no ip forward-protocol nd
!
ip http server
ip http access-class 23
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip route 0.0.0.0 0.0.0.0 10.206.10.1 name Internet
ip route 10.206.10.0 255.255.255.0 10.206.10.1 name NEINLAN
ip route 10.206.14.0 255.255.255.0 3.1.3.2 name NEINBLRAIR
ip route 10.218.0.0 255.255.255.0 10.206.10.1 name NEHHKG
ip route 10.218.1.0 255.255.255.0 10.206.10.1 name NEHHKG
!
access-list 100 permit ip 10.206.0.0 0.0.255.255 any
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 privilege level 15
 password cisco
 login
 transport input all
!
scheduler allocate 20000 1000
end

neinho23-primary#


Thanks

Muthukuar

11 REPLIES 11
Philip D'Ath
Advisor

Do you want both links to be active and in use at the same time, or active/standby?

HI,

          I want active & active ...

Thanks

Muthukumar

Hi,

 I need ISP link is active & active and router is Active & standby..

Thanks

Muthukumar

HI,

          Please help on this..

Thanks

Muthukumar

Hi

Could you not just use GLBP as its active/active by default or else split the subnets have multiple groups to make active/active in HSRP or VRRP , its a active/standby protocol so its not really suited for active/active

Hi ,

       Can i get the GLBP configuration for this ?and can you confirm that  whether GLBP supported for  cisco 2911 router..

Thanks

Muthukumar

yes its supported , just change the vrrp to glbp

https://supportforums.cisco.com/document/23466/how-configure-glbp

http://www.cisco.com/c/en/us/td/docs/ios-xml/ios/ipapp_fhrp/configuration/xe-3s/fhp-xe-3s-book/fhp-glbp.html#GUID-A2D19870-5191-4181-B02F-D4810F9789E3

Hi,

   I am understanding that GLBP for Router HA right..Can i get link load balancing for ISP Link and pls suggest, whether both isp link terminated to single router or separate router..

Thanks

Muthukumar

Hi

If your using BGP you need to look at single/multi BGP  homing load sharing you can manipulate the metrics to chose what to be learnt etc from each ISP as primary/secondary paths

http://www.cisco.com/c/en/us/support/docs/ip/border-gateway-protocol-bgp/13762-40.html

maxrodri
Beginner

Hello Muthukumar,

So you have 2 routers connected to your provider. Also there are 4 interfaces on this device configured for VRRP group 1, this might cause conflict as the VIP address will have 4 differents IP addresses, such a thing is not possible.

How these interfaces are connected to the other router? Maybe you can either define more than one VRRP group.

-Max

Hi Max,

                 Earlier i have tried with 4 vrrp group means each interface is having each group even also ISP Link is flapping when both routers are in live..

Thanks

Muthukumar