cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
605
Views
0
Helpful
5
Replies
Highlighted
Beginner

VTP Sync Issue

Hi,

We have 6500 as a core switch in VSS. Earlier it was configured as VTP server mode with version 2. But some days before we configured it VTP Primary command. After configured the command the VTP version automatically change to Version 3. And rest of other access switches is configured in client mode and version 2. So if we are creating any new Vlan on core switch it will not propagated on other access switches.

So for troubleshooting purpose we connected a new switch to core switch and configured it as VTP client and version 2. At this time all Vlan propagated in that switch also we tested to add new Vlan from core switch and its propagated in new switch.

So we just want to know that is VTP Primary command works in V3 only and why the Vlan changes is not propagated in access switches when the V3 and V2 communication is supported  .

Regards,

Sunil

5 REPLIES 5
Highlighted
Beginner

VTP3 is compatible with VTP2 (but not with VTP1). A VTP3 device can update a VTP2 device but not vice versa. The vtp primary command is VTP3 only thats why your 6500 changed.

http://www.cisco.com/en/US/prod/collateral/switches/ps5718/ps708/solution_guide_c78_508010.html

Highlighted

If the VTP3 is compatible with VTP2 then why the Vlan changes is not propagated in access switches when the V3 and V2 are able to communicate. Also confirm that VTP primary command is support only in V3. If yes than that’s why our VTP version of core switch is change to V2 to V3 when applied the VTP Primary command.

Highlighted

Check your cofiguration revision number. Maybe thats why the newly added switch did update while the others did not.

  •VTP version 3 supports propagation of any database in a domain by allowing you to configure a primary and secondary server.

From

http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.2SX/configuration/guide/vtp.html#wp1051097

Highlighted

We checked the cofiguration revision number 189 for server and 188 for access switches.

Highlighted

I think that the one working in VTP2 should be in vtp client mode and not in  vtp server in order to work with VTP3.

What confuses me is that your new switch did update as it should.

Try checking the password, domain name etc.

Content for Community-Ad