cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

WS-C3750E-48PD etherchannel multi vlan

what am i doing wrong? i can not get the vlans to go over my fiber port channel.

the no commands are what i want, and i have read should work. the rest is current running. 

 

WS-C3750E-48PD, 15.2(4)E10 (UNIVERSALK9)

!
spanning-tree mode pvst
spanning-tree extend system-id
no spanning-tree vlan 1,101-103,1000
!
!
!
!
vlan internal allocation policy ascending
vlan dot1q tag native
!

 

interface Port-channel1
description LAN trunk 20gb fiber
 switchport mode access
no switchport trunk encapsulation dot1q
no switchport trunk allowed vlan 1-200,1000
no switchport mode trunk
no switchport trunk native vlan 1

 

interface Port-channel2
description server trunk 2gb cat temp
switchport access vlan 102
no shutdown
!
interface Port-channel3
description WAN trunk 2gb cat temp
switchport access vlan 1000
no shutdown

 

interface TenGigabitEthernet1/0/1
description 10g fiber trunk 1 of 2
switchport mode access
no switchport trunk encapsulation dot1q
no switchport trunk allowed vlan 1-200,1000
no switchport mode trunk
no switchport trunk native vlan 1
channel-group 1 mode active
!
interface TenGigabitEthernet1/0/2
description 10g fiber trunk 2 of 2
switchport mode access
no switchport trunk encapsulation dot1q
no switchport trunk allowed vlan 1-200,1000
no switchport mode trunk
no switchport trunk native vlan 1
channel-group 1 mode active

 

!
interface Vlan1
description LAN
ip address 
!
interface Vlan101
description LAN
ip address
!
interface Vlan102
description server_link
ip address 
!
interface Vlan103
description cameras
ip address
!
interface Vlan1000
description WAN
ip address 
!
ip default-gateway .
ip forward-protocol nd

 

2 ACCEPTED SOLUTIONS

Accepted Solutions

balaji.bandi
VIP Guru VIP Guru
VIP Guru

Not sure if i understand your question correctly here.

 

If you looking your VLAN to go across Port-channel you should allow them to span over.

 

as per your config, it is mode set to access, this act as access port.

 

change to below to work, make sure you shut the port-channel make the changes and enable back.

 

interface Port-channel1
description LAN trunk 20gb fiber
no switchport mode access
switchport mode trunk
switchport trunk encapsulation dot1q

switchport trunk native vlan 1

switchport trunk allowed vlan 1-200,1000

 

if this not what you looking explain more.

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

View solution in original post

so i need to "shut the port-channel make the changes and enable back".

oh. i did not do that. i left the channel live the whole time. did not think i had to bounce it. i will try that.

what you see is two configs in one. i am "working" in the mode access right now.
the "no" commands are what i feel are the proper trunking set up, but dropped my vlans when i did them, but like i said... i did not bounce the channel.

View solution in original post

6 REPLIES 6

balaji.bandi
VIP Guru VIP Guru
VIP Guru

Not sure if i understand your question correctly here.

 

If you looking your VLAN to go across Port-channel you should allow them to span over.

 

as per your config, it is mode set to access, this act as access port.

 

change to below to work, make sure you shut the port-channel make the changes and enable back.

 

interface Port-channel1
description LAN trunk 20gb fiber
no switchport mode access
switchport mode trunk
switchport trunk encapsulation dot1q

switchport trunk native vlan 1

switchport trunk allowed vlan 1-200,1000

 

if this not what you looking explain more.

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

so i need to "shut the port-channel make the changes and enable back".

oh. i did not do that. i left the channel live the whole time. did not think i had to bounce it. i will try that.

what you see is two configs in one. i am "working" in the mode access right now.
the "no" commands are what i feel are the proper trunking set up, but dropped my vlans when i did them, but like i said... i did not bounce the channel.

make changes effective on best way do it always shutdown mode.

 

so follow below steps to make effective. (make sure you do it console, if your are not doing this config from management interface) - if not you loose connectivityt to switch.

 

config t

!

interface Port-channel1

shutdown

!

interface Port-channel1
description LAN trunk 20gb fiber
no switchport mode access
switchport mode trunk
switchport trunk encapsulation dot1q

switchport trunk native vlan 1

switchport trunk allowed vlan 1-200,1000

no shut

!

 

it should work as expected.

 

let us know the inputs.

 

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Leo Laohoo
VIP Community Legend VIP Community Legend
VIP Community Legend

@GaarithKivijarvi96345 wrote:

no switchport trunk encapsulation dot1q
no switchport trunk allowed vlan 1-200,1000
no switchport mode trunk
no switchport trunk native vlan 1


Uhhhh ... whut?

Deepak Kumar
Advocate
Advocate

It seems that your port-channel configuration is not correct:

 

try as:

 

config t

default interface TenGigabitEthernet1/0/2

default interface TenGigabitEthernet1/0/1

!

interface Port-channel1
description LAN trunk 20gb fiber
 no switchport mode access
 switchport trunk encapsulation dot1q

 switchport mode trunk

 switchport trunk allowed vlan 1-200,1000
 switchport trunk native vlan 1

!

interface TenGigabitEthernet1/0/1
description 10g fiber trunk 1 of 2
switchport mode trunk
channel-group 1 mode active
!
interface TenGigabitEthernet1/0/2
description 10g fiber trunk 2 of 2
switchport mode trunk
channel-group 1 mode active

 

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution if this comment will help you!

when i shut the channels and then did the changes, and then no shut, it all worked. so use to just making live changes and did not think of the need to re provision the interface on the level 2. if was level 3 (ip address, route, gateway...) would not have been an issue.

 

thnks!

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: