02-21-2011 11:07 AM - edited 03-06-2019 03:40 PM
I am trying to get a second set of eyes with folks that have experience configuring WS-C4506E's to support Avaya VoIP PoE phones. The following is the configuration that has been applied. I would like to see if their are any improvements that I can make to provide the best configuration. Please note I have limited exposure and experience with applying QoS settings to LAN Switches. If there other questions or it makes sense to post a particular output please do not hesitate to let me know. Thanks
!
! Global QoS Commands
!
qos dbl
qos map dscp 24 25 26 27 28 29 30 32 to tx-queue 4
qos map dscp 32 33 34 35 36 37 38 39 to tx-queue 4
qos map dscp 40 41 42 43 44 45 47 to tx-queue 4
qos map cos 3 to dscp 26
qos map cos 5 to dscp 46
!
class-map match-all AutoQos-VoIP-Cos-1
match cos 1
class-map match-all AutoQos-VoIP-Cos-2
match cos 2
class-map match-all AutoQos-VoIP-Cos-4
match cos 4
class-map match-all AutoQos-VoIP-Cos-6
match cos 6
class-map match-all AutoQos-VoIP-Cos-7
match cos 7
class-map match-all AutoQos-VoIP-Bearer-Cos
match cos 5
class-map match-all AutoQos-VoIP-Control-QosGroup24
match dscp cs3
class-map match-all AutoQos-VoIP-Control-QosGroup26
match dscp af31
class-map match-all AutoQos-VoIP-Bearer-QosGroup
match dscp ef
class-map match-all AutoQos-VoIP-Control-Cos
match cos 3
!
policy-map AutoQos-VoIP-Input-Cos-Policy
class AutoQos-VoIP-Bearer-Cos
set dscp ef
class AutoQos-VoIP-Control-Cos
set dscp af31
class AutoQos-VoIP-Cos-2
set dscp cs2
class AutoQos-VoIP-Cos-1
set dscp cs1
class AutoQos-VoIP-Cos-4
set dscp af41
class AutoQos-VoIP-Cos-6
set dscp cs6
class AutoQos-VoIP-Cos-7
set dscp cs7
policy-map AutoQos-VoIP-Output-Policy-Trunk
class AutoQos-VoIP-Bearer-QosGroup
set dscp ef
set cos 5
priority
police cir percent 60
class AutoQos-VoIP-Control-QosGroup26
set dscp af31
set cos 3
bandwidth remaining percent 5
class AutoQos-VoIP-Control-QosGroup24
set dscp cs3
set cos 3
bandwidth remaining percent 5
class class-default
dbl
policy-map AutoQos-VoIP-Output-Policy
class AutoQos-VoIP-Bearer-QosGroup
set dscp ef
set cos 5
priority
police cir percent 33
class AutoQos-VoIP-Control-QosGroup26
set dscp af31
set cos 3
bandwidth remaining percent 5
class AutoQos-VoIP-Control-QosGroup24
set dscp cs3
set cos 3
bandwidth remaining percent 5
class class-default
dbl
!
! Sample - Core/Distribution Layer Uplink Port
!
interface range gi1/3
switchport trunk encap dot1q
switchport mode trunk
qos trust dscp
auto qos voip trust
service-policy input AutoQos-VoIP-Input-Cos-Policy
service-policy output AutoQos-VoIP-Output-Policy-Trunk1
!
! Sample - Access Layer Port
!
interface fa2/1
switchport access vlan 100
switchport voice vlan 200
switchport mode acces
qos trust dscp
auto qos voip trust
tx-queue 3
priority high
spanning-tree portfast
exit
02-21-2011 03:55 PM
This is pretty much a stock standard AutoQos configuration
.
ONe thing you have to make sure is the values in the following groups:
class AutoQos-VoIP-Control-QosGroup26
set dscp af31
set cos 3
bandwidth remaining percent 5
class AutoQos-VoIP-Control-QosGroup24
set dscp cs3
set cos 3
bandwidth remaining percent 5
because you have your access port set to trust any incoming dscp value, you must make sure that your phones are set to send the right DSCP value.
I am not sure where you set that in Avaya, but make sure you double check.
08-14-2012 07:39 AM
minkdennis wrote:
This is pretty much a stock standard AutoQos configuration
.
ONe thing you have to make sure is the values in the following groups:
class AutoQos-VoIP-Control-QosGroup26
set dscp af31
set cos 3
bandwidth remaining percent 5
class AutoQos-VoIP-Control-QosGroup24
set dscp cs3
set cos 3
bandwidth remaining percent 5because you have your access port set to trust any incoming dscp value, you must make sure that your phones are set to send the right DSCP value.
I am not sure where you set that in Avaya, but make sure you double check.
I too am deploying a 4510E with a sup7E in our environment. This is a new sup module that we don't have as part of our WAN enterprise till now.
I was looking for the same answers regarding AVAYA 4620 model phones.
If possible can we have a bullet proof configuration for QoS for these switches? The phones use DSCP. I'm not sure that auto qos voip trust would be the right parameter to put in under the interface configuraitons. The policy map generated may include unwanted parameters. Does anyone else have this phone and switch setup that I can use for our new deployment that is tested and proven?
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide