cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
995
Views
0
Helpful
3
Replies

ce 9 xevent documentation

tomas_vll
Level 1
Level 1

Hello! I have been experimenting with the Macro language. When looking for documentation on xevent commands I see in the API documentation that you can access the available commands by

 

xEvent ?

The problem when i execute these commands on a CE9.4 or 9.1 system nothing is returned over CLI (putty). If I execute the command on a CE8 system the command returns the expected results.  I have tested this with multiple systems. Is this a bug or some setting i am missing?

1 Accepted Solution

Accepted Solutions

Wayne DeNardi
VIP Alumni
VIP Alumni

Try typing "xEvent" without the trailing question mark

xEvent

That will give the top level event list, you can then drill in further if you want by specifying the category, ie

xEvent Audio

If you want a full list of all the event, use a * instead of the ?

xEvent *

This behaviour was changed some time in the CE9 software train, I can't recall when, but the documentation was updated in the CE9.5.x release - see collaboration-endpoint-software-api-reference-guide-ce95.pdf

Wayne

Please remember to mark helpful responses and to set your question as answered if appropriate.

View solution in original post

3 Replies 3

Wayne DeNardi
VIP Alumni
VIP Alumni

Try typing "xEvent" without the trailing question mark

xEvent

That will give the top level event list, you can then drill in further if you want by specifying the category, ie

xEvent Audio

If you want a full list of all the event, use a * instead of the ?

xEvent *

This behaviour was changed some time in the CE9 software train, I can't recall when, but the documentation was updated in the CE9.5.x release - see collaboration-endpoint-software-api-reference-guide-ce95.pdf

Wayne

Please remember to mark helpful responses and to set your question as answered if appropriate.

I also meet the same issue. I try to input xEvent *,xEvent ?,xEvent ??, all of them were rejected.


@xujf wrote:

I also meet the same issue. I try to input xEvent *,xEvent ?,xEvent ??, all of them were rejected.


What software version are you running on your endpoint?

How are you trying to input the xEvent command?  This works via a CLI session on the endpoint (via telnet, serial or SSH), not via the XML API on the Web Interface.

Wayne

Please remember to mark helpful responses and to set your question as answered if appropriate.