Showing results for 
Search instead for 
Did you mean: 

Cisco Meeting Server 2.1.5 WebRTC with Firefox issue

Paul Freiberg
Level 1
Level 1

Hi all,

with Expressway X8.9.2 and CMS 2.1.5 now we use succesfully the Expressway Web Proxy feature for WebRTC.

It works fine with chrome but it does not work with firefox.

On Firefox the session connects fine but video and audio from other party is not displayed or heard and the other party just sees a black display and hears nothing.

Is that issue known?


5 Replies 5

Paul Freiberg
Level 1
Level 1

It hangs with the message "Loading media - please wait".

And on top left of FF the page information are flashing with a red camera and microphone icon.

I just tested with the portable version of Firefox 52.0.2 and audio/video worked for me using the web proxy through our VCS.  Take a look at Acano KB #1126 to check your web browser/computer.


I have exactly the same issue with the same versions.

I try from several workstation with firefox installed (home, etc ...). Same issue.

And the Acano kb test are even successfull.

It looks like a bug I guess.

I got it work as I was at home and was connected via vpn to a user subnet. But while I was physical in that network it did not worked...

In the Firewall we saw connections from expressway to my home private subnet (192.x.x.x) while I was not in VPN.

With Chrome all works.

Very strange, today we try to look more deeper.

Also we see UDP Packets (TURN I guess) from Expressway-E to the Client in the User net which we block. And short before similare UDP Packets between CMS and that IP which was allowed because the IP in the User net sent a packet to the CMS...

I raise a TAC case about this.

Firefox is in BETA testing, not officially supported.

Firefox still has problems negotiating WebRTC, particularly when TURN is involved.

In fact, it works when I connect in the LAN (no TURN involved ==> Direct communication with CMS).

No ETA yet for support, but soon.