cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
213
Views
10
Helpful
5
Replies

Webex Room Kit - Audio, but NO VIDEO in calls between endpoints

mbrown-gcscu
Beginner
Beginner

We have recently begun configuring some Webex room kits which we purchased some time ago. We have a mostly working setup right now; the "mostly" being the reason for this post.

We have two units set up for testing currently. One is a Webex Room Kit Plus, the other is a Webex Room Kit.

Both have been registered to CUCM - we are on version 11.0.1.22900-14. The room kits have been fully upgraded to RoomOS 10.15.3.

We do have two Expressway VMs set up in our network as well. The room kits ARE NOT currently registered to the Expressways.

Current behavior is as follows:

* Both units can place and receive calls successfully, either to each other or to other standard phones in our network
* Audio on calls works normally, both between the units and from a unit to standard phones
* Video on calls between the two room kit units DOES NOT work, only audio
* Video in a call placed to a room kit from the Jabber desktop client DOES work; video is seen both in the desktop client and on the room kit display

We must be missing something here, but have been searching for days now without any luck on what a solution for our situation might be. Anyone faced anything like this before?

1 Accepted Solution

Accepted Solutions

Do you dial Kit to Kit using SIP address (.i.e. 123456@example.com)? If not, try dialing by SIP address.

Are the two Room Kits in the same device pool? If not, please check the "Location" settings well. Go to, System > Location Info > Location. Set immersive bit rate between the two locations in question to unlimited and test again. Make sure the device pool of each Room Kit is assigned the correct region and location. 

If the two room kits are in the same device pool, then the location settings does not apply. 

If the issue still persists, change the region setting from 2048 to 2000000000 kbps which is the CUCM default value. The call is not going to consume that much bandwidth but it allows the kits to use any type of video codec. 

Not sure how your Jabber connected with video if the video bit rate was set to none.

View solution in original post

5 Replies 5

TechLvr
Participant
Participant

This must be a region relationship issue. In CUCM go to, System > Region Information > Region

Click “Find”, and then click on the region that’s associated with the device pool of a Room Kit. Near the bottom of the page, highlight the same region from the list of regions, and set the “Maximum Bit Rate for Immersive Video Calls” to 2048. Then under the same page, highlight the region of another Room Kit, if applicable, and set the bit rate for immersive video calls also to 2048.

You Jabber calls to Room Kit works because it uses the bit rate setting for regular video calls which seems to be set correctly.

If the issue persists, please share a screen shot of the region page.  

 

mbrown-gcscu
Beginner
Beginner

Unfortunately, this did not help. After setting the new values for bit rate, still no video is transmitted on Room Kit to Room Kit calls.

Checking the call logs shows that no video traffic is ever generated at all in the kit-to-kit call.

Kit-to-kit call:

mbrowngcscu_0-1663074625982.png

However, in the Jabber-to-kit call, we clearly see the video traffic that is sent:

mbrowngcscu_1-1663074694577.png

This is the current configuration of our regions. Prior to configuring this, all Bit Rate values for Video Calls and Immersive Video Call were set to None. The Jabber-to-Room Kit calls were working correctly even with the Video Calls value set to None.

mbrowngcscu_2-1663075125091.png

mbrowngcscu_3-1663075180454.png

It occurred to me that we did not try to place a call from a Room Kit to a Jabber client to see if that works. I hope to get that tested today at some point.

Thank you for the suggestion. Looking forward to hearing if you have more ideas.

Do you dial Kit to Kit using SIP address (.i.e. 123456@example.com)? If not, try dialing by SIP address.

Are the two Room Kits in the same device pool? If not, please check the "Location" settings well. Go to, System > Location Info > Location. Set immersive bit rate between the two locations in question to unlimited and test again. Make sure the device pool of each Room Kit is assigned the correct region and location. 

If the two room kits are in the same device pool, then the location settings does not apply. 

If the issue still persists, change the region setting from 2048 to 2000000000 kbps which is the CUCM default value. The call is not going to consume that much bandwidth but it allows the kits to use any type of video codec. 

Not sure how your Jabber connected with video if the video bit rate was set to none.

mbrown-gcscu
Beginner
Beginner

Yes! The location settings were what we were missing. Once the bit rates between the appropriate locations were updated to unlimited, we got video between the two room kits as expected.

Thanks so much for the assist! 

Glad that worked and thanks for the update. 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: