Showing results for 
Search instead for 
Did you mean: 

Cisco Unity Connection 9 web record of call handler issue

Daniel Isham

I am having an issue with CUC 9.1 and recording call handlers. When I record a standard greeting in the CUC web administration page, I am able to save the recording. If go to another section in CUC and go back to that specific greeting, the newly recording greeting is gone and the greeting that was there previously is there. Is there an issue with IE 9 or 10 when recording call handlers? Is there a service I can restart to see if it will help remediate this issue?

Thank you in advance!

1 Accepted Solution

Accepted Solutions

I had the same issue a few months back (admittedly with a different version). The problem was with a recent update to a java plugin so I was never seeing the SSL certificate error that the plugin normally pops up. To resolve it I had to roll back to an older version of the plugin.

View solution in original post

10 Replies 10

Chris Deren
Hall of Fame Master Hall of Fame Master
Hall of Fame Master

Check out:

Unity Connection Greetings Getting Duplicated To Other Call Handlers.
Symptom: When uploading recorded greetings for a standard greeting on a call handler, Using the Media Master Plugin the greeting is getting duplicated to a bunch of other call handlers that don't have a standard greeting recorded yet. Conditions: Goto an existing call handler on PC 1. Open up the standard greeting On PC2, create a new call handler, click on save. You should now be on the Edit Basic call handler screen. On PC1 Goto greetings standard greetings, and open up the mediamaster. Now, using the phone, record a greeting, and click on stop. DON'T SAVE OR CLICK ON ANYTHING ELSE. Quickly On PC2, which should still be on the Edit Basic call handler screen, click on SAVE. Now on PC2 If you open the media master by clicking on Recorded Name, you should now have the greeting waiting to be saved on PC1 as the recorded name for the new call handler. It also works for a users greeting or Edit Basics page(Writing over the existing recorded name or greeting) Appears like mediamaster is caching the recording , and if anyone else happens to save, it saves it to that greeting. Also When the 2nd (non recording) user clicks on save, during the window between the 1st (recording) user finishing his/her greeting and clicking on save, not only does the cached greeting goto the 2nd users mailbox, or call handler, it clears the cache so that the 1st, recording, user doesn't update their greeting when they click on save; it is left as the old greeting, or blank. So, basically the 2nd user 'steals' the 1st users recording. Workaround: None

Under bug

CSCtz86847 has been superseded by CSCtz44199



Thank you for shedding light on that bug. Unfortunately this doesn't apply as the customer is using G.711 for recordings..

I don't think it matters, for some reason Cisco merged 2 bugs which don't seem to be related (at least at first glance), did you read the description above, does that not match your symptoms?


The main symptom is that the recordings aren't being retained even though we save them. I am going to do further testing this evening to narrow things down and will try Firefox as well. Thanks again Chris.


It looks like the bug info you sent doesn't affect the version of CUC I am currently running. A co-worker of mine told me about access the CUC web admin page using the DNS name and that it has something to do with the certificate in Java, or something to that effect. Have you had any experience with this as well? I haven't had a chance to test this out yet but will do later this week.


I had the same issue a few months back (admittedly with a different version). The problem was with a recent update to a java plugin so I was never seeing the SSL certificate error that the plugin normally pops up. To resolve it I had to roll back to an older version of the plugin.

bottom line,

every time there is a java update we run into issues with the cisco plugins that use it. (unity connection, ucs, anyconnect plugins just to name a few.

its time cisco does something to get away from this java crap



I ran in to these same symptoms and have been fighting it for a while. I have not ultimately found a solution but I found the following workaround which allowed me to get my greetings uploaded until a better solution can be found. I am posting it here in case it might work for others in a pinch.



Open the mediamaster applet on the appropriate page and choose to open file

browse to and select the greeting you want to upload

BEFORE clicking save, click the play button in the mediamaster (I have mine set to play via phone, I didn't test via computer). The file uploads and plays.

Then click save. For some reason, this seems to have properly uploaded the greeting without any errors.

I hope this is helpful to someone who is running in to this same frustrating problem.



Playing via phone before saving fixed the SSL error / unable to save file issue with CUCM 10.5 and Java 8.

Thanks jwspade! This is the easiest suggestion and worked for me.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers