cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
968
Views
0
Helpful
4
Replies

CUBAC 8.6 Contact Details

mattcalderon
Enthusiast
Enthusiast

I am currently facing an issue with the CUBAC client showing the incorrect correct phone status.  I have integrated with CUPS and the presence all shows well.  My issue that we are facing is that the phone status shows as out of service for a few devices.  I have confirmed that we have CTI enabled control over everything necessary, and the phone is associated to the end user.  Here is the catch!  When I go to that contact-->contact details for that user in the directory, I notice that the contact nubmber and use device name have the BAT mac address that we used before we TAPPEd the phones.  How can i refresh this so that the user's MAC of the phone is correct?

I have attached a screen shot of the user in question.

Matt

1 Accepted Solution

Accepted Solutions

Matt,

My appologies as I left out one detail that might have been important.  When you restart the LDAP service click the "i" next to the service as it starts up.  Monitor the sync to ensure it finishes before proceeding to step 6.

When it is currently updating the database Active Sources and Active Synchs should both be one.  Once it has completed Active Synchs will go back to 0.  So please ensure both go to 1, and then that Active Syncs goes back to 0 before proceeding with step 6.  If you did this too quickly it might have not finished and thus not updated anything.

Regards,

Jason

View solution in original post

4 Replies 4

Jason Newman
Cisco Employee
Cisco Employee

Matt,

In order to refresh the MAC specified for device monitoring you can do the following:

1) Log into the CUBAC adminsitration page.

2) Go to System Conf -> Directory Rules

3) Select the CCMDefaultRule

4) If this is empty create a new rule filter and make it "lastname eq to XXXXXXXX"  (yes with the X's, this is designed to filter all users out of the database)

5) Go to Engineering -> Service Management and restart the LDAP service  (this assumes under System Config -> Directory Sync that you have the enable contact sync and on start-up boxes selected)

6) Go back to the filter rule you created and change it to "lastname approx eq to *".  (Be sure this is approx eq to and not just eq to)

7) Restart the LDAP service one additional time.

After this you should see that the devices were updated and should no longer be BAT extensions. 

Regards,

Jason

Ok, I completed the above steps and the contact details were not updated.

Matt,

My appologies as I left out one detail that might have been important.  When you restart the LDAP service click the "i" next to the service as it starts up.  Monitor the sync to ensure it finishes before proceeding to step 6.

When it is currently updating the database Active Sources and Active Synchs should both be one.  Once it has completed Active Synchs will go back to 0.  So please ensure both go to 1, and then that Active Syncs goes back to 0 before proceeding with step 6.  If you did this too quickly it might have not finished and thus not updated anything.

Regards,

Jason

thanks!  that worked, but will that have to be done frequently?  I have my directory and contact synchronization set and set to sync every hour right now  (this will change once we go into production) so why did i  manually have to push this?

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: