Showing results for 
Search instead for 
Did you mean: 

Install of CUCM on VMWare fails on installing progmeter

Level 1
Level 1

Hi, Everyone

First time post here, and first time installing CUCM (any version).

I built a VM using a downloaded OVA template for CUCM, and the install fails with a critical stop.  Once I figured out how to dump logs to the virtual serial port, and looked at the install.log, I found the following information that looks like where the install failed (these are the only LVL::Error and LVL::Critical messages in the log).

It looks like install failed to install the progmeter application component.

Does anyone know what this app does?  Any ideas on why it might have failed to install and possible workaround?

I may already have the answer to the question, as I'm attempting install on a VM running on VMWare vServer (rather than ESX/ESXi/vSphere).  It is possible that simply being on an unsupported configuration is my problem.  I'm trying to work with the equipment immediately available to me, but fully understand that I may have set myself up for failure by even attempting this.

Any help is appreciated greatly.


Sean C




08/17/2011 17:51:51 component_install|File:/opt/cisco/install/bin/component_install:743, Function: exec_progmeter(), /opt/cisco/install/bin/progmeter failed (1)|<LVL::Error>
08/17/2011 17:51:51|Internal Error, File:/usr/local/bin/base_scripts/, Function: install(), failed to install application components|<LVL::Critical>
08/17/2011 17:51:51 post_install|File:/opt/cisco/install/bin/post_install:869, Function: install_applications(), /usr/local/bin/base_scripts/ -install failed (1)|<LVL::Error>
08/17/2011 17:51:51 post_install|Exiting with result 1|<LVL::Info>
08/17/2011 17:51:51 post_install|INSTALL_TYPE="Basic Install"|<LVL::Debug>
08/17/2011 17:51:51 post_install|File:/opt/cisco/install/bin/post_install:570, Function: check_for_critical_error(), check_for_critical_error, found /common/log/install/critical.log, exiting|<LVL::Error>
08/17/2011 17:51:52 post_install|(CAPTURE) Mail notification cancelled - smtp server address for email not found! [/usr/local/platform/conf/platformConfig.xml]|<LVL::Debug>
08/17/2011 17:51:52 display_screen|Arguments: "Critical Error" "The installation has encountered a unrecoverable internal error. For further assistance report the following information to your support provider.

"/opt/cisco/install/callmanager/scripts/ install PostInstall /usr/local/cm/ /usr/local/cm/ /common/log/install/capture.txt " terminated. Exceeded max time (360)

The system will now halt.

Continuing will allow you to dump diagnostic information before halting." "Continue"|<LVL::Debug>

12 Replies 12

Level 4
Level 4

I am not sure about supported platforms nor can I make heads or tails of the log file.  But, I've you've already verified the media, I've had repeated install failures on an ESXi CUCM vm because I had an invaild NTP setting.  Giving it a legit NTP IP or just using the internal clock fixed this.

Just figured I'd throw that out there.

Thanks for the input gmgarrian.  I saw another thread last night about installing on VMs and saw other people had resolved install problems using the same fix. 

I was able to successfully configured networking, including external NTP server.  I wish that's all that was a problem for me!

Thanks again,

Sean C

Hi all,

I had the same problem installing CUCM IM&P 10.5. Reinstalled the VM on different hosts, with different resource parameters, but the result was the same.

Issue was with the domain and access to the CUCM publisher, during installation CUCM IM&P periodically outputs a message about that it cant access the CUCM publisher by configured IP and name and if you ignore this messages IM&P continues installation and at the end crushes with this problem.

Issue has been solved by creating according PTR records on my DNS server for CUCM publisher, it is bettter to do this records for all nodes (as it says in guides). Also at pre-installation tasks I have configured DNS-client on IM&P pointing my DNS server and domain.

Think this can help some one.

Kirill Muravyev

Justin Brenton
Level 4
Level 4

Hi Sean,

Unfortunately ESXi is required for 8.5+, You can get 8.0 to work in your environment.  You will also need a Intel processor in your ESXi Server.



Hi Sean, Justin

Getting the same issue when installing on EXSi and Intel proc

Did you end up finding a resolution for your issue Sean?

I was unable to get a successful install on my original hardware, so we installed on hardware that met the spec.

Funny thing is that I copied that VM to the box where install failed and was able to run the VM.

Sent from my iPhone


I had the same problem.

Decision: Use FLEXIBLE Network Adaper for VM  - ONLY!

For example, try to find another VM wit flexible Network adapter and clone it.

Dean O'Meara
Level 1
Level 1


Has anyone found a fix for this?

I am trying to run call manager 8.6.1 on the following enviroment

VMware ESXI 4.1

4GB of RAM

80 GB HDD Space

I have allocated the VM one CPU

In regards to vsergeyey reponse I have checked the network adapter and this is flexible.

I have run the OVA template firstly before mounting the image

I have tried installing numerous times.

Each and every time near the "Installing Database Component" I get the following error;

I recently had problems and was able to get CUCM 8.5.1 and 8.6.2a installed by using both VMWare Workstation 7 and VMWare ESX Server 3i.

But the trick for me was to install on a machine with VTX support on the host CPU. One machine was dual core Xeon and the other was an I7 CPU.

Once I did that I could copy the vm to a machine with older processor and run successfully. I am using VMware Server 2.0. I have not tried it on ESXi 4 yet.

Client VM spec was 2 core, 3gb RAM, 80gb drive size (expanding not fixed).

Thanks Sean.

Will give this ago and report back my results.

Hi all,

I've encountered the same issue as this on my own environment and resolved it with the following method by myself:

   -I've replaced the older CPU Intel Core-i7 2600S (Ivy Bridge, LGA1155, TDP65W) with the newer CPU

    Core-i7 3770S on my own hardware.

It would be happy if this information could help anyone troubleshoot it.



Dileep NR
Level 1
Level 1

Hi I faced the similar issue.

Just dont be panic, close the web page and see the progress in Vsphere console tab of the particular sub/Pub. Still you can see the call manager upgrade status bar.

The issue is because, sometimes the server web page stop responding while upgrade. Server shows the last status when it was connected to the server.