cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

2855
Views
0
Helpful
1
Replies
Fred Rawlings
Beginner

LDAP connection error

Hi

I have a 2008 domain controller that I'm trying to configure the LDAP directory with CUCM 8.5, I keep getting the following error message when saving,

Error while Connecting to ldap://xxx.xxx.xxx.xxx:389, null

We do have this setup with another domain controller and it's been working fine, the reason for setting this up on another is because we have another domain that we're going to move everything over

current domain - xy.com

new domain - corp.xy.com

I basically took the current settings from the CUCM with the current domain controller, created a new and copied, replacing the fields with the settings of the new domain controller.

Current settings

LDAP Configuration Name: XY Users AD

LDAP Manager Distinguished Name: CN=Call Manager LDAP Sync,OU=Admins,DC=xy,DC=com

LDAP User Search Base: OU=xy users,DC=xy,DC=com

LDAP Server Information: xxx.xxx.xxx.xxx:389

Settings on the new domain controller

LDAP Configuration Name: Corp XY users AD

LDAP Manager Distinguished Name: CN=Call Manager LDAP Sync,OU=Admins,DC=corp.xy,DC=com

LDAP User Search Base: OU=xy users,DC=corp.xy,DC=com

LDAP Server Information: xxx.xxx.xxx.xxx:389 (IP of the new domain controller)

Did I miss a step anywhere? Any ideas would be greatly appreciated.

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Tommer Catlin
Advocate

Correct me if Im wrong here but:

LDAP User Search Base: OU=xy users,DC=corp.xy,DC=com

Should be:   OU=XY users, DC=CORP, DC=XY, DC=COM

You cant have corp.xy

But, just to double check if you can bind to LDAP using a tool such as Softera:

http://www.ldapbrowser.com/download.htm

You can verify if its a context naming issue or Controller issue or CUCM issue.   I always use Softtera first.  If it works with the bind name and OU, then I go to CUCM and configure it.

View solution in original post

1 REPLY 1
Tommer Catlin
Advocate

Correct me if Im wrong here but:

LDAP User Search Base: OU=xy users,DC=corp.xy,DC=com

Should be:   OU=XY users, DC=CORP, DC=XY, DC=COM

You cant have corp.xy

But, just to double check if you can bind to LDAP using a tool such as Softera:

http://www.ldapbrowser.com/download.htm

You can verify if its a context naming issue or Controller issue or CUCM issue.   I always use Softtera first.  If it works with the bind name and OU, then I go to CUCM and configure it.

View solution in original post

Create
Recognize Your Peers
Content for Community-Ad