cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1601
Views
0
Helpful
6
Replies
Highlighted
Beginner

Unity Connection upgrade 12.5 fails

we are running CUC 10.5 and doing RU upgrade to 12.5, i have installed the ciscocm.cuc_upgrade_12_0_v1.2.k3.cop.sgn and ciscocm.version3-keys.cop.sgn cop files as per the upgrade guide and then started the upgradation of 12.5 but it fails. i have attached the screenshot and  install log.

even though CUC 10.5 is still compatible with CUCM 12.5 and working fine but eventually we have to upgrade to 12.5

any suggestion will be highly appreciated.

 

Regards,

Farrukh

 

 

Everyone's tags (5)
6 REPLIES 6
Highlighted
Beginner

Re: Unity Connection upgrade 12.5 fails

Hi, I did an upgrade from 10.5.2 to 12.5 recently and it was successful.
Just out of curiosity, did you change the OS to CentOS 7 (64-bit) before the upgrade?

Note: If you are upgrading Unity Connection from any earlier version to release 12.5(1),
you must change the Guest Operating System before upgrade.

https://www.cisco.com/c/en/us/td/docs/voice_ip_comm/connection/12x/install_upgrade/guide/b_12xcuciumg.pdf
Highlighted
Beginner

Re: Unity Connection upgrade 12.5 fails

Hi,

 

yes I did change the os to "CentOS 4/5 or later (64bit)" as on current vmtools i do not have the option to select centOS 7 so once it will upgrade then will update the vmtools and then will select it.

 

I have did the same for CUCM and IMP nodes and they have upgraded without any issue.

 

Highlighted
Beginner

Re: Unity Connection upgrade 12.5 fails

Hi,

This is the issue "CentOS 4/5 or later (64bit)"

The Bootloader on Centos 7 is different.
Highlighted
Enthusiast

Re: Unity Connection upgrade 12.5 fails

There are 3 cop files to install (you only listed 2). Did you install "ciscocm.refresh_upgrade.cop" too?

 

This is for 9.x...so nevermind.

Highlighted

Re: Unity Connection upgrade 12.5 fails

hi

 

were you able to solve this problem?

 

thanks.

 

Henrique

Highlighted

Re: Unity Connection upgrade 12.5 fails

if you are having this problem, before the upgrade change the security status to permissive: utils os secure permissive on both pub and sub.