Showing results for 
Search instead for 
Did you mean: 

hyperflex installation doesn't go thru

Level 1
Level 1


I am trying to install Hyper Flex with 3 nodes and use the nested v Center setup. Initially I used v3.0.1e then I was about to connect to Hyper Flex connect for v Center
setup but it prompt me an error that no cluster was created, so I redo again from scratch using the same installer, but I think I am hitting the bug which doesn't allow me to continue, it always have the error at the beginning of validation.
I do not have the way to install v Center externally so i tried a lower Hyper flex installer version. I tried both 2.6.1a and 2.6.1e, it allows me to pass thru the initial
validation, but I always have this error below under DEPLOY. Not sure that is wrong with "Installing Software packages on Storage Controller Virtual Machine"

Can someone interpret to me what does the error I am having? I suspect that it might be because I was able to install successfully with a higher version of es-xi (6.5)
from Hyper flex3.0.1 before then I tried a lower Hyper flex2.6.1a and 2.6.1e but now I am having another issue with Storage controller. What I did was to delete the virtual LAN service profile,
and put the service into factory default mode but still gives me the error when using v2.6.1a and v2.6.1e

Kindly advise me on what should be the solution for this




3 Replies 3

Level 1
Level 1

I ran into the same exact issue as you.  Received bug CSCvk07339 during install of hyperflex when trying an nested vcenter.  Put a fake Vcenter cluster name in.  Install went thru fine, cluster is online and healthy but I also receive "Cluster not created. Please check configuration (100027)"  when trying to log onto HX Connect and create my first datastore.


I have opened a ticket with TAC and will update.

So I was able to find a workaround for this nested vcenter issue before TAC could contact me.   Proceed thru the install and put a fake vcenter cluster name as mentioned in the above BUG ID.  When the install finishes you will not be able to login to HX Connect to create a datastore for VCenter, however you can create one via command line as the cluster (in my case) was online and healthy.

Create a datastore via cli by connecting to the storage cluster vip via ssh, then typing the following command:

stcli datastore create --name VCENTER --size 500 --unit gb


Obviously change the name and size to what you personally need.


Go ahead and deploy VCenter onto this datastore by using one of the hosts.  After you are done follow the official embedded vcenter deployment instructions:


I had one issue when after reregistering the cluster with vcenter that my cluster was in "an invalid state", I simply ran 

stcli cluster start

and my cluster was healthy.   What a pain!!

Level 1
Level 1

In your case you need to clear the storage partitions on the hosts.  You should follow this article to prepare a cluster for reinstall.  Otherwise you will have all sorts of problems.  Everything needs to be back to factory defaults (although you can leave the USCM configuration alone if the networking isn't going to change).


After you wipe everything and get things ready, go ahead and follow my directions above, you will be able to get version 3.01e installed. 

Review Cisco Networking for a $25 gift card