cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
693
Views
1
Helpful
3
Replies

Upgrade from ESXi 6.7 to 7.0 fails on UCS

mbrown-revitycu
Level 1
Level 1

We are attempting to upgrade our current VMWare environment from v6.7 to v7.0U3.

We were able to upgrade vCenter with little trouble.

However, attempting to upgrade our ESXi host - we only have one on this particular hypervisor - has not been as easy.


For reference the information on the hypervisor we are attempting to upgrade:

Hypervisor: VMware ESXi, 6.7.0, 14320388
Model: UCSB-B200-M4
Processor Type: Intel(R) Xeon(R) CPU E5-2630 v4 @ 2.20GHz



When attempting the upgrade from ESXCLI this error is displayed:

VIB Cisco_Systems_Inc._bootbank_ucs-tool-esxi_1.0.1-1OEM requires esx-version < < 6.5.1


This first attempt was made with the offline bundle image found here:

https://customerconnect.vmware.com/en/downloads/details?downloadGroup=ESXI70U3N&productId=974


Further research on our part has led us to believe we should be using the Cisco specific image located here instead:

https://customerconnect.vmware.com/en/downloads/details?downloadGroup=OEM-ESXI70U3-CISCO-FEB08&productId=974


Are we on the right track here?

Thanks.

3 Replies 3

Ruben Cocheno
Spotlight
Spotlight

@mbrown-revitycu 

I recommend to use the Cisco custom version since it should have everything for that platform. You are on track

Tag me to follow up.
Please mark it as Helpful and/or Solution Accepted if that is the case. Thanks for making Engineering easy again.
Connect with me for more on Linkedin https://www.linkedin.com/in/rubencocheno/

Our experience is that once you start using the vendor specific ISO you will run into issues upgrading with the generic ESXi upgrade bundle since the generic upgrade bundle or install ISO don’t contains updated versions of hardware vendor components like ucs-tools. The fix is to use the custom vendor offline bundle, or if you update via vCenter LCM, you can upgrade via a combination of the generic ISO and an extension baseline containing the vendor add-ons, available for 7.0 at https://customerconnect.vmware.com/downloads/details?downloadGroup=ADDON_ESXI70U3_CISCO&productId=974

If you switch from vLCM baselines and baseline groups to image based updates, you don’t even have to download and sideload the vendor add-ons since they are automatically downloaded via the same download repositories that provide ESXi updates. (caveat: Image based updates are an ESXi 7.0 feature, e.g. you can use it to update/upgrade ESXi using images once you are on ESXi 7.0)

mbrown-revitycu
Level 1
Level 1

I ended up using the Cisco specific ISO, and the upgrade went smooth as silk on all four hosts we needed to upgrade. We won't be upgrading beyond 7.0 because these UCS hosts aren't even able to run 8.0 as far as I can tell. The only upgrade we would do would be if they ever release anything beyond 7.0 U3o, and I don't know how likely that is.

Review Cisco Networking for a $25 gift card