Showing results for 
Search instead for 
Did you mean: 

Community Helping Community


Use for UCS-C22-M3?

So I got a hand me down UCS-C22-M3 with 96Gb ram, dual 8 core processors, and 8 300Gb hard drives. It won't run ESX because it only has software RAID. You can't even see the hard drives to boot from them during startup. Software RAID sees the drives just fine, and I can configure virtual disks, but the VD's don't show up during ESX install.


What else can this beast be used for? Some monster SuSE/CentOS dev server for compiling apps? Seems overkill for running a UCS manager.


Thoughts/ideas would be appreciated.


Re: Use for UCS-C22-M3?

No one interested in thoughts on this? Okay.

So I bought a 9240-8i RAID controller and installed it, and disabled the onboard software RAID.

Hooked it up to the 8 drives that were in there before, and which meet the compatibility matrix for the 9240-8i.

LSI WebBios says the drives are unsupported, and Google says this is because of unsupported drives or block sizes, which is not the case.

CMIC Create Virtual drive results in "Error: erro: Invalid device ID / select-timeout", and there is nothing in any documentation about that error code.

So, I'm guessing I have a nice brick for recycling metal, since the UCS-C22-M3 can't actually be used for anything.


Cisco Employee

Re: Use for UCS-C22-M3?

Take a look at the spec sheet for answers to some of your questions:


Screen Shot 2019-08-23 at 1.41.46 PM.pngScreen Shot 2019-08-23 at 1.42.16 PM.png


Can you confirm the hard drives you have installed are on the spec sheet? I would also make sure that the RAID controller firmware is correct to properly recognize the HDD and create RAID.

Re: Use for UCS-C22-M3?

Thanks, Wes.

I have installed the 9240-8i PCIe card (noted as compatible in C22-M3 two lines up from where you took your screenshot), and disabled the embedded RAID.

The hard drives (Seagate ST300MM0006) are the ones that came in the server (and were working before in embedded RAID), and are in the 9240-8i compatibility matrix here:

I used the latest Cisco HUU to update the firmware on the 9240-8i to match the requirements for the C22-M3, going from 20.10.1-0092 to 20.13.1-0255. HUU also indicated that the drive firmware is the latest available.

The disks are seen in LSI's WebBios and in CIMC's Physical Drive info correctly with 512 block size. I checked that just to be sure since I saw people were having problems with it, even though these drives were not purchased on eBay. They were included in the working server, which had SuSE 11 running on it when I got it (JBOD).


The drives are showing up as "Unconfigured Good (Unsupported)" in LSI WebBIOS. Perhaps the firmware that worked for the embedded software RAID doesn't work for the LSI 9240-8i PCIe RAID card. I'll check that next, but this seems highly unlikely.

Re: Use for UCS-C22-M3?

Compatibility list says A001 for firmware on these Seagate drives. HUU updated it to A005.

So now I need to figure out how to downdate (opposite of update??) them to A001, at least to rule out that as the culprit. Fun times.

Cisco Employee

Re: Use for UCS-C22-M3?

What CIMC version are you running? Are you able to open a TAC case and upload logs so we can take a look?

Re: Use for UCS-C22-M3?

CIMC is version 3.0(4l). I'm booting to HUU 1.4.5e as I type this though, to see if the HDD Firmware utility will let me "update" to A001. Will test on one drive only of course, in case I paperweight it. Have spares just in case, but I think they are all at A004 or 5 as well.

My CCO should be attached to the service account for this device still, as it was passed down to me because my client didn't need it anymore, but I think the support for this specific device may have expired already. I'll try to open a TAC case and share the case number here if successful. I can certainly upload logs though.

Re: Use for UCS-C22-M3?

HUU 1.4(5e) is not GUI based like 3.0, and doesn't have an option to update HDD firmware. It doesn't even list them in the inventory.

Re: Use for UCS-C22-M3?

"Contract  200752695 - The contract has been terminated or expired."


No I can't open a TAC case for this device. The contract that provided service for it has expired.

Alright, I'm off to dig into the world of firmware downgrades.

Thanks for your time, Wes.

Re: Use for UCS-C22-M3?

Just in case the 9240-8i I purchased had a bad config from when it was used before, I went into the WebBIOS and set it to factory defaults. When I rescanned the disks, they were all in JBOD mode, instead of "Unconfigured/Good/Unsupported". Then I rebooted. What happened next is beyond my comprehension...

It booted to an EFI Shell. I typed exit, and now I'm sitting at an ESXi 5.5 Hypervisor console. This had SuSE 11sp2 on it before I started tinkering. I tested installing ESXi 6.7u2 on it before I learned that ESXi doesn't work with the embedded RAID controller, which is what lead me to purchase the 9240-8i. That install went fine on JBOD, although the disk I installed to was not bootable so it failed to boot, of course.

I feel like Alice tumbling down the rabbit hole. I hope you are getting a laugh out of this too.


Re: Use for UCS-C22-M3?

Answers... potentially got some answers...

UEFI was the first boot option in the BIOS. I disabled that.

Then I went into CIMC, and lo and behold I discover the Storage is showing a Virtual Drive using two of the disks (1 and 8) and the others are all flagged with "Foreign config", which made me think of the cleaning robot from Wall-E. Why did this happen after booting to the EFI shell and thereby unlocking some mythical ESXi 5.5 server that should not have existed, you might ask? I have no idea.

So, I removed the Virtual Drive, and erased the foreign configs. CIMC now reporting overall server status as Good, with a checkmark.

I then created a RAID-1 with two disks and made it bootable, and used the others for the Datastore array.

Mapped the ESXi 6.7u2 iso to KVM vDVD and began installing ESXi 6.7u2 as originally planned.

Alas, ESXi installer says there are no disks available to install on, so I look back at CIMC and now the two Virtual Drives I created are gone.

This is why we drink. If anyone thinks they are some super-engineer and wants to take this up as a pet project, I'll be glad to take on the Red Queen at your side.

Also, I rebooted and it went to the EFI shell again.

Cisco Employee

Re: Use for UCS-C22-M3?

The deleted drives after install, is symptom of trying to install esxi to a VD created under Mega_SR/software raid/embedded controller.


Am assuming you rewired the SAS backplane port(s) up to the newly inserted 9240 controller's SAS ports, and disabled the software raid mode for embedded controller.   Need to make sure the only option rom loading is for the 9240 controller (should be Cntrl + H) and not the Cntrl + M for software raid.


In CIMC, BIOS/advanced settings, make sure you disable option roms for everything other than the PCI-E slot the 9240 controller is in.



Re: Use for UCS-C22-M3?

Yes, sir. I disabled option ROM for the onboard NICs as well, and disabled the Onboard via the Southbridge settings section in the BIOS. The onboard software RAID options don't startup during POST anymore. I tried everything short of buying older drives with A001 firmware, because I couldn't find any. That's what lead me to post to this community trying to downgrade firmware or find old drives. I also tried using the 1.4.5 HUU to downgrade the firmware, but that version didn't have the hard drive firmware update part. Even if it did, I figure it would indicate that my firmware is newer so I can't do anything. I have another post here chronicling my attempts.

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here