cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1403
Views
10
Helpful
3
Replies

Confusions regarding Voice vlan -panasonic voip phones

ITexpert
Participant
Participant

Hello Guys,

 

I am using cisco 4506 series switch and Panasonic VoIP phones -KX-NT543.  

I believe these phones do not support cdp but do lldp.

 

I configure new vlan 14 on my switch 

int ge5/23

switchport voice vlan 14

switchport mode access

switchport access vlan 1

no shutdown

 

my Voip phone is still getting IP in vlan 1.

I already enable lldp on switch. 

 

Thanks

3 Replies 3

Daniele Giordano
Rising star
Rising star

If I correctly remember voice vlan is passed only via CDP.

My suggestion is tagged voip traffic on the phone and on the switch.

 

 

switch config:

 

switchport mode trunk

switchport trunk allowed vlan 1,14

switchport trunk native vlan 1   (default, not showed)

switchport voice vlan 14   (cdp compatibility, leave it in case of cisco phones)

 

tag voice vlan 14 on the phone

 

Connect PC behind the phone. PC will be in vlan 1, phone in vlan 14.

 

Regards.

Nipun Singh Raghav
Cisco Employee
Cisco Employee
For LLDP, define the vlan within a network policy.
On the interface, reference this policy and enable LLDP TLV to be network policy.
Review the Cat4k admin guide.

Nipun Singh Raghav
"We cannot solve our problems with the same thinking we used when we created them"

Hello @Nipun Singh Raghav @Daniele Giordano 

 

Daniele, I tried but it doesnt work, dont know why.

 

Nipun, Can you please mention the link to follow the procedure.

 

Thanks

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers