cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1783
Views
1
Helpful
16
Replies

problem with fax in as5350xm cisco

zeinab.mahdavi
Beginner
Beginner

 

Hello Everybody ,

 

we want relay fax from as5350xm to the sip server. So,I have configured fax(t38 protocol ) on as5350xm gateway and the Sip server ,

Now the signaling is Properly working , but we  couldn't hear or receive fax tone in fax machine, I'm confused that whether gateway must relay a fax tone to fax machine or our sip server ?

the connection establishment is ,first the IVR is played then we click on start button on the fax machine and nothing could be hear  and then the gateway send the invite fax(t38 SDP) to our sip server , also it receive 200 OK(t38 sdp) and response as ack .

I don't know why the data (fax) couldn't transfer .

Furthermore , the packet that we receive on our Sip Server , is the same as below , but we couldn't interpret it. all of the packet are 172 bytes and ,the following 3 packets are the first three packet that we receive in one call and also followed by many other same packet.

are these special t30 packet format that based on ITU ? 

128 - 8 - 198 - 219 - 10 - 173 - 235 - 34 - 9 - 182 - 20 - 85 - 155 - 20 - 6 - 116 - 135 - 157 - 18 - 7 - 201 - 134 - 148 - 24 - 5 - 227 - 129 - 225 - 4 - 24 - 151 - 134 - 198 - 7 - 18 - 156 - 135 - 112 - 6 - 21 - 154 - 133 - 111 - 6 - 100 - 132 - 158 - 17 - 6 - 93 - 134 - 144 - 31 - 4 - 254 - 129 - 232 - 26 - 26 - 233 - 129 - 249 - 4 - 31 - 144 - 135 - 112 - 7 - 78 - 135 - 226 - 4 - 17 - 152 - 159 - 18 - 5 - 235 - 135 - 120 - 7 - 90 - 135 - 225 - 4 - 23 - 155 - 156 - 29 - 26 - 149 - 132 - 100 - 7 - 87 - 135 - 231 - 4 - 20 - 154 - 156 - 28 - 27 - 151 - 132 - 102 - 7 - 220 - 135 - 251 - 4 - 21 - 133 - 146 - 31 - 24 - 150 - 132 - 99 - 6 - 113 - 135 - 159 - 16 - 6 - 210 - 134 - 150 - 25 - 4 - 228 - 129 - 236 - 5 - 27 - 149 - 134 - 241 - 7 - 28 - 146 - 135 - 67 - 6 - 23 - 152 - 132 - 97 - 6 - 99 - 132 - 152 - 20 - 6 - 72 - 135 - 146 - 29 - 7 - 245 - 134 - 148 - 24 - 5 - 226 - 129 - 230 - 4 - 25 - 150 - 134 - 218

/************************************************************************************************/

128 - 8 - 198 - 220 - 10 - 173 - 235 - 194 - 9 - 182 - 20 - 85 - 7 - 19 - 156 - 135 - 114 - 6 - 106 - 154 - 133 - 111 - 6 - 101 - 132 - 158 - 17 - 6 - 81 - 134 - 144 - 31 - 4 - 248 - 129 - 233 - 26 - 26 - 232 - 134 - 255 - 4 - 31 - 144 - 134 - 92 - 6 - 17 - 153 - 132 - 100 - 6 - 108 - 133 - 155 - 21 - 6 - 112 - 135 - 156 - 18 - 7 - 193 - 134 - 151 - 25 - 4 - 225 - 129 - 227 - 5 - 24 - 148 - 134 - 206 - 7 - 29 - 157 - 135 - 116 - 6 - 20 - 155 - 133 - 109 - 6 - 102 - 132 - 153 - 22 - 6 - 69 - 134 - 147 - 28 - 7 - 243 - 134 - 234 - 26 - 5 - 239 - 129 - 229 - 4 - 30 - 145 - 134 - 214 - 6 - 16 - 159 - 132 - 120 - 6 - 104 - 133 - 154 - 107 - 7 - 210 - 135 - 242 - 7 - 104 - 133 - 147 - 30 - 25 - 145 - 132 - 108 - 7 - 244 - 134 - 241 - 7 - 111 - 133 - 144 - 25 - 30 - 144 - 133 - 105 - 7 - 243 - 134 - 207 - 7 - 109 - 132 - 145 - 24 - 30 - 146 - 133 - 106 - 7 - 254 - 135 - 218 - 7 - 96 - 132 - 150 - 27 - 31 - 157 - 154 - 21 - 7

/************************************************************************************************/

128 - 8 - 198 - 220 - 10 - 173 - 235 - 194 - 9 - 182 - 20 - 85 - 7 - 19 - 156 - 135 - 114 - 6 - 106 - 154 - 133 - 111 - 6 - 101 - 132 - 158 - 17 - 6 - 81 - 134 - 144 - 31 - 4 - 248 - 129 - 233 - 26 - 26 - 232 - 134 - 255 - 4 - 31 - 144 - 134 - 92 - 6 - 17 - 153 - 132 - 100 - 6 - 108 - 133 - 155 - 21 - 6 - 112 - 135 - 156 - 18 - 7 - 193 - 134 - 151 - 25 - 4 - 225 - 129 - 227 - 5 - 24 - 148 - 134 - 206 - 7 - 29 - 157 - 135 - 116 - 6 - 20 - 155 - 133 - 109 - 6 - 102 - 132 - 153 - 22 - 6 - 69 - 134 - 147 - 28 - 7 - 243 - 134 - 234 - 26 - 5 - 239 - 129 - 229 - 4 - 30 - 145 - 134 - 214 - 6 - 16 - 159 - 132 - 120 - 6 - 104 - 133 - 154 - 107 - 7 - 210 - 135 - 242 - 7 - 104 - 133 - 147 - 30 - 25 - 145 - 132 - 108 - 7 - 244 - 134 - 241 - 7 - 111 - 133 - 144 - 25 - 30 - 144 - 133 - 105 - 7 - 243 - 134 - 207 - 7 - 109 - 132 - 145 - 24 - 30 - 146 - 133 - 106 - 7 - 254 - 135 - 218 - 7 - 96 - 132 - 150 - 27 - 31 - 157 - 154 - 21 - 7

/************************************************************************************************/

 

16 Replies 16

Daniele Giordano
Rising star
Rising star

Hi, can you add a "debug ccsip message" of fax call?

Can you add a "debug fax relay t30 all" and the config of your AS?

Regards.

-------------------------------------------------------Config-------------------------------------------------------------------

Cisco#show run
Building configuration...

Current configuration : 4041 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Cisco
!
boot-start-marker
no boot startup-test
boot-end-marker
!
enable secret 5 $1$GQvH$/7LADpw5r7YQrsXB3ARyS.
enable password
!
!
!
resource-pool disable
no aaa new-model
!
resource policy
!
!
!
ip cef
no ip domain lookup
!
!
isdn switch-type primary-net5
!
!
voice service voip
 fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711alaw
 modem passthrough nse codec g711alaw
 sip
  bind control source-interface GigabitEthernet0/0
  bind media source-interface GigabitEthernet0/0
  ds0-num
  header-passing
  registrar server
  no call service stop
!
!
!
!
!
!
!
!
!
!
!
!
voice translation-rule 1
 rule 1 /^199/ //
!
!
voice translation-profile OUT
 translate called 1
!
!
!
!
username pendar secret 5 $1$y/q/$FAhTfd8raw5p4E8N1msKj.
!
!
controller E1 3/0
 pri-group timeslots 1-31
 cablelength medium
!
controller E1 3/1
 framing NO-CRC4
 pri-group timeslots 1-31
 cablelength medium
!
!
!
interface GigabitEthernet0/0
 ip address 172.16.122.38 255.255.255.252
 shutdown
 duplex full
 speed 100
 negotiation auto
!
interface GigabitEthernet0/1
 ip address 217.218.20.88 255.255.255.224
 duplex full
 speed 100
 negotiation auto
!
interface Serial0/0
 no ip address
 shutdown
 clock rate 2000000
 no fair-queue
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial3/0:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn incoming-voice modem 64
 isdn bchan-number-order ascending
 no cdp enable
!
interface Serial3/1:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn incoming-voice modem 64
 isdn supp-service name calling
 isdn bchan-number-order ascending
 no cdp enable
!
interface Group-Async0
 physical-layer async
 no ip address
 encapsulation slip
!
interface Group-Async1
 physical-layer async
 no ip address
 encapsulation slip
!
interface Group-Async21
 physical-layer async
 no ip address
 encapsulation slip
!
ip default-gateway 172.16.122.37
!
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0
ip route 0.0.0.0 0.0.0.0 172.16.122.37
no ip http server
!
!
access-list 101 permit ip any any
dialer-list 1 protocol ip permit
!
!
!
control-plane
!
!
!
voice-port 3/0:D
 disc_pi_off
 output attenuation -6
 echo-cancel coverage 24
 no non-linear
 playout-delay mode fixed
 no comfort-noise
 cptone DE
!
voice-port 3/1:D
 disc_pi_off
 output attenuation -6
 echo-cancel coverage 24
 no non-linear
 playout-delay mode fixed
 no comfort-noise
 cptone DE
!
!
!
dial-peer voice 2 pots
 translation-profile outgoing OUT
 service session
 destination-pattern .+
 no digit-strip
 direct-inward-dial
 port 3/1:D
 forward-digits all
!
dial-peer voice 3 pots
 translation-profile outgoing OUT
 service session
 destination-pattern .+
 no digit-strip
 direct-inward-dial
 port 3/0:D
 forward-digits all
!
dial-peer voice 12 voip
 service session
 destination-pattern .+
 session protocol sipv2
 session target ipv4:217.218.20.86
 session transport udp
 dtmf-relay rtp-nte
 codec g711alaw
 fax-relay sg3-to-g3
 no vad
!
dial-peer voice 13 voip
 service session
 destination-pattern .+
 session protocol sipv2
 session target ipv4:217.218.20.86
 session transport udp
 dtmf-relay h245-signal
 codec g711alaw
 fax-relay sg3-to-g3
 no vad
!
!
sip-ua
 credentials username 1112 password 12495242375C5C550E7A02 realm pendar
 credentials username 1111 password 075E701D1F realm pendar
 authentication username 1112 password 083149400D1817 realm pendar
 no remote-party-id
 no redirection
 srv version 1
 retry bye 1
 retry refer 3
 retry register 10
 timers notify 400
 timers refer 567
 timers register 100
 registrar ipv4:217.218.20.86 expires 60
 sip-server ipv4:217.218.20.86
!
ss7 mtp2-variant Bellcore 0
ss7 mtp2-variant Bellcore 1
ss7 mtp2-variant Bellcore 2
ss7 mtp2-variant Bellcore 3
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 password
 login
!
scheduler allocate 10000 400
end

-----------------------------------------------------debug ccsip message-------------------------------------------

Sent:
INVITE sip:82131000@217.218.20.86:5060 SIP/2.0
Via: SIP/2.0/UDP 217.218.20.88:5060;x-ds0num="ISDN 3/0:D 3/0:DS1 2:DS0";branch=z9hG4bKB450
From: <sip:2188827748@217.218.20.86>;tag=31ECB4-77C
To: <sip:82131000@217.218.20.86>
Date: Mon, 28 Apr 2003 19:09:31 GMT
Call-ID: C644FAB7-78E311D7-8147EB32-2F8E14EF@217.218.20.88
Supported: 100rel,timer,resource-priority,replaces
Min-SE:  1800
Cisco-Guid: 3326328930-2