Showing results for 
Search instead for 
Did you mean: 

UC560 CfwdAll external caller to external number

Level 1
Level 1

Hello All,

I have a UC560 in operation at a remote site and am experiencing difficulty with two functions - one of which is listed in the topic.

The device is using a Telstra SIP trunk, there are no FXO ports in use and no ISDN interface.

Handsets are SPA525G2's.

Inbound and outbound calls work. Call forwarding works internally.

I can set cfwdall on a handset to an external number, and if I call the extension from another internal extension, everything works as expected.

However, if the call to the handset with cfwdall originates from an external number, it is simply dropped.

The debug ccsip message traces tell me that the UC is throwing an error 503, q.850;cause=34, and never attempting to make the outbound call.

Interestingly, it appears to work fine if I transfer an external call to an external number, it just will not function with call forwarding.

This is by far the most critical of the two issues.

The second;

When external calls go unanswered or the line is busy, they are simply dropped.

Internally, the forwarding to voicemail works, but if the call originates from outside it does not.

I am hoping this one is part & parcel of the primary issue.

I have been trying to open a support case with the SMB VOIP support team via phone, however I have spent 2.5hrs on hold - the timer is still ticking away as I write this.

The worst thing is that this site is in the outback, over a thousand kilometers from our office. The logistics of just getting here are mind boggling, and prohibitively expensive. At this stage I have two days left and a fair amount of more mundane issues to resolve.

1 Accepted Solution

Accepted Solutions

Hello Addam,

What are the settings under voice service voip?

Best regards,


View solution in original post

5 Replies 5

Hello Addam,

What are the settings under voice service voip?

Best regards,


^^ This.

'allow-connections SIP to SIP' was the missing entry that was required.

As you were definitely on the right track I've marked this as the answer.

Hello Addam,

I am glad that you have resolved it. Thank you for the feedback and the rating.

Best regards,


Level 1
Level 1


     I am sorry you are having these issues.  As for the callfwdall, it sounds like it is a caller ID issue with the outbound hairpin call.  The original caller ID is being retained and refused by your SIP provider.  To correct this, if you are using CCA, under your outbound dial plan, you will see a caller id tab.  Currently, I would think, the setting is set to "Internal Extensions".  Verify that the setting is set to "Any Number", save and make a test call.  If you are managing the unit with CLI, you would need to adjust your caller ID rule to allow any number.  As for the second issue, we would need to see the inbound number that the provider is sending and if the unit has a DID setup for that number and the call forwards on it. Please call 1-866-606-1866 and get into the UC queue and an engineer will be able to assist you with these issue.  Hopefully, we should be able to get this working as desired in a short time.  Thank you Addam.

James Battisti

The error being thrown was a 503, upon closer inspection being q.850;cause=34.

Essentially the SIP connect was failing and it was trying to fall back to a PSTN trunk and throwing the q.850 error which I believe is from the ISDN standard.

Naturally this means it never tried to make the outgoing call, so nothing to do with caller ID rejection at the provider.

It took me no less than a total of 5 hours on hold to finally get hold of a UC engineer via the Australian 1800 number for SMB. However, once I did, he solved it with commendable speed.

That one setting mentioned in my reply above was the root cause of both the cfwdall error and the voicemail error.